summaryrefslogtreecommitdiff
path: root/packages/mono/files
diff options
context:
space:
mode:
Diffstat (limited to 'packages/mono/files')
-rw-r--r--packages/mono/files/configure-svnr87352.patch21
-rw-r--r--packages/mono/files/genmdesc-cpp.patch22
2 files changed, 43 insertions, 0 deletions
diff --git a/packages/mono/files/configure-svnr87352.patch b/packages/mono/files/configure-svnr87352.patch
new file mode 100644
index 0000000000..021554f35e
--- /dev/null
+++ b/packages/mono/files/configure-svnr87352.patch
@@ -0,0 +1,21 @@
+--- mono/configure.in.orig 2007-10-11 21:05:59.000000000 +0200
++++ mono/configure.in 2007-10-11 23:44:23.000000000 +0200
+@@ -1148,6 +1148,8 @@
+ ], [
+ AC_MSG_RESULT(no)
+ with_tls=pthread
++ ], [
++ AC_MSG_RESULT(yes)
+ ])
+ fi
+
+@@ -1250,6 +1252,9 @@
+ ], [
+ with_sigaltstack=no
+ AC_MSG_RESULT(no)
++ ], [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_WORKING_SIGALTSTACK)
+ ])
+ fi
+
diff --git a/packages/mono/files/genmdesc-cpp.patch b/packages/mono/files/genmdesc-cpp.patch
new file mode 100644
index 0000000000..56eca8effd
--- /dev/null
+++ b/packages/mono/files/genmdesc-cpp.patch
@@ -0,0 +1,22 @@
+--- mono-1.2.5.1/mono/mini/genmdesc.pl.orig 2007-10-03 21:02:07.000000000 +0200
++++ mono-1.2.5.1/mono/mini/genmdesc.pl 2007-10-03 21:06:16.000000000 +0200
+@@ -36,7 +36,9 @@
+ $i++;
+ }
+ close (OPS);
+- my $cpp = "cpp -undef ";
++ my $cpp = $ENV{"CPP"};
++ $cpp = "cpp" unless defined $cpp;
++ $cpp .= " -undef ";
+ foreach (@defines) {
+ $cpp .= " -U$_";
+ $arch_found = 1 if $arch eq $_;
+@@ -44,7 +46,7 @@
+ die "$arch arch is not supported.\n" unless $arch_found;
+
+ $cpp .= " -D$arch $srcdir/mini-ops.h|";
+- #print "Running: $cpp\n";
++ print "Running: $cpp\n";
+ open (OPS, $cpp) || die "Cannot execute cpp: $!";
+ while (<OPS>) {
+ next unless /MINI_OP\s*\(\s*(\S+?)\s*,\s*"(.*?)"/;