summaryrefslogtreecommitdiff
path: root/packages/meta/package-index.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/meta/package-index.bb')
-rw-r--r--packages/meta/package-index.bb21
1 files changed, 5 insertions, 16 deletions
diff --git a/packages/meta/package-index.bb b/packages/meta/package-index.bb
index b28234f17c..842a02a544 100644
--- a/packages/meta/package-index.bb
+++ b/packages/meta/package-index.bb
@@ -1,13 +1,13 @@
DESCRIPTION = "Rebuild the package index"
LICENSE = "MIT"
-PR = "r2"
-
-DEPENDS = "ipkg-utils-native"
+PR = "r3"
INHIBIT_DEFAULT_DEPS = "1"
ALLOW_EMPTY = "1"
PACKAGES = ""
+inherit rootfs_ipk
+
do_fetch() {
}
do_unpack() {
@@ -27,17 +27,6 @@ do_build[nostamp] = "1"
do_build[dirs] = "${DEPLOY_DIR_IPK}"
do_build() {
set -ex
- touch Packages
- ipkg-make-index -r Packages -p Packages -l Packages.filelist -m .
-
- ipkgarchs="${PACKAGE_ARCHS}"
-
- for arch in $ipkgarchs; do
- if [ -e ${DEPLOY_DIR_IPK}/$arch/ ] ; then
- touch ${DEPLOY_DIR_IPK}/$arch/Packages
- ipkg-make-index -r ${DEPLOY_DIR_IPK}/$arch/Packages -p ${DEPLOY_DIR_IPK}/$arch/Packages -l ${DEPLOY_DIR_IPK}/$arch/Packages.filelist -m ${DEPLOY_DIR_IPK}/$arch/
- fi
- done
-
- set +ex
+ rootfs_ipk_do_indexes
+ set +ex
}