summaryrefslogtreecommitdiff
path: root/packages/man
diff options
context:
space:
mode:
Diffstat (limited to 'packages/man')
-rw-r--r--packages/man/man_1.5p.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/man/man_1.5p.bb b/packages/man/man_1.5p.bb
index c666cf6c9c..c6ae5e0e78 100644
--- a/packages/man/man_1.5p.bb
+++ b/packages/man/man_1.5p.bb
@@ -4,6 +4,7 @@ MAINTAINER = "Inge Arnesen <inge.arnesen@gmail.com>"
DESCRIPTION = "The man page suite, including man, apropos, \
and whatis consists of programs that are used to read most \
of the documentation available on a Linux system."
+PR = "r1"
RDEPENDS="less groff"
# Note: The default man.conf uses wrong names for GNU eqn and troff,
# so we install our own
@@ -15,17 +16,20 @@ GS = "-DGREPSILENT=\"q\""
DEFS = "-DUSG -DDO_COMPRESS ${GS}"
do_configure() {
+ # this doesn't support cross compilation, so it generates a
+ # bogus configuration
./configure -d -confdir ${sysconfdir}
}
do_compile() {
+ # this fixes up the cross compilation by killing the bogus DEFS
(cd src; ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
makemsg.c -o makemsg)
oe_runmake 'DEFS=${DEFS}'
}
do_install() {
- oe_runmake 'PREFIX=${D}' install
+ oe_runmake 'PREFIX=${D}' 'DEFS=${DEFS}' install
install -m 644 ${FILESDIR}/man.conf ${D}/etc
}