summaryrefslogtreecommitdiff
path: root/packages/llvm/llvm_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/llvm/llvm_2.4.bb')
-rw-r--r--packages/llvm/llvm_2.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/packages/llvm/llvm_2.4.bb b/packages/llvm/llvm_2.4.bb
index c1ad694ae6..a66d1b376b 100644
--- a/packages/llvm/llvm_2.4.bb
+++ b/packages/llvm/llvm_2.4.bb
@@ -5,12 +5,17 @@ LICENSE = "various"
SRC_URI = "\
http://llvm.org/releases/${PV}/llvm-${PV}.tar.gz \
file://fix-build.patch;patch=1 \
+ file://fix-static-initialization.patch;patch=1 \
"
DEPENDS = "llvm-native"
inherit autotools
+# --enable-debug-runtime disables automatic stripping and lets
+# OE control that
+EXTRA_OECONF += "--enable-debug-runtime --enable-targets=host-only"
+
do_compile() {
# The build wants these binaries, together with the build-fix patch
# they are not compiled again (which would not work).