summaryrefslogtreecommitdiff
path: root/packages/llvm/llvm_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/llvm/llvm_2.4.bb')
-rw-r--r--packages/llvm/llvm_2.4.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/packages/llvm/llvm_2.4.bb b/packages/llvm/llvm_2.4.bb
index d06e4a3f74..c1ad694ae6 100644
--- a/packages/llvm/llvm_2.4.bb
+++ b/packages/llvm/llvm_2.4.bb
@@ -12,14 +12,13 @@ DEPENDS = "llvm-native"
inherit autotools
do_compile() {
- # tblgen doesnt want to link correctly. Pull the one in we have in staging.
+ # The build wants these binaries, together with the build-fix patch
+ # they are not compiled again (which would not work).
+ # Most important aspect is removing BUILD_TARGET_DIRS variable.
install -d Release/Build/bin
cp ${STAGING_BINDIR_NATIVE}/tblgen Release/Build/bin
cp ${STAGING_BINDIR_NATIVE}/fpcmp Release/Build/bin
cp ${STAGING_BINDIR_NATIVE}/llvm-PerfectShuffle Release/Build/bin
- install -d Release/Build/lib
- touch Release/Build/lib/libLLVMSupport.a
- touch Release/Build/lib/libLLVMSystem.a
oe_runmake
}