summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-rp-2.6.24/defconfig-collie10
-rw-r--r--packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch12
-rw-r--r--packages/linux/linux-rp.inc4
-rw-r--r--packages/linux/linux-rp_2.6.24.bb25
-rw-r--r--packages/linux/linux.inc9
5 files changed, 25 insertions, 35 deletions
diff --git a/packages/linux/linux-rp-2.6.24/defconfig-collie b/packages/linux/linux-rp-2.6.24/defconfig-collie
index a29a12de45..b4b1e114d9 100644
--- a/packages/linux/linux-rp-2.6.24/defconfig-collie
+++ b/packages/linux/linux-rp-2.6.24/defconfig-collie
@@ -825,7 +825,7 @@ CONFIG_SPI_MASTER=y
# SPI Master Controller Drivers
#
# CONFIG_SPI_BITBANG is not set
-# CONFIG_SPI_LOCOMO is not set
+CONFIG_SPI_LOCOMO=m
#
# SPI Protocol Masters
@@ -857,8 +857,8 @@ CONFIG_SSB_POSSIBLE=y
CONFIG_MCP=y
CONFIG_MCP_SA11X0=y
CONFIG_MCP_UCB1200=y
-CONFIG_MCP_UCB1200_TS=m
-# CONFIG_MCP_COLLIE_TS is not set
+# CONFIG_MCP_UCB1200_TS is not set
+CONFIG_MCP_COLLIE_TS=m
#
# Multimedia devices
@@ -1014,8 +1014,8 @@ CONFIG_HID=m
# CONFIG_HIDRAW is not set
# CONFIG_USB_SUPPORT is not set
CONFIG_MMC=m
-CONFIG_MMC_DEBUG=y
-CONFIG_MMC_UNSAFE_RESUME=y
+# CONFIG_MMC_DEBUG is not set
+# CONFIG_MMC_UNSAFE_RESUME is not set
#
# MMC/SD Card Drivers
diff --git a/packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch b/packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch
index 3927ffeccf..6fb34ec179 100644
--- a/packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch
+++ b/packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch
@@ -6,8 +6,8 @@ This patch is a bit ugly:
Index: linux-2.6.24/drivers/input/keyboard/sharpsl_rc.c
===================================================================
---- linux-2.6.24.orig/drivers/input/keyboard/sharpsl_rc.c 2008-03-07 20:47:28.000000000 +0000
-+++ linux-2.6.24/drivers/input/keyboard/sharpsl_rc.c 2008-03-07 22:36:40.000000000 +0000
+--- linux-2.6.24.orig/drivers/input/keyboard/sharpsl_rc.c 2008-03-08 19:29:02.000000000 +0000
++++ linux-2.6.24/drivers/input/keyboard/sharpsl_rc.c 2008-03-08 22:23:35.000000000 +0000
@@ -21,12 +21,10 @@
#include <linux/module.h>
#include <linux/slab.h>
@@ -96,11 +96,11 @@ Index: linux-2.6.24/drivers/input/keyboard/sharpsl_rc.c
- reset_scoop_gpio(&REMOTE_SCOOP_DEVICE.dev, REMOTE_AKIN_PULLUP);
-
+ if (machine_is_borzoi() || machine_is_spitz())
-+ reset_scoop_gpio(&platform_scoop_config->devs[1].dev, SPITZ_SCP2_AKIN_PULLUP);
++ reset_scoop_gpio(platform_scoop_config->devs[1].dev, SPITZ_SCP2_AKIN_PULLUP);
+ else if (machine_is_akita())
+ akita_reset_ioexp(&akitaioexp_device.dev, AKITA_IOEXP_AKIN_PULLUP);
+ else
-+ reset_scoop_gpio(&platform_scoop_config->devs[0].dev, CORGI_SCP_AKIN_PULLUP);
++ reset_scoop_gpio(platform_scoop_config->devs[0].dev, CORGI_SCP_AKIN_PULLUP);
mod_timer(&data->rctimer, jiffies + msecs_to_jiffies(RC_POLL_MS));
}
return IRQ_HANDLED;
@@ -110,11 +110,11 @@ Index: linux-2.6.24/drivers/input/keyboard/sharpsl_rc.c
} else {
- set_scoop_gpio(&REMOTE_SCOOP_DEVICE.dev, REMOTE_AKIN_PULLUP);
+ if (machine_is_borzoi() || machine_is_spitz())
-+ set_scoop_gpio(&platform_scoop_config->devs[1].dev, SPITZ_SCP2_AKIN_PULLUP);
++ set_scoop_gpio(platform_scoop_config->devs[1].dev, SPITZ_SCP2_AKIN_PULLUP);
+ else if (machine_is_akita())
+ akita_set_ioexp(&akitaioexp_device.dev, AKITA_IOEXP_AKIN_PULLUP);
+ else
-+ set_scoop_gpio(&platform_scoop_config->devs[0].dev, CORGI_SCP_AKIN_PULLUP);
++ set_scoop_gpio(platform_scoop_config->devs[0].dev, CORGI_SCP_AKIN_PULLUP);
data->handling_press = 0;
}
}
diff --git a/packages/linux/linux-rp.inc b/packages/linux/linux-rp.inc
index a8980ab06e..43747f358d 100644
--- a/packages/linux/linux-rp.inc
+++ b/packages/linux/linux-rp.inc
@@ -58,12 +58,12 @@ module_autoload_snd-soc-poodle_poodle = "snd-soc-poodle"
module_autoload_locomo-spi_collie = "locomo-spi"
module_autoload_mmc_block_collie = "mmc_block"
+module_autoload_mmc_spi = "mmc-spi"
module_autoload_locomokbd_collie = "locomokbd"
module_autoload_sa1100-cs_collie = "sa1100_cs"
module_autoload_collie-ts_collie = "collie-ts"
module_autoload_leds-locomo_collie = "leds-locomo"
-module_autoload_unix_collie = "unix"
-
+module_autoload_power_collie = "power"
do_configure() {
rm -f ${S}/.config
diff --git a/packages/linux/linux-rp_2.6.24.bb b/packages/linux/linux-rp_2.6.24.bb
index 32a3b0544e..a650a31743 100644
--- a/packages/linux/linux-rp_2.6.24.bb
+++ b/packages/linux/linux-rp_2.6.24.bb
@@ -1,6 +1,6 @@
require linux-rp.inc
-PR = "r6"
+PR = "r7"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_collie = "1"
@@ -82,24 +82,23 @@ SRC_URI = "${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
# Disabled until I find the reason this gives issues with cdc_subset
# ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
-# Is anything out of this still needed? Parts were commited to mainline by rmk (drivers/mfd/)
-# (Pavel Machek's git tree has updated versions of this?)
-# ${JLSRC}/zaurus-lcd-2.6.11.diff.gz;patch=1
-# These patches are extracted from Pavel Machek's git tree
-# (diff against vanilla kernel)
SRC_URI_append_collie = "\
- ${TKSRC}/mtd-sharp-flash-hack-r3.patch;patch=1 \
+ ${TKSRC}/mtd-sharp-flash-hack-r4.patch;patch=1 \
${TKSRC}/mcp-sa11x0-r0.patch;patch=1 \
- ${TKSRC}/locomo-r0.patch;patch=1 \
-# ${TKSRC}/locomo_spi-4.patch;patch=1 \
- ${TKSRC}/collie-kexec.patch;patch=1 \
- ${TKSRC}/sharpsl_pm-3.patch;patch=1 \
- ${TKSRC}/collie_pm-2.patch;patch=1 \
- ${TKSRC}/locomokeyb_suspendkey-2.patch;patch=1 \
+ ${TKSRC}/locomo-r1.patch;patch=1 \
+ ${TKSRC}/collie-kexec-r1.patch;patch=1 \
+ ${TKSRC}/sharpsl_pm-4.patch;patch=1 \
+ ${TKSRC}/collie_pm-3.patch;patch=1 \
${TKSRC}/ucb1x00_suspend.patch;patch=1 \
${TKSRC}/collie-ts.patch;patch=1 \
${TKSRC}/pcmcia_suspend.patch;patch=1 \
+ ${TKSRC}/locomo_spi-6.patch;patch=1 \
+ ${TKSRC}/config.patch;patch=1 \
+ ${TKSRC}/locomokeyb.patch;patch=1 \
+ ${TKSRC}/mmc-spi.patch;patch=1 \
+ ${TKSRC}/linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
+ ${TKSRC}/sa1100_spinlock.patch;patch=1 \
"
SRC_URI_append_poodle = "\
diff --git a/packages/linux/linux.inc b/packages/linux/linux.inc
index e46061610d..ad7071c405 100644
--- a/packages/linux/linux.inc
+++ b/packages/linux/linux.inc
@@ -90,17 +90,8 @@ do_configure_append_avr32() {
sed -i -e s:-mno-pic::g arch/avr32/Makefile
}
-
-UBOOT_ENTRYPOINT ?= "20008000"
-UBOOT_LOADADDRESS ?= "${UBOOT_ENTRYPOINT}"
-
do_compile_append() {
if test "x${KERNEL_IMAGETYPE}" = "xuImage" ; then
- if test "x${ARCH}" = "xpowerpc" ; then
- UBOOT_ARCH=ppc
- else
- UBOOT_ARCH=$ARCH
- fi
if test -e arch/${ARCH}/boot/compressed/vmlinux ; then
${OBJCOPY} -O binary -R .note -R .comment -S arch/${ARCH}/boot/compressed/vmlinux linux.bin
uboot-mkimage -A ${UBOOT_ARCH} -O linux -T kernel -C none -a ${UBOOT_LOADADDRESS} -e ${UBOOT_ENTRYPOINT} -n "${DISTRO_NAME}/${PV}/${MACHINE}" -d linux.bin arch/${ARCH}/boot/uImage