summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.21/defconfig2
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.21.6.bb2
-rw-r--r--packages/linux/linux-omap1.inc13
3 files changed, 5 insertions, 12 deletions
diff --git a/packages/linux/ixp4xx-kernel/2.6.21/defconfig b/packages/linux/ixp4xx-kernel/2.6.21/defconfig
index 56474d512a..0fbb58a561 100644
--- a/packages/linux/ixp4xx-kernel/2.6.21/defconfig
+++ b/packages/linux/ixp4xx-kernel/2.6.21/defconfig
@@ -885,7 +885,7 @@ CONFIG_TUN=m
CONFIG_NET_ETHERNET=y
CONFIG_MII=m
CONFIG_IXP4XX_QMGR=m
-CONFIG_IXP4XX_NPE=m
+CONFIG_IXP4XX_NPE=y
CONFIG_IXP4XX_NPE_FW_LOAD=y
CONFIG_IXP4XX_NPE_FW_MTD=y
CONFIG_IXP4XX_MAC=m
diff --git a/packages/linux/ixp4xx-kernel_2.6.21.6.bb b/packages/linux/ixp4xx-kernel_2.6.21.6.bb
index ff90bcb3b3..b0ba8ba787 100644
--- a/packages/linux/ixp4xx-kernel_2.6.21.6.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.21.6.bb
@@ -6,7 +6,7 @@
# http://trac.nslu2-linux.org/kernel/
#
# The revision that is pulled from SVN is specified below
-IXP4XX_KERNEL_SVN_REV = "914"
+IXP4XX_KERNEL_SVN_REV = "915"
#
# The directory containing the patches to be applied is
# specified below
diff --git a/packages/linux/linux-omap1.inc b/packages/linux/linux-omap1.inc
index ac7d398122..e2b168e454 100644
--- a/packages/linux/linux-omap1.inc
+++ b/packages/linux/linux-omap1.inc
@@ -7,8 +7,7 @@ COMPATIBLE_MACHINE = "omap5912osk"
inherit kernel
-KERNEL_IMAGETYPE = "vmlinux"
-KERNEL_OUTPUT = "${KERNEL_IMAGETYPE}"
+KERNEL_IMAGETYPE = "uImage"
module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
@@ -22,15 +21,9 @@ do_configure_prepend() {
oe_runmake oldconfig
}
-
do_deploy() {
- if [ "${MACHINE}" == "omap5912osk" ]; then
- install -d ${DEPLOY_DIR_IMAGE}
- ${OBJCOPY} -O binary -R .note -R .comment -S ${KERNEL_OUTPUT} ${S}/linux.bin
- gzip -f -9 ${S}/linux.bin
- mkimage -A arm -O linux -T kernel -C gzip -a 0x10008000 -e 0x10008000 -n "OE" -d ${S}/linux.bin.gz ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${KERNEL_VERSION}-${MACHINE}-${DATETIME}.bin
- rm ${S}/linux.bin.gz
- fi
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
}
do_deploy[dirs] = "${S}"