summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-openzaurus-2.6.15/defconfig-c7x023
-rw-r--r--packages/linux/linux-openzaurus-2.6.15/defconfig-collie23
-rw-r--r--packages/linux/linux-openzaurus-2.6.15/defconfig-cxx0030
-rw-r--r--packages/linux/linux-openzaurus-2.6.15/defconfig-ipaq-pxa27024
-rw-r--r--packages/linux/linux-openzaurus-2.6.15/defconfig-poodle24
-rw-r--r--packages/linux/linux-openzaurus-2.6.15/defconfig-tosa23
-rw-r--r--packages/linux/linux-openzaurus_2.6.15.bb9
7 files changed, 149 insertions, 7 deletions
diff --git a/packages/linux/linux-openzaurus-2.6.15/defconfig-c7x0 b/packages/linux/linux-openzaurus-2.6.15/defconfig-c7x0
index fa298f2ab8..e6363bba62 100644
--- a/packages/linux/linux-openzaurus-2.6.15/defconfig-c7x0
+++ b/packages/linux/linux-openzaurus-2.6.15/defconfig-c7x0
@@ -1363,6 +1363,29 @@ CONFIG_MMC_PXA=y
# CONFIG_MMC_WBSD is not set
#
+# Real Time Clock
+#
+CONFIG_RTC_CLASS=y
+CONFIG_RTC_HCTOSYS=y
+CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
+
+#
+# RTC interfaces
+#
+CONFIG_RTC_INTF_SYSFS=y
+CONFIG_RTC_INTF_PROC=y
+CONFIG_RTC_INTF_DEV=y
+
+#
+# RTC drivers
+#
+# CONFIG_RTC_DRV_X1205 is not set
+# CONFIG_RTC_DRV_DS1672 is not set
+# CONFIG_RTC_DRV_PCF8563 is not set
+CONFIG_RTC_DRV_SA1100=y
+# CONFIG_RTC_DRV_TEST is not set
+
+#
# File systems
#
CONFIG_EXT2_FS=y
diff --git a/packages/linux/linux-openzaurus-2.6.15/defconfig-collie b/packages/linux/linux-openzaurus-2.6.15/defconfig-collie
index cbe06f9c3a..0a8bbbd914 100644
--- a/packages/linux/linux-openzaurus-2.6.15/defconfig-collie
+++ b/packages/linux/linux-openzaurus-2.6.15/defconfig-collie
@@ -791,6 +791,29 @@ CONFIG_USB_GADGET=y
# CONFIG_MMC is not set
#
+# Real Time Clock
+#
+CONFIG_RTC_CLASS=y
+CONFIG_RTC_HCTOSYS=y
+CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
+
+#
+# RTC interfaces
+#
+CONFIG_RTC_INTF_SYSFS=y
+CONFIG_RTC_INTF_PROC=y
+CONFIG_RTC_INTF_DEV=y
+
+#
+# RTC drivers
+#
+# CONFIG_RTC_DRV_X1205 is not set
+# CONFIG_RTC_DRV_DS1672 is not set
+# CONFIG_RTC_DRV_PCF8563 is not set
+CONFIG_RTC_DRV_SA1100=y
+# CONFIG_RTC_DRV_TEST is not set
+
+#
# File systems
#
CONFIG_EXT2_FS=y
diff --git a/packages/linux/linux-openzaurus-2.6.15/defconfig-cxx00 b/packages/linux/linux-openzaurus-2.6.15/defconfig-cxx00
index 9941367a3b..65ad9227cc 100644
--- a/packages/linux/linux-openzaurus-2.6.15/defconfig-cxx00
+++ b/packages/linux/linux-openzaurus-2.6.15/defconfig-cxx00
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.15-rc7
-# Mon Jan 2 09:25:11 2006
+# Linux kernel version: 2.6.15
+# Sun Feb 5 23:30:47 2006
#
CONFIG_ARM=y
CONFIG_MMU=y
@@ -882,7 +882,7 @@ CONFIG_UNIX98_PTYS=y
#
# CONFIG_WATCHDOG is not set
# CONFIG_NVRAM is not set
-CONFIG_SA1100_RTC=y
+# CONFIG_RTC is not set
# CONFIG_DTLK is not set
# CONFIG_R3964 is not set
@@ -968,6 +968,7 @@ CONFIG_NEW_LEDS=y
CONFIG_LEDS_CLASS=y
CONFIG_LEDS_TRIGGERS=y
CONFIG_LEDS_SPITZ=y
+# CONFIG_LEDS_TOSA is not set
CONFIG_LEDS_TRIGGER_TIMER=y
#
@@ -1328,6 +1329,29 @@ CONFIG_MMC_PXA=y
# CONFIG_MMC_WBSD is not set
#
+# Real Time Clock
+#
+CONFIG_RTC_CLASS=y
+CONFIG_RTC_HCTOSYS=y
+CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
+
+#
+# RTC interfaces
+#
+CONFIG_RTC_INTF_SYSFS=y
+CONFIG_RTC_INTF_PROC=y
+CONFIG_RTC_INTF_DEV=y
+
+#
+# RTC drivers
+#
+# CONFIG_RTC_DRV_X1205 is not set
+# CONFIG_RTC_DRV_DS1672 is not set
+# CONFIG_RTC_DRV_PCF8563 is not set
+CONFIG_RTC_DRV_SA1100=y
+# CONFIG_RTC_DRV_TEST is not set
+
+#
# File systems
#
CONFIG_EXT2_FS=y
diff --git a/packages/linux/linux-openzaurus-2.6.15/defconfig-ipaq-pxa270 b/packages/linux/linux-openzaurus-2.6.15/defconfig-ipaq-pxa270
index d826d06886..2503332093 100644
--- a/packages/linux/linux-openzaurus-2.6.15/defconfig-ipaq-pxa270
+++ b/packages/linux/linux-openzaurus-2.6.15/defconfig-ipaq-pxa270
@@ -763,6 +763,29 @@ CONFIG_MMC_PXA=y
# CONFIG_MMC_WBSD is not set
#
+# Real Time Clock
+#
+CONFIG_RTC_CLASS=y
+CONFIG_RTC_HCTOSYS=y
+CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
+
+#
+# RTC interfaces
+#
+CONFIG_RTC_INTF_SYSFS=y
+CONFIG_RTC_INTF_PROC=y
+CONFIG_RTC_INTF_DEV=y
+
+#
+# RTC drivers
+#
+# CONFIG_RTC_DRV_X1205 is not set
+# CONFIG_RTC_DRV_DS1672 is not set
+# CONFIG_RTC_DRV_PCF8563 is not set
+CONFIG_RTC_DRV_SA1100=y
+# CONFIG_RTC_DRV_TEST is not set
+
+#
# File systems
#
CONFIG_EXT2_FS=y
@@ -992,3 +1015,4 @@ CONFIG_CRC32=y
CONFIG_LIBCRC32C=y
CONFIG_ZLIB_INFLATE=y
CONFIG_ZLIB_DEFLATE=y
+
diff --git a/packages/linux/linux-openzaurus-2.6.15/defconfig-poodle b/packages/linux/linux-openzaurus-2.6.15/defconfig-poodle
index 3f6f49c5bf..7fdc6fadf3 100644
--- a/packages/linux/linux-openzaurus-2.6.15/defconfig-poodle
+++ b/packages/linux/linux-openzaurus-2.6.15/defconfig-poodle
@@ -1286,6 +1286,29 @@ CONFIG_MMC_PXA=y
# CONFIG_MMC_WBSD is not set
#
+# Real Time Clock
+#
+CONFIG_RTC_CLASS=y
+CONFIG_RTC_HCTOSYS=y
+CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
+
+#
+# RTC interfaces
+#
+CONFIG_RTC_INTF_SYSFS=y
+CONFIG_RTC_INTF_PROC=y
+CONFIG_RTC_INTF_DEV=y
+
+#
+# RTC drivers
+#
+# CONFIG_RTC_DRV_X1205 is not set
+# CONFIG_RTC_DRV_DS1672 is not set
+# CONFIG_RTC_DRV_PCF8563 is not set
+CONFIG_RTC_DRV_SA1100=y
+# CONFIG_RTC_DRV_TEST is not set
+
+#
# File systems
#
CONFIG_EXT2_FS=y
@@ -1533,3 +1556,4 @@ CONFIG_CRC32=y
CONFIG_LIBCRC32C=m
CONFIG_ZLIB_INFLATE=y
CONFIG_ZLIB_DEFLATE=y
+
diff --git a/packages/linux/linux-openzaurus-2.6.15/defconfig-tosa b/packages/linux/linux-openzaurus-2.6.15/defconfig-tosa
index 14acb3c56c..a52fc2f457 100644
--- a/packages/linux/linux-openzaurus-2.6.15/defconfig-tosa
+++ b/packages/linux/linux-openzaurus-2.6.15/defconfig-tosa
@@ -1269,6 +1269,29 @@ CONFIG_MMC_PXA=y
# CONFIG_MMC_WBSD is not set
#
+# Real Time Clock
+#
+CONFIG_RTC_CLASS=y
+CONFIG_RTC_HCTOSYS=y
+CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
+
+#
+# RTC interfaces
+#
+CONFIG_RTC_INTF_SYSFS=y
+CONFIG_RTC_INTF_PROC=y
+CONFIG_RTC_INTF_DEV=y
+
+#
+# RTC drivers
+#
+# CONFIG_RTC_DRV_X1205 is not set
+# CONFIG_RTC_DRV_DS1672 is not set
+# CONFIG_RTC_DRV_PCF8563 is not set
+CONFIG_RTC_DRV_SA1100=y
+# CONFIG_RTC_DRV_TEST is not set
+
+#
# File systems
#
CONFIG_EXT2_FS=y
diff --git a/packages/linux/linux-openzaurus_2.6.15.bb b/packages/linux/linux-openzaurus_2.6.15.bb
index 24d346298a..fac29e5c61 100644
--- a/packages/linux/linux-openzaurus_2.6.15.bb
+++ b/packages/linux/linux-openzaurus_2.6.15.bb
@@ -1,6 +1,6 @@
include linux-openzaurus.inc
-PR = "r3"
+PR = "r4"
# Handy URLs
# git://rsync.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git \
@@ -21,6 +21,8 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.15.tar.bz2 \
${RPSRC}/scoop_cpr_fix-r1.patch;patch=1 \
${RPSRC}/pxa2xx_release-r1.patch;patch=1 \
${RPSRC}/arm_apm_pm_legacy-r1.patch;patch=1 \
+ ${RPSRC}/arm_checksum_memory-r0.patch;patch=1 \
+ ${RPSRC}/pxa_clocks-r0.patch;patch=1 \
${RPSRC}/ide_not_removable-r0.patch;patch=1 \
${RPSRC}/sharpsl_pm_move-r0.patch;patch=1 \
${RPSRC}/sharpsl_pm_gcc4_fix-r0.patch;patch=1 \
@@ -37,7 +39,8 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.15.tar.bz2 \
${RPSRC}/led_nand-r2.patch;patch=1 \
${RPSRC}/ide_end_request-r0.patch;patch=1 \
${RPSRC}/pxa_timerfix-r0.patch;patch=1 \
- ${RPSRC}/pxa_rtc-r3.patch;patch=1 \
+ ${RPSRC}/rtc_class-r0.patch;patch=1 \
+ ${RPSRC}/rtc_class_pxa-r0.patch;patch=1 \
${RPSRC}/input_power-r4.patch;patch=1 \
${RPSRC}/jffs2_longfilename-r0.patch;patch=1 \
${RPSRC}/pxa25x_cpufreq-r0.patch;patch=1 \
@@ -68,9 +71,7 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.15.tar.bz2 \
${RPSRC}/zaurus_keyboard_tweak-r0.patch;patch=1 \
${RPSRC}/corgi_bl_cleanup-r2.patch;patch=1 \
${RPSRC}/corgi_bl_generic-r2.patch;patch=1 \
- ${RPSRC}/arm_checksum_memory-r0.patch;patch=1 \
${RPSRC}/pxafb_tweaks-r0.patch;patch=1 \
- ${RPSRC}/pxa_clocks-r0.patch;patch=1 \
${RPSRC}/pm_changes-r0.patch;patch=1 \
${RPSRC}/sharpsl_pm-do-r2.patch;patch=1 \
file://add-oz-release-string.patch;patch=1 \