summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-geodegx_2.4.24.bb2
-rw-r--r--packages/linux/nslu2-kernel_2.6.12.2.bb2
-rw-r--r--packages/linux/openslug-kernel-2.6.12.2/defconfig37
3 files changed, 36 insertions, 5 deletions
diff --git a/packages/linux/linux-geodegx_2.4.24.bb b/packages/linux/linux-geodegx_2.4.24.bb
index 0cc97f4842..605a36e49a 100644
--- a/packages/linux/linux-geodegx_2.4.24.bb
+++ b/packages/linux/linux-geodegx_2.4.24.bb
@@ -6,7 +6,7 @@ KV = "2.4.24"
DESCRIPTION = "Linux kernel for the AMD Geode GX processor"
LICENSE = "GPL"
-SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/2.4/linux-${KV}.tar.bz2 \
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
http://www.amd.com/files/connectivitysolutions/geode/Patches_Linux_${KV}_1.00.tar.gz \
file://${WORKDIR}/Patches_Linux_${KV}_1.00/linux-${KV}-geode.patch;patch=1 \
file://linux-2.4.24-gcc340-fixes.patch;patch=1 \
diff --git a/packages/linux/nslu2-kernel_2.6.12.2.bb b/packages/linux/nslu2-kernel_2.6.12.2.bb
index 6fbb5d02ae..d72015c29a 100644
--- a/packages/linux/nslu2-kernel_2.6.12.2.bb
+++ b/packages/linux/nslu2-kernel_2.6.12.2.bb
@@ -1,5 +1,5 @@
# Kernel for NSLU2
-PR = "r3"
+PR = "r4"
include nslu2-kernel.inc
# N2K_EXTRA_PATCHES - list of patches to apply (can include
diff --git a/packages/linux/openslug-kernel-2.6.12.2/defconfig b/packages/linux/openslug-kernel-2.6.12.2/defconfig
index eb5be45af5..ba3744e2f5 100644
--- a/packages/linux/openslug-kernel-2.6.12.2/defconfig
+++ b/packages/linux/openslug-kernel-2.6.12.2/defconfig
@@ -618,12 +618,30 @@ CONFIG_NETCONSOLE=m
#
# Input device support
#
-# CONFIG_INPUT is not set
+CONFIG_INPUT=m
+
+#
+# Userland interfaces
+#
+CONFIG_INPUT_MOUSEDEV=n
+# CONFIG_INPUT_JOYDEV is not set
+# CONFIG_INPUT_TSDEV is not set
+# CONFIG_INPUT_EVDEV is not set
+# CONFIG_INPUT_EVBUG is not set
+
+#
+# Input Device Drivers
+#
+CONFIG_INPUT_KEYBOARD=n
+CONFIG_INPUT_MOUSE=n
+# CONFIG_INPUT_JOYSTICK is not set
+# CONFIG_INPUT_TOUCHSCREEN is not set
+# CONFIG_INPUT_MISC is not set
#
# Hardware I/O ports
#
-# CONFIG_SERIO is not set
+CONFIG_SERIO=n
# CONFIG_GAMEPORT is not set
#
@@ -903,11 +921,24 @@ CONFIG_USB_STORAGE=y
#
# USB Input Devices
#
-# CONFIG_USB_HID is not set
+CONFIG_USB_HID=m
+CONFIG_USB_HIDINPUT=y
+# CONFIG_HID_FF is not set
+CONFIG_USB_HIDDEV=y
#
# USB HID Boot Protocol drivers
#
+# CONFIG_USB_KBD is not set
+# CONFIG_USB_MOUSE is not set
+# CONFIG_USB_AIPTEK is not set
+# CONFIG_USB_WACOM is not set
+# CONFIG_USB_KBTAB is not set
+# CONFIG_USB_POWERMATE is not set
+# CONFIG_USB_MTOUCH is not set
+# CONFIG_USB_EGALAX is not set
+# CONFIG_USB_XPAD is not set
+# CONFIG_USB_ATI_REMOTE is not set
#
# USB Imaging devices