summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-2.6.28/stb225/uImage.patch23
-rw-r--r--packages/linux/linux_2.6.28.bb3
2 files changed, 25 insertions, 1 deletions
diff --git a/packages/linux/linux-2.6.28/stb225/uImage.patch b/packages/linux/linux-2.6.28/stb225/uImage.patch
new file mode 100644
index 0000000000..f43a221e62
--- /dev/null
+++ b/packages/linux/linux-2.6.28/stb225/uImage.patch
@@ -0,0 +1,23 @@
+diff -urN linux-2.6.28.orig/arch/mips/Makefile linux-2.6.28/arch/mips/Makefile
+--- linux-2.6.28.orig/arch/mips/Makefile 2009-01-28 16:12:23.000000000 +0200
++++ linux-2.6.28/arch/mips/Makefile 2009-01-28 16:13:54.000000000 +0200
+@@ -682,6 +682,19 @@
+
+ all: $(all-y)
+
++# Support for U-Boot image creation (from U-Boot README)
++uImage: vmlinux
++ $(OBJCOPY) -O binary -R .note -R .comment -S vmlinux vmlinux.bin
++ rm -f vmlinux.bin.gz
++ gzip -9 vmlinux.bin
++ LA=`$(OBJDUMP) -p vmlinux | sed -n 's/LOAD.*vaddr \([^ ]*\).*/\1/p'`; \
++ EN=`$(OBJDUMP) -f vmlinux | sed -n 's/.*start address \([^ ]*\).*/\1/p'`; \
++ echo $$LA; \
++ echo $$EN; \
++ mkimage -A mips -O linux -T kernel -C gzip \
++ -a $$LA -e $$EN -n "Linux Kernel Image" \
++ -d vmlinux.bin.gz uImage
++
+ vmlinux.bin: $(vmlinux-32)
+ +@$(call makeboot,$@)
+
diff --git a/packages/linux/linux_2.6.28.bb b/packages/linux/linux_2.6.28.bb
index e37ab9d013..393209c3be 100644
--- a/packages/linux/linux_2.6.28.bb
+++ b/packages/linux/linux_2.6.28.bb
@@ -16,6 +16,7 @@ SRC_URI_append_at91sam9263ek = " \
file://linux-2.6.28-exp.patch.bz2;patch=1 "
SRC_URI_append_stb225 = " \
+ file://uImage.patch;patch=1 \
file://ebase-fix.patch;patch=1 \
file://enable-uart.patch;patch=1 \
- file://ip3902.patch;patch=1 "
+ file://ip3902.patch;patch=1"