summaryrefslogtreecommitdiff
path: root/packages/linux/nslu2-kernel/2.6.14
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/nslu2-kernel/2.6.14')
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/19-jffs2-force-be.patch13
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch83
2 files changed, 50 insertions, 46 deletions
diff --git a/packages/linux/nslu2-kernel/2.6.14/19-jffs2-force-be.patch b/packages/linux/nslu2-kernel/2.6.14/19-jffs2-force-be.patch
new file mode 100644
index 0000000000..4406d17857
--- /dev/null
+++ b/packages/linux/nslu2-kernel/2.6.14/19-jffs2-force-be.patch
@@ -0,0 +1,13 @@
+--- linux-2.6.14.1/fs/jffs2/nodelist.h.orig 2005-11-09 23:12:29.641449728 -0800
++++ linux-2.6.14.1/fs/jffs2/nodelist.h 2005-11-09 23:13:19.228570049 -0800
+@@ -44,7 +44,9 @@
+ #define D2(x)
+ #endif
+
+-#define JFFS2_NATIVE_ENDIAN
++#undef JFFS2_NATIVE_ENDIAN
++#define JFFS2_BIG_ENDIAN 1
++#undef JFFS2_LITTLE_ENDIAN
+
+ /* Note we handle mode bits conversion from JFFS2 (i.e. Linux) to/from
+ whatever OS we're actually running on here too. */
diff --git a/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch b/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
index 7d15e75ed4..038c71c3b3 100644
--- a/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
+++ b/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
@@ -1,39 +1,33 @@
---- linux-2.6.13/arch/arm/boot/compressed/head.S 2005-08-28 16:41:01.000000000 -0700
-+++ linux-2.6.13/arch/arm/boot/compressed/head.S 2005-10-26 15:23:39.646352497 -0700
-@@ -37,6 +37,7 @@
- defined(CONFIG_ARCH_INTEGRATOR) || \
- defined(CONFIG_ARCH_PXA) || \
- defined(CONFIG_ARCH_IXP4XX) || \
-+ defined(CONFIG_MACH_NSLU2) || \
- defined(CONFIG_ARCH_IXP2000) || \
- defined(CONFIG_ARCH_LH7A40X) || \
- defined(CONFIG_ARCH_OMAP)
---- linux-2.6.13/arch/arm/mach-ixp4xx/Kconfig 2005-08-28 16:41:01.000000000 -0700
-+++ linux-2.6.13/arch/arm/mach-ixp4xx/Kconfig 2005-10-26 15:23:39.646352497 -0700
-@@ -43,6 +43,12 @@ config MACH_IXDP465
- IXDP465 Development Platform (Also known as BMP).
- For more information on this platform, see <file:Documentation/arm/IXP4xx>.
+--- linux-2.6.14/arch/arm/mach-ixp4xx/Kconfig 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.14/arch/arm/mach-ixp4xx/Kconfig 1970-01-01 00:00:00.000000000 +0000
+@@ -8,6 +8,16 @@ menu "Intel IXP4xx Implementation Option
-+config MACH_NSLU2
-+ bool "NSLU2"
-+ help
-+ Say 'Y' here if you want your kernel to support Linksys's
-+ NSLU2 NAS device. For more information on this platform,
-+ see http://www.nslu2-linux.org
+ comment "IXP4xx Platforms"
- #
- # IXCDP1100 is the exact same HW as IXDP425, but with a different machine
---- linux-2.6.13/arch/arm/mach-ixp4xx/Makefile 2005-08-28 16:41:01.000000000 -0700
-+++ linux-2.6.13/arch/arm/mach-ixp4xx/Makefile 2005-10-26 15:23:39.646352497 -0700
++# This entry is placed on top because otherwise it would have
++# been shown as a submenu.
++config MACH_NSLU2
++ bool
++ prompt "NSLU2" if !(MACH_IXDP465 || MACH_IXDPG425 || ARCH_IXDP425 || ARCH_ADI_COYOTE || ARCH_AVILA || ARCH_IXCDP1100 || ARCH_PRPMC1100 || MACH_GTWX5715)
++ help
++ Say 'Y' here if you want your kernel to support Linksys's
++ NSLU2 NAS device. For more information on this platform,
++ see http://www.nslu2-linux.org
++
+ config ARCH_AVILA
+ bool "Avila"
+ help
+--- linux-2.6.14/arch/arm/mach-ixp4xx/Makefile 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.14/arch/arm/mach-ixp4xx/Makefile 1970-01-01 00:00:00.000000000 +0000
@@ -8,4 +8,5 @@ obj-$(CONFIG_ARCH_IXDP4XX) += ixdp425-pc
obj-$(CONFIG_MACH_IXDPG425) += ixdpg425-pci.o coyote-setup.o
obj-$(CONFIG_ARCH_ADI_COYOTE) += coyote-pci.o coyote-setup.o
obj-$(CONFIG_MACH_GTWX5715) += gtwx5715-pci.o gtwx5715-setup.o
+obj-$(CONFIG_MACH_NSLU2) += nslu2-pci.o nslu2-setup.o nslu2-power.o
---- linux-2.6.13/arch/arm/mach-ixp4xx/nslu2-pci.c 2005-10-26 15:19:43.171472071 -0700
-+++ linux-2.6.13/arch/arm/mach-ixp4xx/nslu2-pci.c 2005-10-26 15:23:39.646352497 -0700
-@@ -0,0 +1,78 @@
+--- linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-pci.c 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-pci.c 1970-01-01 00:00:00.000000000 +0000
+@@ -0,0 +1,77 @@
+/*
+ * arch/arm/mach-ixp4xx/nslu2-pci.c
+ *
@@ -87,8 +81,7 @@
+
+ if (slot >= 1 && slot <= NSLU2_PCI_MAX_DEV &&
+ pin >= 1 && pin <= NSLU2_PCI_IRQ_LINES) {
-+ irq = pci_irq_table[
-+ (slot + pin - 2) % NSLU2_PCI_IRQ_LINES];
++ irq = pci_irq_table[(slot + pin - 2) % NSLU2_PCI_IRQ_LINES];
+ }
+
+ return irq;
@@ -112,9 +105,9 @@
+}
+
+subsys_initcall(nslu2_pci_init);
---- linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-power.c 2005-09-06 00:17:15.000000000 -0700
-+++ linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-power.c 2005-10-28 15:50:43.554157030 -0700
-@@ -0,0 +1,94 @@
+--- linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-power.c 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-power.c 1970-01-01 00:00:00.000000000 +0000
+@@ -0,0 +1,92 @@
+/*
+ * arch/arm/mach-ixp4xx/nslu2-power.c
+ *
@@ -122,7 +115,7 @@
+ *
+ * Copyright (C) 2005 Tower Technologies
+ *
-+ * based on nslu2-io.c
++ * based on nslu2-io.c
+ * Copyright (C) 2004 Karen Spearel
+ *
+ * Author: Alessandro Zummo <a.zummo@towertech.it>
@@ -166,8 +159,6 @@
+ if (!(machine_is_nslu2()))
+ return 0;
+
-+ printk(KERN_INFO "NSLU2: power/reset\n");
-+
+ *IXP4XX_GPIO_GPISR = 0x20400000; /* read the 2 irqs to clr */
+
+ set_irq_type(NSLU2_RB_IRQ, IRQT_LOW);
@@ -191,7 +182,7 @@
+ printk(KERN_DEBUG "Power Button IRQ %d not available\n",
+ NSLU2_PB_IRQ);
+
-+ return -EIO;
++ return -EIO;
+ }
+
+ return 0;
@@ -209,8 +200,8 @@
+MODULE_AUTHOR("Alessandro Zummo <a.zummo@towertech.it>");
+MODULE_DESCRIPTION("NSLU2 Power/Reset driver");
+MODULE_LICENSE("GPL");
---- linux-2.6.13/arch/arm/mach-ixp4xx/nslu2-setup.c 2005-10-26 15:19:43.171472071 -0700
-+++ linux-2.6.13/arch/arm/mach-ixp4xx/nslu2-setup.c 2005-10-26 15:23:39.646352497 -0700
+--- linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-setup.c 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-setup.c 1970-01-01 00:00:00.000000000 +0000
@@ -0,0 +1,134 @@
+/*
+ * arch/arm/mach-ixp4xx/nslu2-setup.c
@@ -224,7 +215,7 @@
+ * Maintainers: http://www.nslu2-linux.org/
+ *
+ * Fixed missing init_time in MACHINE_START kas11 10/22/04
-+ * Changed to conform to new style __init ixdp425 kas11 10/22/04
++ * Changed to conform to new style __init ixdp425 kas11 10/22/04
+ */
+
+#include <linux/kernel.h>
@@ -346,8 +337,8 @@
+ .timer = &ixp4xx_timer,
+ .init_machine = nslu2_init,
+MACHINE_END
---- linux-2.6.13/include/asm-arm/arch-ixp4xx/hardware.h 2005-10-26 15:19:37.451112111 -0700
-+++ linux-2.6.13/include/asm-arm/arch-ixp4xx/hardware.h 2005-10-26 15:23:39.650352748 -0700
+--- linux-2.6.14/include/asm-arm/arch-ixp4xx/hardware.h 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.14/include/asm-arm/arch-ixp4xx/hardware.h 1970-01-01 00:00:00.000000000 +0000
@@ -44,5 +44,6 @@ extern unsigned int processor_id;
#include "ixdp425.h"
#include "coyote.h"
@@ -355,8 +346,8 @@
+#include "nslu2.h"
#endif /* _ASM_ARCH_HARDWARE_H */
---- linux-2.6.13/include/asm-arm/arch-ixp4xx/irqs.h 2005-08-28 16:41:01.000000000 -0700
-+++ linux-2.6.13/include/asm-arm/arch-ixp4xx/irqs.h 2005-10-26 15:23:39.650352748 -0700
+--- linux-2.6.14/include/asm-arm/arch-ixp4xx/irqs.h 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.14/include/asm-arm/arch-ixp4xx/irqs.h 1970-01-01 00:00:00.000000000 +0000
@@ -93,4 +93,11 @@
#define IRQ_COYOTE_PCI_SLOT1 IRQ_IXP4XX_GPIO11
#define IRQ_COYOTE_IDE IRQ_IXP4XX_GPIO5
@@ -369,8 +360,8 @@
+#define IRQ_NSLU2_PCI_INTC IRQ_IXP4XX_GPIO9
+
#endif
---- linux-2.6.13/include/asm-arm/arch-ixp4xx/nslu2.h 2005-10-26 15:19:43.175472322 -0700
-+++ linux-2.6.13/include/asm-arm/arch-ixp4xx/nslu2.h 2005-10-26 15:23:39.650352748 -0700
+--- linux-2.6.14/include/asm-arm/arch-ixp4xx/nslu2.h 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.14/include/asm-arm/arch-ixp4xx/nslu2.h 1970-01-01 00:00:00.000000000 +0000
@@ -0,0 +1,96 @@
+/*
+ * include/asm-arm/arch-ixp4xx/nslu2.h