summaryrefslogtreecommitdiff
path: root/packages/linux/nas100d-kernel.inc
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/nas100d-kernel.inc')
-rw-r--r--packages/linux/nas100d-kernel.inc6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/linux/nas100d-kernel.inc b/packages/linux/nas100d-kernel.inc
index bf2de136e8..c9301816af 100644
--- a/packages/linux/nas100d-kernel.inc
+++ b/packages/linux/nas100d-kernel.inc
@@ -169,10 +169,10 @@ KERNEL_IMAGETYPE = "zImage"
# To specify the console set KERNEL_CONSOLE in the .bb file.
# CMDLINE_ROOT contains the boot options, CMDLINE_KERNEL_OPTIONS
# contains the things for a specific kernel.
-CMDLINE_KERNEL_OPTIONS ?= "reboot=s"
-CMDLINE_ROOT ?= "root=/dev/ram0 mem=64M@0x00000000 init=/linuxrc"
+CMDLINE_KERNEL_OPTIONS ?=
+CMDLINE_ROOT ?= "root=/dev/mtdblock3 rw rootfstype=jffs2 mem=64M@0x00000000 init=/linuxrc"
# Add distro specific debug (or non-debug) options to this
-CMDLINE_DEBUG ?= ""
+CMDLINE_DEBUG ?= "noirqdebug"
CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_KERNEL_OPTIONS} ${CMDLINE_DEBUG} ${CMDLINE_CONSOLE}"
# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as