summaryrefslogtreecommitdiff
path: root/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb')
-rw-r--r--packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb41
1 files changed, 20 insertions, 21 deletions
diff --git a/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb b/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
index 3e8d26e385..5e562798de 100644
--- a/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
+++ b/packages/linux/mnci-ramses_2.4.21-rmk2-pxa1.bb
@@ -2,6 +2,8 @@ SECTION = "kernel"
DESCRIPTION = "Linux kernel for MNCI device"
MAINTAINER = "M&N Solutions <info@mn-solutions.de>"
LICENSE = "GPL"
+DEPENDS = "modutils-cross virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX}"
+COMPATIBLE_HOST = "arm.*-linux"
KV = "2.4.21"
RMKV = "2"
PXAV = "1"
@@ -17,19 +19,32 @@ S = "${WORKDIR}/linux-${KV}"
inherit kernel
KERNEL_CCSUFFIX = "-3.3.4"
-COMPATIBLE_HOST = "arm.*-linux"
-FILES_kernel = "/boot /tmp"
-DEPENDS = "modutils-cross virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX}"
-# Don't want kernel zImage in rootfs, put it into /tmp ramdisk
-FILES_kernel = ""
+# Put the zImage into kernel-image
ALLOW_EMPTY_kernel = "1"
+FILES_kernel = ""
FILES_kernel-image += "/tmp/zImage"
do_configure_prepend() {
install -m 0644 ${S}/arch/arm/def-configs/${MACHINE} ${S}/.config || die "No default configuration for ${MACHINE} available."
}
+kernel_do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
+ oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" modules_install
+ else
+ oenote "no modules to install"
+ fi
+ install -d ${D}/tmp
+ install -m 0644 ${KERNEL_OUTPUT} ${D}/tmp
+ install -d ${D}/boot
+ install -m 0644 .config ${D}/boot/config-${PV}
+ bzip2 -9 ${D}/boot/*
+ install -d ${D}${sysconfdir}/modutils
+}
+
+
pkg_postinst_kernel-image () {
test -f /tmp/zImage || exit 0
cp /tmp/zImage /dev/mtdblock/1
@@ -55,19 +70,3 @@ pkg_postrm_modules () {
pkg_postrm_kernel () {
}
-kernel_do_install() {
- echo Files: ${FILES}
- echo Files Kernel: ${FILES_kernel}
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
- oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" modules_install
- else
- oenote "no modules to install"
- fi
- install -d ${D}/tmp
- install -m 0644 ${KERNEL_OUTPUT} ${D}/tmp
- install -d ${D}/boot
- install -m 0644 .config ${D}/boot/config-${PV}
- bzip2 -9 ${D}/boot/*
- install -d ${D}${sysconfdir}/modutils
-}