summaryrefslogtreecommitdiff
path: root/packages/linux/mainstone-kernel_2.6.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/mainstone-kernel_2.6.11.bb')
-rw-r--r--packages/linux/mainstone-kernel_2.6.11.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/linux/mainstone-kernel_2.6.11.bb b/packages/linux/mainstone-kernel_2.6.11.bb
index e69de29bb2..2a4d168ac0 100644
--- a/packages/linux/mainstone-kernel_2.6.11.bb
+++ b/packages/linux/mainstone-kernel_2.6.11.bb
@@ -0,0 +1,44 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the Mainstone (PXA270 ref design)"
+LICENSE = "GPL"
+MAINTAINER = "Cliff Brake <cliff.brake@gmail.com>"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.tar.bz2 \
+ file://mainstone_defconfig"
+
+S = "${WORKDIR}/linux-2.6.11"
+
+COMPATIBLE_HOST = 'arm.*-linux'
+
+inherit kernel
+inherit package
+
+ARCH = "arm"
+KERNEL_IMAGETYPE = "zImage"
+#CMDLINE_CONSOLE ?= "ttyS0,115200n8"
+#CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
+#CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 mem=32M@0x00000000"
+#CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
+#CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/${MACHINE}_defconfig ${S}/.config
+# echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+python () {
+ # Don't build kernel unless we're targeting a mainstone
+ mach = bb.data.getVar("MACHINE", d, 1)
+ if mach != 'mainstone':
+ raise bb.parse.SkipPackage("This kernel only builds for the Mainstone")
+}