summaryrefslogtreecommitdiff
path: root/packages/linux/linux_2.6.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux_2.6.26.bb')
-rw-r--r--packages/linux/linux_2.6.26.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/linux/linux_2.6.26.bb b/packages/linux/linux_2.6.26.bb
new file mode 100644
index 0000000000..9e33257442
--- /dev/null
+++ b/packages/linux/linux_2.6.26.bb
@@ -0,0 +1,25 @@
+require linux.inc
+
+PR = "r0"
+
+# Mark archs/machines that this kernel supports
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
+ file://defconfig"
+
+SRC_URI_append_mpc8313e-rdb = "\
+ file://mpc831x-nand.patch;patch=1 \
+ file://mpc8313e-rdb-leds.patch;patch=1 \
+ file://mpc8313e-rdb-cardbus.patch;patch=1 \
+ "
+
+# see http://bugzilla.kernel.org/show_bug.cgi?id=11143
+do_stage_append() {
+ if [ -f arch/${ARCH}/lib/crtsavres.o ]; then
+ mkdir -p ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib
+ cp -a arch/${ARCH}/lib/crtsavres.o ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib/
+ fi
+}
+