summaryrefslogtreecommitdiff
path: root/packages/linux/linux_2.6.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux_2.6.24.bb')
-rw-r--r--packages/linux/linux_2.6.24.bb69
1 files changed, 58 insertions, 11 deletions
diff --git a/packages/linux/linux_2.6.24.bb b/packages/linux/linux_2.6.24.bb
index 64a2a58361..a45db10f1c 100644
--- a/packages/linux/linux_2.6.24.bb
+++ b/packages/linux/linux_2.6.24.bb
@@ -3,17 +3,22 @@ require linux.inc
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_gesbc-9302 = "1"
+DEFAULT_PREFERENCE_cm-x270 = "1"
DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
DEPENDS_append_mpc8313e-rdb = " dtc-native"
-PR = "r2"
+PR = "r7"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
- file://defconfig \
- "
+ http://kamikaze.waninkoko.info/patches/2.6.24/kamikaze1/broken-out/squashfs-lzma-2.6.24.patch;patch=1 \
+ file://powerpc-clockres.patch;patch=1 \
+ file://leds-cpu-activity.patch;patch=1 \
+ file://leds-cpu-activity-powerpc.patch;patch=1 \
+ file://defconfig"
-S = "${WORKDIR}/linux-2.6.24"
+# Real-time preemption. This is experimental and requires a different defconfig.
+#SRC_URI += " http://www.kernel.org/pub/linux/kernel/projects/rt/patch-2.6.24-rt1.bz2;patch=1"
SRC_URI_append_gesbc-9302 = " \
file://0001-gesbc-nand.patch;patch=1 \
@@ -21,21 +26,62 @@ SRC_URI_append_gesbc-9302 = " \
file://0005-ep93xx-reboot.patch;patch=1 \
"
+SRC_URI_append_mpc8313e-rdb = "\
+ file://mpc831x-nand.patch;patch=1 \
+ file://mpc8313e-rdb-leds.patch;patch=1 \
+ file://mpc8313e-rdb-rtc.patch;patch=1"
+
CMDLINE_gesbc-9302 = "console=ttyAM0 root=mtd5 rootfstype=jffs2 mtdparts=GESBC-NAND:64m(app),-(data)"
-# work in progress
-#SRC_URI_append_mpc8313e-rdb = "\
-# file://mpc8313e-rdb-leds.patch;patch=1"
-# file://mpc831x-nand.patch;patch=1 \
-# file://mpc8313e-rdb-rtc.patch;patch=1 "
+SRC_URI_append_cm-x270 = " \
+ file://0001-cm-x270-match-type.patch;patch=1 \
+ file://0002-ramdisk_load.patch;patch=1 \
+ file://0003-mmcsd_large_cards-r0.patch;patch=1 \
+ file://0004-cm-x270-nand-simplify-name.patch;patch=1 \
+ file://0005-add-display-set-default-16bpp.patch;patch=1 \
+ "
-# real-time preemption patch
-SRC_URI_append_mpc8313e-rdb = " http://www.kernel.org/pub/linux/kernel/projects/rt/patch-2.6.24-rt1.bz2;patch=1 file://defconfig-rt "
+CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
FILES_kernel-image_gesbc-9302 = ""
DEVICETREE_mpc8313e-rdb = "arch/${ARCH}/boot/dts/mpc8313erdb.dts"
DEVICETREE_FLAGS_mpc8313e-rdb = "-R 8 -S 0x3000"
+python do_compulab_image() {
+ import os
+ import os.path
+ import struct
+
+ machine = bb.data.getVar('MACHINE', d, 1)
+ if machine == "cm-x270":
+ deploy_dir = bb.data.getVar('DEPLOY_DIR_IMAGE', d, 1)
+ kernel_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.bin')
+ img_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270')
+
+ fo = open(img_file, 'wb')
+
+ image_data = open(kernel_file, 'rb').read()
+
+ # first write size into first 4 bytes
+ size_s = struct.pack('i', len(image_data))
+
+ # truncate size if we are running on a 64-bit host
+ size_s = size_s[:4]
+
+ fo.write(size_s)
+ fo.write(image_data)
+ fo.close()
+
+ os.chdir(deploy_dir)
+ link_file = bb.data.expand('${KERNEL_IMAGE_SYMLINK_NAME}', d) + '.cmx270'
+ img_file = bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270'
+ try:
+ os.unlink(link_file)
+ except:
+ pass
+ os.symlink(img_file, link_file)
+}
+
do_devicetree_image() {
if test -n "${DEVICETREE}" ; then
@@ -47,5 +93,6 @@ do_devicetree_image() {
fi
}
+addtask compulab_image after do_deploy before do_package
addtask devicetree_image after do_deploy before do_package