summaryrefslogtreecommitdiff
path: root/packages/linux/linux_2.6.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux_2.6.21.bb')
-rw-r--r--packages/linux/linux_2.6.21.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/packages/linux/linux_2.6.21.bb b/packages/linux/linux_2.6.21.bb
index 94ec06072a..24d4018de2 100644
--- a/packages/linux/linux_2.6.21.bb
+++ b/packages/linux/linux_2.6.21.bb
@@ -8,6 +8,8 @@ DEPENDS_at32stk1000 = "u-boot-mkimage-gta01-native"
DEPENDS_atngw100 = "u-boot-mkimage-gta01-native"
DEPENDS_at91sam9263ek = "u-boot-mkimage-gta01-native"
+DEFAULT_PREFERENCE_at91sam9263ek = "-1"
+
PR = "r3"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
@@ -49,3 +51,13 @@ do_configure_prepend() {
yes '' | oe_runmake oldconfig
}
+do_install_prepend() {
+ if test -e arch/${ARCH}/boot/Image ; then
+ ln -f arch/arm/boot/Image arch/arm/boot/uImage
+ fi
+
+ if test -e arch/${ARCH}/boot/images/uImage ; then
+ ln -f arch/arm/boot/images/uImage arch/arm/boot/uImage
+ fi
+}
+