summaryrefslogtreecommitdiff
path: root/packages/linux/linux.inc
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux.inc')
-rw-r--r--packages/linux/linux.inc5
1 files changed, 3 insertions, 2 deletions
diff --git a/packages/linux/linux.inc b/packages/linux/linux.inc
index 8066c3a403..77920f7f4f 100644
--- a/packages/linux/linux.inc
+++ b/packages/linux/linux.inc
@@ -85,10 +85,11 @@ do_configure_prepend() {
yes '' | oe_runmake oldconfig
}
-fdo_configure_append_avr32() {
+do_configure_append_avr32() {
sed -i -e s:-mno-pic::g arch/avr32/Makefile
}
+
# Support checking the kernel size since some kernels need to reside in partitions
# with a fixed length or there is a limit in transferring the kernel to memory
do_sizecheck() {
@@ -97,7 +98,7 @@ do_sizecheck() {
if [ $size -ge ${KERNEL_IMAGE_MAXSIZE} ]; then
rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
die "This kernel (size=$size) is too big for your device. Please reduce the size of the kernel by making more of it modular."
-a
+ fi
fi
}