summaryrefslogtreecommitdiff
path: root/packages/linux/linux-x86_2.6.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux-x86_2.6.20.bb')
-rw-r--r--packages/linux/linux-x86_2.6.20.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/packages/linux/linux-x86_2.6.20.bb b/packages/linux/linux-x86_2.6.20.bb
index 5db1563733..c73ee58d2f 100644
--- a/packages/linux/linux-x86_2.6.20.bb
+++ b/packages/linux/linux-x86_2.6.20.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Linux Kernel for x86 compatible machines"
SECTION = "kernel"
LICENSE = "GPL"
-PR = "r0"
+PR = "r2"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://defconfig"
@@ -17,3 +17,11 @@ do_configure_prepend() {
install -m 0644 ${WORKDIR}/defconfig ${S}/.config
}
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/i386/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_populate_staging after do_compile