summaryrefslogtreecommitdiff
path: root/packages/linux/linux-orion_2.6.27.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux-orion_2.6.27.10.bb')
-rw-r--r--packages/linux/linux-orion_2.6.27.10.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/linux/linux-orion_2.6.27.10.bb b/packages/linux/linux-orion_2.6.27.10.bb
new file mode 100644
index 0000000000..057a59b7c3
--- /dev/null
+++ b/packages/linux/linux-orion_2.6.27.10.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Linux Kernel for Marvell Orion based devices"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r1"
+DEPENDS = "devio-native"
+COMPATIBLE_MACHINE = "(dns323|mv2120|kuropro|lspro|ts109|ts209|ts409)"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://kuropro-foonas-mtd.patch;patch=1 \
+ file://fw-and-powerpc-install.patch;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-${PV}"
+
+# Fix the mach-type of orion devices
+SRC_URI_append_dns323 += "file://dns323.patch;patch=1"
+SRC_URI_append_mv2120 += "file://mv2120.patch;patch=1"
+SRC_URI_append_kuropro += "file://kuropro.patch;patch=1"
+SRC_URI_append_lspro += "file://lspro.patch;patch=1"
+SRC_URI_append_ts109 += "file://ts109-ts209.patch;patch=1"
+SRC_URI_append_ts209 += "file://ts109-ts209.patch;patch=1"
+SRC_URI_append_ts409 += "file://ts409.patch;patch=1"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "uImage"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}