summaryrefslogtreecommitdiff
path: root/packages/linux/linux-openzaurus_2.6.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux-openzaurus_2.6.11.bb')
-rw-r--r--packages/linux/linux-openzaurus_2.6.11.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/packages/linux/linux-openzaurus_2.6.11.bb b/packages/linux/linux-openzaurus_2.6.11.bb
index 53f5211019..20ef4f07bc 100644
--- a/packages/linux/linux-openzaurus_2.6.11.bb
+++ b/packages/linux/linux-openzaurus_2.6.11.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
#KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
KV = "${@bb.data.getVar('PV',d,True)}"
-PR = "r16"
+PR = "r17"
DOSRC = "http://www.do13.in-berlin.de/openzaurus"
RPSRC = "http://www.rpsys.net/openzaurus/patches"
@@ -150,6 +150,17 @@ do_configure() {
yes '' | oe_runmake oldconfig
}
+# Check the kernel is below the 1272*1024 byte limit for the c7x0
+do_compile_append() {
+ if [ "${MACHINE}" == "c7x0" ]; then
+ size=`ls arch/${ARCH}/boot/${KERNEL_IMAGETYPE} -s | cut -d ' ' -f 1`
+ if [ $size -ge 1271 ]; then
+ rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
+ die "This kernel is too big for the c7x0 and will destroy your machine if you flash it!!!"
+ fi
+ fi
+}
+
do_deploy() {
install -d ${DEPLOY_DIR}/images
install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin