summaryrefslogtreecommitdiff
path: root/packages/linux/linux-openmoko-2.6.28_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux-openmoko-2.6.28_git.bb')
-rw-r--r--packages/linux/linux-openmoko-2.6.28_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/linux/linux-openmoko-2.6.28_git.bb b/packages/linux/linux-openmoko-2.6.28_git.bb
new file mode 100644
index 0000000000..2389db2bcd
--- /dev/null
+++ b/packages/linux/linux-openmoko-2.6.28_git.bb
@@ -0,0 +1,24 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
+
+KERNEL_RELEASE = "2.6.28"
+KERNEL_VERSION = "${KERNEL_RELEASE}"
+
+OEV = "oe1"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+ file://openwrt-ledtrig-netdev.patch;patch=1 \
+ file://defconfig-oe.patch \
+"
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/gta02-moredrivers-defconfig ${WORKDIR}/defconfig-oe
+ cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
+}
+