summaryrefslogtreecommitdiff
path: root/packages/linux/linux-omap
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux-omap')
-rw-r--r--packages/linux/linux-omap/beagleboard/beagle-asoc.diff212
-rw-r--r--packages/linux/linux-omap/dvb-fix-dma.diff60
-rw-r--r--packages/linux/linux-omap/tick-schedc-suppress-needless-timer-reprogramming.patch81
-rw-r--r--packages/linux/linux-omap/twl-asoc-fix-record.diff34
4 files changed, 0 insertions, 387 deletions
diff --git a/packages/linux/linux-omap/beagleboard/beagle-asoc.diff b/packages/linux/linux-omap/beagleboard/beagle-asoc.diff
deleted file mode 100644
index 6763d85c32..0000000000
--- a/packages/linux/linux-omap/beagleboard/beagle-asoc.diff
+++ /dev/null
@@ -1,212 +0,0 @@
-From: Felipe Contreras <felipe.contreras@gmail.com>
-To: linux-omap@vger.kernel.org
-Cc: Felipe Contreras <felipe.contreras@gmail.com>
-Subject: [PATCH] alsa: add Beagleboard SoC configuration.
-
-This is exactly the same as the overo configuration. It might make sense
-to have them in a single one.
-
-Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
----
-
-This was suggested by Koen Kooi.
-
- sound/soc/omap/Kconfig | 8 ++
- sound/soc/omap/Makefile | 2 +
- sound/soc/omap/omap3beagle.c | 149 ++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 159 insertions(+), 0 deletions(-)
- create mode 100644 sound/soc/omap/omap3beagle.c
-
-diff --git a/sound/soc/omap/Kconfig b/sound/soc/omap/Kconfig
-index d7b8939..ebad024 100644
---- a/sound/soc/omap/Kconfig
-+++ b/sound/soc/omap/Kconfig
-@@ -22,3 +22,11 @@ config SND_OMAP_SOC_OVERO
- help
- Say Y if you want to add support for SoC audio on the Gumstix Overo.
-
-+config SND_OMAP_SOC_OMAP3_BEAGLE
-+ tristate "SoC Audio support for OMAP3 Beagle"
-+ depends on SND_OMAP_SOC && MACH_OMAP3_BEAGLE
-+ select SND_OMAP_SOC_MCBSP
-+ select SND_SOC_TWL4030
-+ help
-+ Say Y if you want to add support for SoC audio on the Beagleboard.
-+
-diff --git a/sound/soc/omap/Makefile b/sound/soc/omap/Makefile
-index b96b97b..09fd0bb 100644
---- a/sound/soc/omap/Makefile
-+++ b/sound/soc/omap/Makefile
-@@ -8,7 +8,9 @@ obj-$(CONFIG_SND_OMAP_SOC_MCBSP) += snd-soc-omap-mcbsp.o
- # OMAP Machine Support
- snd-soc-n810-objs := n810.o
- snd-soc-overo-objs := overo.o
-+snd-soc-omap3beagle-objs := omap3beagle.o
-
- obj-$(CONFIG_SND_OMAP_SOC_N810) += snd-soc-n810.o
- obj-$(CONFIG_SND_OMAP_SOC_OVERO) += snd-soc-overo.o
-+obj-$(CONFIG_SND_OMAP_SOC_OMAP3_BEAGLE) += snd-soc-omap3beagle.o
-
-diff --git a/sound/soc/omap/omap3beagle.c b/sound/soc/omap/omap3beagle.c
-new file mode 100644
-index 0000000..1d0e398
---- /dev/null
-+++ b/sound/soc/omap/omap3beagle.c
-@@ -0,0 +1,149 @@
-+/*
-+ * omap3beagle.c -- SoC audio for OMAP3 Beagle
-+ *
-+ * Author: Steve Sakoman <steve@sakoman.com>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-+ * 02110-1301 USA
-+ *
-+ */
-+
-+#include <linux/clk.h>
-+#include <linux/platform_device.h>
-+#include <sound/core.h>
-+#include <sound/pcm.h>
-+#include <sound/soc.h>
-+#include <sound/soc-dapm.h>
-+
-+#include <asm/mach-types.h>
-+#include <mach/hardware.h>
-+#include <mach/gpio.h>
-+#include <mach/mcbsp.h>
-+
-+#include "omap-mcbsp.h"
-+#include "omap-pcm.h"
-+#include "../codecs/twl4030.h"
-+
-+static int omap3beagle_hw_params(struct snd_pcm_substream *substream,
-+ struct snd_pcm_hw_params *params)
-+{
-+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+ struct snd_soc_dai *codec_dai = rtd->dai->codec_dai;
-+ struct snd_soc_dai *cpu_dai = rtd->dai->cpu_dai;
-+ int ret;
-+
-+ /* Set codec DAI configuration */
-+ ret = snd_soc_dai_set_fmt(codec_dai,
-+ SND_SOC_DAIFMT_I2S |
-+ SND_SOC_DAIFMT_NB_NF |
-+ SND_SOC_DAIFMT_CBM_CFM);
-+ if (ret < 0) {
-+ printk(KERN_ERR "can't set codec DAI configuration\n");
-+ return ret;
-+ }
-+
-+ /* Set cpu DAI configuration */
-+ ret = snd_soc_dai_set_fmt(cpu_dai,
-+ SND_SOC_DAIFMT_I2S |
-+ SND_SOC_DAIFMT_NB_NF |
-+ SND_SOC_DAIFMT_CBM_CFM);
-+ if (ret < 0) {
-+ printk(KERN_ERR "can't set cpu DAI configuration\n");
-+ return ret;
-+ }
-+
-+ /* Set the codec system clock for DAC and ADC */
-+ ret = snd_soc_dai_set_sysclk(codec_dai, 0, 26000000,
-+ SND_SOC_CLOCK_IN);
-+ if (ret < 0) {
-+ printk(KERN_ERR "can't set codec system clock\n");
-+ return ret;
-+ }
-+
-+ return 0;
-+}
-+
-+static struct snd_soc_ops omap3beagle_ops = {
-+ .hw_params = omap3beagle_hw_params,
-+};
-+
-+/* Digital audio interface glue - connects codec <--> CPU */
-+static struct snd_soc_dai_link omap3beagle_dai = {
-+ .name = "TWL4030",
-+ .stream_name = "TWL4030",
-+ .cpu_dai = &omap_mcbsp_dai[0],
-+ .codec_dai = &twl4030_dai,
-+ .ops = &omap3beagle_ops,
-+};
-+
-+/* Audio machine driver */
-+static struct snd_soc_machine snd_soc_machine_omap3beagle = {
-+ .name = "omap3beagle",
-+ .dai_link = &omap3beagle_dai,
-+ .num_links = 1,
-+};
-+
-+/* Audio subsystem */
-+static struct snd_soc_device omap3beagle_snd_devdata = {
-+ .machine = &snd_soc_machine_omap3beagle,
-+ .platform = &omap_soc_platform,
-+ .codec_dev = &soc_codec_dev_twl4030,
-+};
-+
-+static struct platform_device *omap3beagle_snd_device;
-+
-+static int __init omap3beagle_soc_init(void)
-+{
-+ int ret;
-+
-+ printk(KERN_INFO "OMAP3 Beagle SoC init\n");
-+ if (!machine_is_omap3_beagle()) {
-+ printk(KERN_ERR "Not OMAP3 Beagle!\n");
-+ return -ENODEV;
-+ }
-+
-+ omap3beagle_snd_device = platform_device_alloc("soc-audio", -1);
-+ if (!omap3beagle_snd_device) {
-+ printk(KERN_ERR "Platform device allocation failed\n");
-+ return -ENOMEM;
-+ }
-+
-+ platform_set_drvdata(omap3beagle_snd_device, &omap3beagle_snd_devdata);
-+ omap3beagle_snd_devdata.dev = &omap3beagle_snd_device->dev;
-+ *(unsigned int *)omap3beagle_dai.cpu_dai->private_data = 1; /* McBSP2 */
-+
-+ ret = platform_device_add(omap3beagle_snd_device);
-+ if (ret)
-+ goto err1;
-+
-+ return 0;
-+
-+err1:
-+ printk(KERN_ERR "Unable to add platform device\n");
-+ platform_device_put(omap3beagle_snd_device);
-+
-+ return ret;
-+}
-+
-+static void __exit omap3beagle_soc_exit(void)
-+{
-+ platform_device_unregister(omap3beagle_snd_device);
-+}
-+
-+module_init(omap3beagle_soc_init);
-+module_exit(omap3beagle_soc_exit);
-+
-+MODULE_AUTHOR("Steve Sakoman <steve@sakoman.com>");
-+MODULE_DESCRIPTION("ALSA SoC OMAP3 Beagle");
-+MODULE_LICENSE("GPL");
---
-1.6.0.1
-
---
-To unsubscribe from this list: send the line "unsubscribe linux-omap" in
-the body of a message to majordomo@vger.kernel.org
-More majordomo info at http://vger.kernel.org/majordomo-info.html
-
diff --git a/packages/linux/linux-omap/dvb-fix-dma.diff b/packages/linux/linux-omap/dvb-fix-dma.diff
deleted file mode 100644
index e05473fc7f..0000000000
--- a/packages/linux/linux-omap/dvb-fix-dma.diff
+++ /dev/null
@@ -1,60 +0,0 @@
-Hi,
-I post this patch that fixes a kernel crash that happens when using a dvb
-usb stick on a mips platform and I think even on other platforms on which
-the dma access in not cache-coherent.
-
-The problem's origin is that, inside the method usb_bulk_urb_init of file
-drivers/media/dvb/dvb-usb/usb-urb.c, stream->urb_list[i]->transfer_buffer
-points to a memory area that has been allocated to be dma-coherent but
-stream->urb_list[i]->transfer_flags doesn't include the
-URB_NO_TRANSFER_DMA_MAP flag and stream->urb_list[i]->transfer_dma is not
-set.
-When later on the stream->urb_list[i]->transfer_buffer pointer is used
-inside function usb_hcd_submit_urb of file drivers/usb/core/hcd.c since the
-flag URB_NO_TRANSFER_DMA_MAP is not set the urb->transfer_buffer pointer is
-passed to the dma_map_single function that since the address is dma-coherent
-returns a wrong tranfer_dma address that later on leads to the kernel crash.
-
-The problem is solved by setting the URB_NO_TRANSFER_DMA_MAP flag and the
-stream->urb_list[i]->transfer_dma address.
-
-Perhaps to be more safe the URB_NO_TRANSFER_DMA_MAP flag can be set only
-if stream->urb_list[i]->transfer_dma != 0.
-
-I don't know if half of the fault can be of the dma_map_single function that
-should anyway returns a valid address both for a not dma-coherent and a
-dma-coherent address.
-
-Just to be clear:
-I've done this patch to solve my problem and I tested it only on a mips
-platform
-but I think it should not cause any problems on other platforms.
-I posted it here to help someone else that can have my same problem and to
-point it out
-to the mantainer of this part of code.
-You can use it at your own risk and I'm not resposible in any way for any
-problem or
-damage that it can cause.
-I'm available to discuss about it
-
-Bye
-
-Michele Scorcia
-
---------------------
-
-
-
-
---- /tmp/usb-urb.c 2008-10-08 09:53:23.000000000 +0200
-+++ git/drivers/media/dvb/dvb-usb/usb-urb.c 2008-10-08 09:54:16.000000000 +0200
-@@ -152,7 +152,8 @@
- stream->props.u.bulk.buffersize,
- usb_urb_complete, stream);
-
-- stream->urb_list[i]->transfer_flags = 0;
-+ stream->urb_list[i]->transfer_flags = URB_NO_TRANSFER_DMA_MAP;
-+ stream->urb_list[i]->transfer_dma = stream->dma_addr[i];
- stream->urbs_initialized++;
- }
- return 0;
diff --git a/packages/linux/linux-omap/tick-schedc-suppress-needless-timer-reprogramming.patch b/packages/linux/linux-omap/tick-schedc-suppress-needless-timer-reprogramming.patch
deleted file mode 100644
index c5cf4ef6ef..0000000000
--- a/packages/linux/linux-omap/tick-schedc-suppress-needless-timer-reprogramming.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From: "Woodruff, Richard" <r-woodruff2@ti.com>
-
-In my device I get many interrupts from a high speed USB device in a very
-short period of time. The system spends a lot of time reprogramming the
-hardware timer which is in a slower timing domain as compared to the CPU.
-This results in the CPU spending a huge amount of time waiting for the
-timer posting to be done. All of this reprogramming is useless as the
-wake up time has not changed.
-
-As measured using ETM trace this drops my reprogramming penalty from
-almost 60% CPU load down to 15% during high interrupt rate. I can send
-traces to show this.
-
-
-Suppress setting of duplicate timer event when timer already stopped.
-Timer programming can be very costly and can result in long cpu stall/wait
-times.
-
-[akpm@linux-foundation.org: coding-style fixes]
-Signed-off-by: Richard Woodruff <r-woodruff2@ti.com>
-Cc: Thomas Gleixner <tglx@linutronix.de>
-
-On Wed, 24 Sep 2008 18:31:29 +0200 (CEST) Thomas Gleixner <tglx@linutronix.de> wrote:
-
-> No, we only fall trrough into raise_softirq() when the reprogram code
-> detects that the event already expired. So you change the flow :)
->
-> It does also not deal with delta_jiffies >= NEXT_TIMER_MAX_DELTA :(
->
-> I have a closer look on that.
-
-Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
----
-
- kernel/time/tick-sched.c | 19 +++++++++++++------
- 1 file changed, 13 insertions(+), 6 deletions(-)
-
-diff -puN kernel/time/tick-sched.c~tick-schedc-suppress-needless-timer-reprogramming kernel/time/tick-sched.c
---- a/kernel/time/tick-sched.c~tick-schedc-suppress-needless-timer-reprogramming
-+++ a/kernel/time/tick-sched.c
-@@ -282,6 +282,17 @@ void tick_nohz_stop_sched_tick(int inidl
- /* Schedule the tick, if we are at least one jiffie off */
- if ((long)delta_jiffies >= 1) {
-
-+ /*
-+ * calculate the expiry time for the next timer wheel
-+ * timer
-+ */
-+ expires = ktime_add_ns(last_update, tick_period.tv64 *
-+ delta_jiffies);
-+
-+ /* Skip reprogram of event if its not changed */
-+ if (ts->tick_stopped && ktime_equal(expires, dev->next_event))
-+ goto out2;
-+
- if (delta_jiffies > 1)
- cpu_set(cpu, nohz_cpu_mask);
- /*
-@@ -332,12 +343,7 @@ void tick_nohz_stop_sched_tick(int inidl
- goto out;
- }
-
-- /*
-- * calculate the expiry time for the next timer wheel
-- * timer
-- */
-- expires = ktime_add_ns(last_update, tick_period.tv64 *
-- delta_jiffies);
-+ /* Mark expiries */
- ts->idle_expires = expires;
-
- if (ts->nohz_mode == NOHZ_MODE_HIGHRES) {
-@@ -356,6 +362,7 @@ void tick_nohz_stop_sched_tick(int inidl
- tick_do_update_jiffies64(ktime_get());
- cpu_clear(cpu, nohz_cpu_mask);
- }
-+out2:
- raise_softirq_irqoff(TIMER_SOFTIRQ);
- out:
- ts->next_jiffies = next_jiffies;
-_
diff --git a/packages/linux/linux-omap/twl-asoc-fix-record.diff b/packages/linux/linux-omap/twl-asoc-fix-record.diff
deleted file mode 100644
index 9c0ceaa2e0..0000000000
--- a/packages/linux/linux-omap/twl-asoc-fix-record.diff
+++ /dev/null
@@ -1,34 +0,0 @@
-From linux-omap-owner@vger.kernel.org Sat Dec 06 02:14:21 2008
-Date: Fri, 5 Dec 2008 16:46:34 -0800
-From: "Steve Sakoman" <sakoman@gmail.com>
-To: "linux-omap@vger.kernel.org" <linux-omap@vger.kernel.org>
-Subject: [FYI PATCH] ASOC:TWL4030 Audio capture fix
-
-A couple of folks have noticed an issue with audio capture -- the
-capture result is always silence.
-
-The patch below is a quick fix for those with this issue. There are
-substantial changes to the codec driver that will be trickling down
-from ASoC, and they deal with this issue differently.
-
-So consider this as a bandaid for those who don't want to wait for the
-trickle down :-)
-
-Steve
-
-
-diff --git a/sound/soc/codecs/twl4030.c b/sound/soc/codecs/twl4030.c
-index ee2f0d3..8b4aafb 100644
---- a/sound/soc/codecs/twl4030.c
-+++ b/sound/soc/codecs/twl4030.c
-@@ -45,8 +45,8 @@ static const u8 twl4030_reg[TWL4030_CACHEREGNUM] = {
- 0xc3, /* REG_OPTION (0x2) */
- 0x00, /* REG_UNKNOWN (0x3) */
- 0x00, /* REG_MICBIAS_CTL (0x4) */
-- 0x24, /* REG_ANAMICL (0x5) */
-- 0x04, /* REG_ANAMICR (0x6) */
-+ 0x34, /* REG_ANAMICL (0x5) */
-+ 0x14, /* REG_ANAMICR (0x6) */
- 0x0a, /* REG_AVADC_CTL (0x7) */
- 0x00, /* REG_ADCMICSEL (0x8) */
- 0x00, /* REG_DIGMIXING (0x9) */