summaryrefslogtreecommitdiff
path: root/packages/linux/linux-msm7xxxx_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux-msm7xxxx_git.bb')
-rw-r--r--packages/linux/linux-msm7xxxx_git.bb31
1 files changed, 22 insertions, 9 deletions
diff --git a/packages/linux/linux-msm7xxxx_git.bb b/packages/linux/linux-msm7xxxx_git.bb
index a2972bbe8d..c0d2617346 100644
--- a/packages/linux/linux-msm7xxxx_git.bb
+++ b/packages/linux/linux-msm7xxxx_git.bb
@@ -3,23 +3,36 @@ require linux.inc
PV = "2.6.25+${PR}+gitr${SRCREV}"
PV_htckaiser = "2.6.24+${PR}+gitr${SRCREV}"
PV_htcpolaris = "2.6.24+${PR}+gitr${SRCREV}"
-
-PR = "r2"
+PV_htcraphael = "2.6.27+${PR}+gitr${SRCREV}"
+PV_htcdiamond = "2.6.27+${PR}+gitr${SRCREV}"
+PR = "r4"
COMPATIBLE_MACHINE = "htckaiser|htcpolaris|htcraphael|htcdiamond|htcvogue|htctitan"
SRCREV_htckaiser = "1082670ccae30e6592311cc9dee93ba978382a25"
SRCREV_htcpolaris = "1082670ccae30e6592311cc9dee93ba978382a25"
-SRCREV_htcraphael = "c07884fc4c99845e2d940009e494f83e22509e3d"
-SRCREV_htcdiamond = "c07884fc4c99845e2d940009e494f83e22509e3d"
+SRCREV_htcraphael = "05e144ae16c252bd8f4d0e53faf14c58a74d8c0f"
+SRCREV_htcdiamond = "05e144ae16c252bd8f4d0e53faf14c58a74d8c0f"
SRCREV_htcvogue = "8cfc6730b38091c908b2df3b906a3a54f27e1bb2"
SRCREV_htctitan = "8cfc6730b38091c908b2df3b906a3a54f27e1bb2"
-SRC_URI = "git://git.linuxtogo.org/home/groups/mobile-linux/kernel.git;branch=htc-msm-2.6.25;protocol=git file://defconfig"
-SRC_URI_htckaiser = "git://git.linuxtogo.org/home/groups/mobile-linux/kernel.git;branch=htc-msm;protocol=git file://defconfig"
-SRC_URI_htcpolaris = "git://git.linuxtogo.org/home/groups/mobile-linux/kernel.git;branch=htc-msm;protocol=git file://defconfig"
-SRC_URI_htcvogue = "git://git.linuxtogo.org/home/groups/mobile-linux/kernel.git;branch=htc-vogue;protocol=git file://defconfig"
-SRC_URI_htctitan = "git://git.linuxtogo.org/home/groups/mobile-linux/kernel.git;branch=htc-vogue;protocol=git file://defconfig"
+SRC_BRANCH = "htc-msm-2.6.25"
+SRC_BRANCH_htckaiser = "htc-msm"
+SRC_BRANCH_htcpolaris = "htc-msm"
+SRC_BRANCH_htcraphael = "htc-msm-2.6.27"
+SRC_BRANCH_htcvogue = "htc-vogue"
+SRC_BRANCH_htctitan = "htc-vogue"
+SRC_URI = "\
+ git://git.linuxtogo.org/home/groups/mobile-linux/kernel.git;branch=${SRC_BRANCH};protocol=git \
+ file://defconfig \
+"
S = "${WORKDIR}/git"
+do_configure_prepend_htcraphael() {
+ install -m 0644 arch/arm/configs/${MACHINE}_defconfig ${WORKDIR}/defconfig
+}
+
+do_configure_prepend_htcdiamond() {
+ install -m 0644 arch/arm/configs/${MACHINE}_defconfig ${WORKDIR}/defconfig
+}