summaryrefslogtreecommitdiff
path: root/packages/linux/linux-ezx-2.6.24/update_patches.sh
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux-ezx-2.6.24/update_patches.sh')
-rw-r--r--packages/linux/linux-ezx-2.6.24/update_patches.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/linux/linux-ezx-2.6.24/update_patches.sh b/packages/linux/linux-ezx-2.6.24/update_patches.sh
new file mode 100644
index 0000000000..9a8d36e461
--- /dev/null
+++ b/packages/linux/linux-ezx-2.6.24/update_patches.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+set -e
+
+# Helper script to update patches and speedup filling the SRC_URI section of our .bb
+# Run it while in packages/linux/linux-ezx-2.6.x/
+
+[ -d patches ] && mtn drop -R patches
+rm -rf patches
+
+svn --quiet co http://svn.openezx.org/branches/kernel-2.6.24.x-patches patches
+find patches -type f -print0
+mtn add patches patches/*
+
+cat patches/series | grep ^[0-9A-Za-z] | sed -e 's/.*/\tfile:\/\/patches\/\0;patch=1 \\/'
+ls -1 patches/defconfig-* | sed -e 's/.*/\tfile:\/\/\0 \\/'
+