summaryrefslogtreecommitdiff
path: root/packages/linux/ixp4xx-kernel_2.6.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/ixp4xx-kernel_2.6.19.bb')
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.19.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/packages/linux/ixp4xx-kernel_2.6.19.bb b/packages/linux/ixp4xx-kernel_2.6.19.bb
index 915e241f75..6841c93d00 100644
--- a/packages/linux/ixp4xx-kernel_2.6.19.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.19.bb
@@ -23,3 +23,16 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
+
+# Remove the specific cmdline hacking patches if we are not building for nslu2.
+addtask remove_cmdline_hacks before do_patch after do_unpack
+do_remove_cmdline_hacks() {
+
+# if [ "${MACHINE}" != "nslu2" ] ; then
+ sed -e '/88-nas100d-dflt-cmdline.patch/d' \
+ -e '/88-nslu2-dflt-cmdline.patch/d' \
+ '${WORKDIR}/series' > '${WORKDIR}/series.new'
+ mv '${WORKDIR}/series.new' '${WORKDIR}/series'
+# fi
+
+}