summaryrefslogtreecommitdiff
path: root/packages/linux/ixp4xx-kernel/2.6.16/75-dsmg600.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/ixp4xx-kernel/2.6.16/75-dsmg600.patch')
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.16/75-dsmg600.patch40
1 files changed, 20 insertions, 20 deletions
diff --git a/packages/linux/ixp4xx-kernel/2.6.16/75-dsmg600.patch b/packages/linux/ixp4xx-kernel/2.6.16/75-dsmg600.patch
index 05d467d0be..3603bd3ca8 100644
--- a/packages/linux/ixp4xx-kernel/2.6.16/75-dsmg600.patch
+++ b/packages/linux/ixp4xx-kernel/2.6.16/75-dsmg600.patch
@@ -9,9 +9,9 @@
include/asm-arm/arch-ixp4xx/irqs.h | 10 ++
8 files changed, 296 insertions(+)
---- linux-ixp4xx.orig/arch/arm/mach-ixp4xx/Kconfig 2006-02-23 18:29:02.000000000 +0100
-+++ linux-ixp4xx/arch/arm/mach-ixp4xx/Kconfig 2006-02-23 18:29:11.000000000 +0100
-@@ -85,6 +85,14 @@ config MACH_NAS100D
+--- linux-ixp4xx.orig/arch/arm/mach-ixp4xx/Kconfig 2006-03-18 18:10:31.000000000 +0100
++++ linux-ixp4xx/arch/arm/mach-ixp4xx/Kconfig 2006-03-18 18:10:34.000000000 +0100
+@@ -83,6 +83,14 @@ config MACH_NAS100D
NAS 100d device. For more information on this platform,
see http://www.nslu2-linux.org/wiki/NAS100d/HomePage
@@ -27,7 +27,7 @@
# Avila and IXDP share the same source for now. Will change in future
#
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-ixp4xx/arch/arm/mach-ixp4xx/dsmg600-pci.c 2006-02-23 18:29:11.000000000 +0100
++++ linux-ixp4xx/arch/arm/mach-ixp4xx/dsmg600-pci.c 2006-03-18 18:10:34.000000000 +0100
@@ -0,0 +1,74 @@
+/*
+ * DSM-G600 board-level PCI initialization
@@ -104,7 +104,7 @@
+
+subsys_initcall(dsmg600_pci_init);
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-ixp4xx/arch/arm/mach-ixp4xx/dsmg600-setup.c 2006-02-23 18:29:11.000000000 +0100
++++ linux-ixp4xx/arch/arm/mach-ixp4xx/dsmg600-setup.c 2006-03-18 18:10:34.000000000 +0100
@@ -0,0 +1,139 @@
+/*
+ * DSM-G600 board-setup
@@ -245,15 +245,15 @@
+ .timer = &ixp4xx_timer,
+ .init_machine = dsmg600_init,
+MACHINE_END
---- linux-ixp4xx.orig/arch/arm/tools/mach-types 2006-02-23 18:29:02.000000000 +0100
-+++ linux-ixp4xx/arch/arm/tools/mach-types 2006-02-23 18:29:39.000000000 +0100
+--- linux-ixp4xx.orig/arch/arm/tools/mach-types 2006-03-18 18:10:31.000000000 +0100
++++ linux-ixp4xx/arch/arm/tools/mach-types 2006-03-18 18:10:34.000000000 +0100
@@ -969,3 +969,4 @@ mxc300_30ads MACH_MXC30030ADS MXC30030A
fujitsu_wimaxsoc MACH_FUJITSU_WIMAXSOC FUJITSU_WIMAXSOC 956
dualpcmodem MACH_DUALPCMODEM DUALPCMODEM 957
gesbc9312 MACH_GESBC9312 GESBC9312 958
+dsmg600 MACH_DSMG600 DSMG600 964
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-ixp4xx/include/asm-arm/arch-ixp4xx/dsmg600.h 2006-02-23 18:29:11.000000000 +0100
++++ linux-ixp4xx/include/asm-arm/arch-ixp4xx/dsmg600.h 2006-03-18 18:10:34.000000000 +0100
@@ -0,0 +1,62 @@
+/*
+ * DSM-G600 platform specific definitions
@@ -317,16 +317,16 @@
+#define DSMG600_IRQ_RSTBTN IRQ_IXP4XX_GPIO3
+
+#define DSMG600_GPIO_PWROFF DSMG600_GPIO2 /* power off */
---- linux-ixp4xx.orig/arch/arm/mach-ixp4xx/Makefile 2006-02-23 18:29:02.000000000 +0100
-+++ linux-ixp4xx/arch/arm/mach-ixp4xx/Makefile 2006-02-23 18:29:11.000000000 +0100
+--- linux-ixp4xx.orig/arch/arm/mach-ixp4xx/Makefile 2006-03-18 18:10:31.000000000 +0100
++++ linux-ixp4xx/arch/arm/mach-ixp4xx/Makefile 2006-03-18 18:10:34.000000000 +0100
@@ -10,4 +10,5 @@ obj-$(CONFIG_ARCH_ADI_COYOTE) += coyote-
obj-$(CONFIG_MACH_GTWX5715) += gtwx5715-pci.o gtwx5715-setup.o
obj-$(CONFIG_MACH_NSLU2) += nslu2-pci.o nslu2-setup.o nslu2-power.o
obj-$(CONFIG_MACH_NAS100D) += nas100d-pci.o nas100d-setup.o nas100d-power.o
+obj-$(CONFIG_MACH_DSMG600) += dsmg600-pci.o dsmg600-setup.o
---- linux-ixp4xx.orig/include/asm-arm/arch-ixp4xx/hardware.h 2006-02-23 18:29:02.000000000 +0100
-+++ linux-ixp4xx/include/asm-arm/arch-ixp4xx/hardware.h 2006-02-23 18:29:11.000000000 +0100
+--- linux-ixp4xx.orig/include/asm-arm/arch-ixp4xx/hardware.h 2006-03-18 18:10:31.000000000 +0100
++++ linux-ixp4xx/include/asm-arm/arch-ixp4xx/hardware.h 2006-03-18 18:10:34.000000000 +0100
@@ -46,5 +46,6 @@ extern unsigned int processor_id;
#include "prpmc1100.h"
#include "nslu2.h"
@@ -334,8 +334,8 @@
+#include "dsmg600.h"
#endif /* _ASM_ARCH_HARDWARE_H */
---- linux-ixp4xx.orig/include/asm-arm/arch-ixp4xx/irqs.h 2006-02-23 18:29:02.000000000 +0100
-+++ linux-ixp4xx/include/asm-arm/arch-ixp4xx/irqs.h 2006-02-23 18:29:11.000000000 +0100
+--- linux-ixp4xx.orig/include/asm-arm/arch-ixp4xx/irqs.h 2006-03-18 18:10:31.000000000 +0100
++++ linux-ixp4xx/include/asm-arm/arch-ixp4xx/irqs.h 2006-03-18 18:10:34.000000000 +0100
@@ -109,4 +109,14 @@
#define IRQ_NAS100D_PCI_INTD IRQ_IXP4XX_GPIO8
#define IRQ_NAS100D_PCI_INTE IRQ_IXP4XX_GPIO7
@@ -343,11 +343,11 @@
+/*
+ * D-Link DSM-G600 board IRQs
+ */
-+#define IRQ_DSMG600_PCI_INTA IRQ_IXP4XX_GPIO11
-+#define IRQ_DSMG600_PCI_INTB IRQ_IXP4XX_GPIO10
-+#define IRQ_DSMG600_PCI_INTC IRQ_IXP4XX_GPIO9
-+#define IRQ_DSMG600_PCI_INTD IRQ_IXP4XX_GPIO8
-+#define IRQ_DSMG600_PCI_INTE IRQ_IXP4XX_GPIO7
-+#define IRQ_DSMG600_PCI_INTF IRQ_IXP4XX_GPIO6
++#define IRQ_DSMG600_PCI_INTA IRQ_IXP4XX_GPIO11
++#define IRQ_DSMG600_PCI_INTB IRQ_IXP4XX_GPIO10
++#define IRQ_DSMG600_PCI_INTC IRQ_IXP4XX_GPIO9
++#define IRQ_DSMG600_PCI_INTD IRQ_IXP4XX_GPIO8
++#define IRQ_DSMG600_PCI_INTE IRQ_IXP4XX_GPIO7
++#define IRQ_DSMG600_PCI_INTF IRQ_IXP4XX_GPIO6
+
#endif