summaryrefslogtreecommitdiff
path: root/packages/linux/handhelds-pxa-2.6_2.6.15-hh0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/handhelds-pxa-2.6_2.6.15-hh0.bb')
-rw-r--r--packages/linux/handhelds-pxa-2.6_2.6.15-hh0.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/packages/linux/handhelds-pxa-2.6_2.6.15-hh0.bb b/packages/linux/handhelds-pxa-2.6_2.6.15-hh0.bb
deleted file mode 100644
index e85687758e..0000000000
--- a/packages/linux/handhelds-pxa-2.6_2.6.15-hh0.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-SECTION = "kernel"
-DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
-LICENSE = "GPL"
-
-COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = '(h3900|h2200|ipaq-pxa270)'
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
-
-SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
- file://ide_not_removable-r0.patch;patch=1 \
- file://block-pio.patch;patch=1 \
- file://defconfig"
-
-S = "${WORKDIR}/kernel26"
-
-inherit kernel
-
-K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
-K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
-K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
-HHV = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
-
-KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
-do_configure() {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "No default configuration for ${MACHINE} available."
- yes '' | oe_runmake oldconfig
-}
-
-do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
-}
-
-do_deploy[dirs] = "${S}"
-
-addtask deploy before do_build after do_compile