summaryrefslogtreecommitdiff
path: root/packages/linux/ep93xx-kernel_2.6.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/ep93xx-kernel_2.6.15.bb')
-rw-r--r--packages/linux/ep93xx-kernel_2.6.15.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/linux/ep93xx-kernel_2.6.15.bb b/packages/linux/ep93xx-kernel_2.6.15.bb
new file mode 100644
index 0000000000..4af3c65927
--- /dev/null
+++ b/packages/linux/ep93xx-kernel_2.6.15.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xxcompatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://linux-2.6.15-ep93xx-gao19.diff;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "zImage"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+