summaryrefslogtreecommitdiff
path: root/packages/lighttpd/lighttpd_1.4.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/lighttpd/lighttpd_1.4.13.bb')
-rw-r--r--packages/lighttpd/lighttpd_1.4.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/lighttpd/lighttpd_1.4.13.bb b/packages/lighttpd/lighttpd_1.4.13.bb
new file mode 100644
index 0000000000..53aa9ff37f
--- /dev/null
+++ b/packages/lighttpd/lighttpd_1.4.13.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Web server"
+SECTION = "net"
+#DEPENDS = "libpcre openssl"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "http://www.lighttpd.net/download/lighttpd-1.4.13.tar.gz \
+file://${PV}/configure.in.patch;patch=1;pnum=2 file://${PV}/src-server.c.patch;patch=1;pnum=1"
+
+EXTRA_OECONF="--without-bzip2 \
+ --without-ldap \
+ --without-lua \
+ --without-memcache \
+ --without-mysql \
+ --without-pcre \
+ --without-openssl \
+ --without-webdav-locks \
+ --without-webdav-props \
+ --disable-nls \
+ --disable-static"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/mod_*.so"