summaryrefslogtreecommitdiff
path: root/packages/libxml/libxml2_2.6.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libxml/libxml2_2.6.26.bb')
-rw-r--r--packages/libxml/libxml2_2.6.26.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/libxml/libxml2_2.6.26.bb b/packages/libxml/libxml2_2.6.26.bb
new file mode 100644
index 0000000000..192eb14275
--- /dev/null
+++ b/packages/libxml/libxml2_2.6.26.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNOME XML library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2/libxml2-${PV}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --without-c14n"
+
+do_stage() {
+ autotools_stage_all
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/*-config"
+FILES_${PN}-utils += "${bindir}/*"