summaryrefslogtreecommitdiff
path: root/packages/libsdl
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libsdl')
-rw-r--r--packages/libsdl/libsdl-qpe-1.2.9/explicit-extern-C.patch22
-rw-r--r--packages/libsdl/libsdl-qpe-1.2.9/no-PAGE_SIZE.patch11
-rw-r--r--packages/libsdl/libsdl-qpe_1.2.9.bb4
3 files changed, 36 insertions, 1 deletions
diff --git a/packages/libsdl/libsdl-qpe-1.2.9/explicit-extern-C.patch b/packages/libsdl/libsdl-qpe-1.2.9/explicit-extern-C.patch
new file mode 100644
index 0000000000..3dd44bea27
--- /dev/null
+++ b/packages/libsdl/libsdl-qpe-1.2.9/explicit-extern-C.patch
@@ -0,0 +1,22 @@
+--- SDL-1.2.9-orig/src/video/SDL_sysvideo.h.org 2005-04-17 10:40:41.000000000 +0000
++++ SDL-1.2.9-orig/src/video/SDL_sysvideo.h 2007-05-25 07:34:38.000000000 +0000
+@@ -332,6 +332,9 @@
+ SDL_VideoDevice *(*create)(int devindex);
+ } VideoBootStrap;
+
++#ifdef __cplusplus
++extern "C" {
++#endif
+ #ifdef ENABLE_X11
+ extern VideoBootStrap X11_bootstrap;
+ #endif
+@@ -417,6 +420,9 @@
+ #ifdef ENABLE_RISCOS
+ extern VideoBootStrap RISCOS_bootstrap;
+ #endif
++#ifdef __cplusplus
++};
++#endif
+ /* This is the current video device */
+ extern SDL_VideoDevice *current_video;
+
diff --git a/packages/libsdl/libsdl-qpe-1.2.9/no-PAGE_SIZE.patch b/packages/libsdl/libsdl-qpe-1.2.9/no-PAGE_SIZE.patch
new file mode 100644
index 0000000000..856aaf2472
--- /dev/null
+++ b/packages/libsdl/libsdl-qpe-1.2.9/no-PAGE_SIZE.patch
@@ -0,0 +1,11 @@
+--- SDL-1.2.9-orig/src/video/qtopia/SDL_sysvideo.cc.org 2007-05-25 07:07:32.000000000 +0000
++++ SDL-1.2.9-orig/src/video/qtopia/SDL_sysvideo.cc 2007-05-25 07:24:48.000000000 +0000
+@@ -809,7 +809,7 @@
+ current->pitch = finfo.line_length;
+ current->flags = (SDL_FULLSCREEN|SDL_HWSURFACE);
+ mapped_offset = (((long)finfo.smem_start) -
+- (((long)finfo.smem_start)&~(PAGE_SIZE-1)));
++ (((long)finfo.smem_start)&~(getpagesize()-1)));
+ mapped_memlen = finfo.smem_len+mapped_offset;
+ if(console_fd >0 ) {
+ mapped_mem = mmap(NULL, mapped_memlen,PROT_READ|PROT_WRITE, MAP_SHARED, console_fd, 0);
diff --git a/packages/libsdl/libsdl-qpe_1.2.9.bb b/packages/libsdl/libsdl-qpe_1.2.9.bb
index eaca6b88aa..2fbf66b5d8 100644
--- a/packages/libsdl/libsdl-qpe_1.2.9.bb
+++ b/packages/libsdl/libsdl-qpe_1.2.9.bb
@@ -6,7 +6,7 @@ PROVIDES = "virtual/libsdl"
LICENSE = "LGPL"
# NOTE: make sure to keep PR in sync with libsdl-x11
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://agawa-piro-mickey-1.2.9.patch;patch=1 \
@@ -16,6 +16,8 @@ SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://ipaq-1.2.9.patch;patch=1 \
file://SDL-Akita-1.2.9.patch;patch=1 \
file://fixlibs-1.2.9.patch;patch=1 \
+ file://no-PAGE_SIZE.patch;patch=1 \
+ file://explicit-extern-C.patch;patch=1 \
file://acinclude.m4"
S = "${WORKDIR}/SDL-${PV}"