summaryrefslogtreecommitdiff
path: root/packages/libsdl/libsdl-x11_1.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libsdl/libsdl-x11_1.2.7.bb')
-rw-r--r--packages/libsdl/libsdl-x11_1.2.7.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/packages/libsdl/libsdl-x11_1.2.7.bb b/packages/libsdl/libsdl-x11_1.2.7.bb
index b93dde6f2e..80c547b520 100644
--- a/packages/libsdl/libsdl-x11_1.2.7.bb
+++ b/packages/libsdl/libsdl-x11_1.2.7.bb
@@ -1,4 +1,3 @@
-PR = "r3"
DESCRIPTION = "Simple DirectMedia Layer - X11 Edition"
SECTION = "libs"
PRIORITY = "optional"
@@ -7,12 +6,15 @@ DEPENDS = "x11 xext"
PROVIDES = "virtual/libsdl"
LICENSE = "LGPL"
+# NOTE: make sure to keep PR in sync with libsdl-qpe
+PR = "r6"
+
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://extra-keys.patch;patch=1 \
file://acinclude.m4"
S = "${WORKDIR}/SDL-${PV}"
-inherit autotools
+inherit autotools binconfig
EXTRA_OECONF = "--disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
--enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
@@ -23,6 +25,9 @@ EXTRA_OECONF = "--disable-debug --disable-cdrom --enable-threads --enable-timers
--disable-video-opengl --enable-input-events --enable-pthreads \
--disable-video-picogui --disable-video-qtopia --enable-dlopen"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/*config"
+
do_configure_prepend() {
rm -f ${S}/acinclude.m4
cp ${WORKDIR}/acinclude.m4 ${S}/
@@ -47,9 +52,4 @@ do_stage() {
do
install -m 0644 $f ${STAGING_INCDIR}/SDL/
done
-
- cat sdl-config | sed -e "s,-I/usr/include/SDL,-I${STAGING_INCDIR}/SDL," \
- | sed -e "s,libdirs ,mickey_is_cool ," \
- | sed -e "s,-lSDL ,-lSDL-1.2 , "> ${STAGING_BINDIR}/sdl-config
- chmod a+rx ${STAGING_BINDIR}/sdl-config
}