summaryrefslogtreecommitdiff
path: root/packages/libqpe
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libqpe')
-rw-r--r--packages/libqpe/libqpe-opie/citytime-path.patch11
-rw-r--r--packages/libqpe/libqpe-opie/fix-sd-card-path.patch17
-rw-r--r--packages/libqpe/libqpe-opie_1.2.3.bb3
-rw-r--r--packages/libqpe/libqpe-opie_cvs.bb4
4 files changed, 34 insertions, 1 deletions
diff --git a/packages/libqpe/libqpe-opie/citytime-path.patch b/packages/libqpe/libqpe-opie/citytime-path.patch
new file mode 100644
index 0000000000..0abaf146d7
--- /dev/null
+++ b/packages/libqpe/libqpe-opie/citytime-path.patch
@@ -0,0 +1,11 @@
+--- library/tzselect.cpp.orig 2008-01-12 21:05:49.000000000 +1300
++++ library/tzselect.cpp 2008-01-12 21:06:01.000000000 +1300
+@@ -273,7 +273,7 @@
+ void TimeZoneSelector::slotExecute( void )
+ {
+ // execute the world time application...
+- if (QFile::exists(QPEApplication::qpeDir()+"bin/citytime"))
++ if (QFile::exists(OPIE_BINDIR "/citytime"))
+ Global::execute( "citytime" );
+ else
+ QMessageBox::warning(this,tr("citytime executable not found"),
diff --git a/packages/libqpe/libqpe-opie/fix-sd-card-path.patch b/packages/libqpe/libqpe-opie/fix-sd-card-path.patch
new file mode 100644
index 0000000000..32be5d2e7c
--- /dev/null
+++ b/packages/libqpe/libqpe-opie/fix-sd-card-path.patch
@@ -0,0 +1,17 @@
+Index: library/storage.cpp
+===================================================================
+RCS file: /cvs/opie/library/storage.cpp,v
+retrieving revision 1.25
+retrieving revision 1.26
+diff -U3 -r1.25 -r1.26
+--- library/storage.cpp 7 Mar 2005 14:32:58 -0000 1.25
++++ library/storage.cpp 29 Dec 2007 02:14:09 -0000 1.26
+@@ -307,7 +307,7 @@
+ bool hasMmc=false;
+ if( deviceTab("/dev/mmc/part"))
+ hasMmc=true;
+- if( deviceTab("/dev/mmcd"))
++ else if( deviceTab("/dev/mmcblk"))
+ hasMmc=true;
+ return hasMmc;
+ }
diff --git a/packages/libqpe/libqpe-opie_1.2.3.bb b/packages/libqpe/libqpe-opie_1.2.3.bb
index bd2e672fff..a51d6a9225 100644
--- a/packages/libqpe/libqpe-opie_1.2.3.bb
+++ b/packages/libqpe/libqpe-opie_1.2.3.bb
@@ -1,9 +1,12 @@
require ${PN}.inc
+PR = "r2"
TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/library \
file://fix-titleheight.patch;patch=1 \
file://unbreak-logging.patch;patch=1 \
+ file://citytime-path.patch;patch=1 \
+ file://fix-sd-card-path.patch;patch=1 \
"
diff --git a/packages/libqpe/libqpe-opie_cvs.bb b/packages/libqpe/libqpe-opie_cvs.bb
index 10ad8d56ea..e6bf737efa 100644
--- a/packages/libqpe/libqpe-opie_cvs.bb
+++ b/packages/libqpe/libqpe-opie_cvs.bb
@@ -1,9 +1,11 @@
require ${PN}.inc
-PV = "1.2.3+cvs${SRCDATE}"
+PV = "${OPIE_CVS_PV}"
+PR = "r2"
SRC_URI = "${HANDHELDS_CVS};module=opie/library \
file://fix-titleheight.patch;patch=1 \
file://unbreak-logging.patch;patch=1 \
+ file://citytime-path.patch;patch=1 \
"