summaryrefslogtreecommitdiff
path: root/packages/libgpewidget
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libgpewidget')
-rw-r--r--packages/libgpewidget/libgpewidget_0.100.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/libgpewidget/libgpewidget_0.100.bb b/packages/libgpewidget/libgpewidget_0.100.bb
index e69de29bb2..16877362e3 100644
--- a/packages/libgpewidget/libgpewidget_0.100.bb
+++ b/packages/libgpewidget/libgpewidget_0.100.bb
@@ -0,0 +1,19 @@
+LICENSE = "LGPL"
+PR = "r0"
+DESCRIPTION = "libgpewidget contains a collection of widgets and other common code shared by many GPE applications."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+DEPENDS = "gtk+ cairo libxrender gtk-doc intltool-native"
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz"
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = "--enable-cairo"
+
+do_stage () {
+ oe_libinstall -C .libs -so libgpewidget ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+