summaryrefslogtreecommitdiff
path: root/packages/libetpan
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libetpan')
-rw-r--r--packages/libetpan/files/configure-pthreads.patch11
-rw-r--r--packages/libetpan/files/mailstream.patch21
-rw-r--r--packages/libetpan/libetpan_0.45.bb23
3 files changed, 55 insertions, 0 deletions
diff --git a/packages/libetpan/files/configure-pthreads.patch b/packages/libetpan/files/configure-pthreads.patch
new file mode 100644
index 0000000000..c8f9566bd9
--- /dev/null
+++ b/packages/libetpan/files/configure-pthreads.patch
@@ -0,0 +1,11 @@
+--- libetpan-0.45/configure.in.orig 2006-05-09 09:48:36.000000000 +0100
++++ libetpan-0.45/configure.in 2006-05-09 09:48:55.000000000 +0100
+@@ -350,7 +350,7 @@
+ LDFLAGS="-$flag $LDFLAGS"
+ AC_TRY_LINK([], [pthread_create();],
+ [pthflag=yes; checkpthread=no],
+- [pthflag=no; LDFLAGS="$OLDCFLAGS"])
++ [pthflag=no; LDFLAGS="$OLDFLAGS"])
+ AC_MSG_RESULT($pthflag)
+ fi
+ done
diff --git a/packages/libetpan/files/mailstream.patch b/packages/libetpan/files/mailstream.patch
new file mode 100644
index 0000000000..2d0dad06fd
--- /dev/null
+++ b/packages/libetpan/files/mailstream.patch
@@ -0,0 +1,21 @@
+diff -urNad libetpan-0.45~/src/data-types/mailstream_ssl.c libetpan-0.45/src/data-types/mailstream_ssl.c
+--- libetpan-0.45~/src/data-types/mailstream_ssl.c 2006-02-17 23:45:14.000000000 +0300
++++ libetpan-0.45/src/data-types/mailstream_ssl.c 2006-04-17 19:11:48.609551256 +0400
+@@ -448,7 +448,7 @@
+ break;
+
+ default:
+- return r;
++ return -1;
+ }
+ }
+ }
+@@ -486,7 +486,7 @@
+ break;
+
+ default:
+- return r;
++ return -1;
+ }
+ }
+ }
diff --git a/packages/libetpan/libetpan_0.45.bb b/packages/libetpan/libetpan_0.45.bb
new file mode 100644
index 0000000000..b4ea299b9a
--- /dev/null
+++ b/packages/libetpan/libetpan_0.45.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "libetpan is a library for communicating with mail and news servers. \
+It supports the protocols SMTP, POP3, IMAP and NNTP."
+HOMEPAGE = "http://www.etpan.org"
+SECTION = "libs"
+DEPENDS = "gnutls"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
+ file://etpan_suffix.patch;patch=1 \
+ file://mailstream.patch;patch=1 \
+ file://configure-pthreads.patch;patch=1 "
+
+inherit autotools pkgconfig gettext
+
+EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
+
+do_stage() {
+ oe_runmake install includedir=${STAGING_INCDIR} libdir=${STAGING_LIBDIR} bindir=${STAGING_BINDIR}
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"