summaryrefslogtreecommitdiff
path: root/packages/libcwd/libcwd_0.99.44.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libcwd/libcwd_0.99.44.bb')
-rw-r--r--packages/libcwd/libcwd_0.99.44.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/libcwd/libcwd_0.99.44.bb b/packages/libcwd/libcwd_0.99.44.bb
new file mode 100644
index 0000000000..1288ea6e75
--- /dev/null
+++ b/packages/libcwd/libcwd_0.99.44.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Libcwd is a thread-safe, full-featured debugging support library for C++ developers. \
+It includes ostream-based debug output with custom debug channels and devices, \
+powerful memory allocation debugging support, as well as run-time support for \
+printing source line number information and demangled type names."
+SECTION = "devel/libs"
+LICENSE = "QPL"
+HOMEPAGE = "http://libcwd.sourceforge.net"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+PR = "r0"
+
+SRC_URI = "http://puzzle.dl.sourceforge.net/sourceforge/libcwd/libcwd-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+PARALLEL_MAKE = ""
+
+PACKAGES =+ "${PN}-config ${PN}-mt"
+FILES_${PN} = "${libdir}/libcwd.so*"
+FILES_${PN}-mt = "${libdir}/libcwd_r.so*"
+FILES_${PN}-config = "${datadir}"
+RRECOMMENDS_${PN} = "${PN}-config"
+RRECOMMENDS_${PN}-mt = "${PN}-config"