summaryrefslogtreecommitdiff
path: root/packages/keylaunch/keylaunch-conf_2.0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/keylaunch/keylaunch-conf_2.0.10.bb')
-rw-r--r--packages/keylaunch/keylaunch-conf_2.0.10.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/keylaunch/keylaunch-conf_2.0.10.bb b/packages/keylaunch/keylaunch-conf_2.0.10.bb
new file mode 100644
index 0000000000..f9748d29f7
--- /dev/null
+++ b/packages/keylaunch/keylaunch-conf_2.0.10.bb
@@ -0,0 +1,27 @@
+RDEPENDS_append_spitz = " display-brightness"
+RDEPENDS_append_akita = " display-brightness"
+RDEPENDS_append_c7x0 = " display-brightness"
+
+SECTION = "gpe"
+LICENSE = "GPL"
+DESCRIPTION = "Device-specific keylaunch configuration"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PR = "r1"
+
+SRC_URI = " file://keylaunchrc"
+SRC_URI += " file://80chvt-SUID"
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/X11/Xinit.d
+ install ${WORKDIR}/keylaunchrc ${D}${sysconfdir}/keylaunchrc.matchbox
+ install ${WORKDIR}/80chvt-SUID ${D}${sysconfdir}/X11/Xinit.d
+}
+
+pkg_postinst_${PN}() {
+ update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.matchbox 10
+}
+
+pkg_postrm_${PN}() {
+ update-alternatives --remove keylaunchrc /etc/keylaunchrc.matchbox
+}