summaryrefslogtreecommitdiff
path: root/packages/kexecboot/kexecboot_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/kexecboot/kexecboot_0.4.bb')
-rw-r--r--packages/kexecboot/kexecboot_0.4.bb41
1 files changed, 3 insertions, 38 deletions
diff --git a/packages/kexecboot/kexecboot_0.4.bb b/packages/kexecboot/kexecboot_0.4.bb
index 4eed4d0482..c38b2b402c 100644
--- a/packages/kexecboot/kexecboot_0.4.bb
+++ b/packages/kexecboot/kexecboot_0.4.bb
@@ -1,12 +1,4 @@
-LICENSE = "GPL"
-PR = "r4"
-DEPENDS = "klibc"
-RDEPENDS = "kexec-static"
-
-inherit autotools
-
-# You can create your own *-img.h by doing
-# ./make-image-header.sh <file>.png HAND
+PR = "r5"
SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
file://add-reboot-option.patch;patch=1 \
@@ -16,35 +8,8 @@ SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
file://add-sleep.patch;patch=1 \
file://silent-output-hack.patch;patch=1 \
file://kexecboot-tosa.patch;patch=1 \
- file://fb-render-16bit.patch;patch=1 \
- file://logo-img.h \
- file://logo.png \
- "
+ file://fb-render-16bit.patch;patch=1"
S = "${WORKDIR}/kexecboot-${PV}"
-export CC=${TARGET_PREFIX}klcc
-
-# standard oe cflags don't work with klcc
-export CFLAGS = ""
-export CPPFLAGS = ""
-export LDFLAGS = ""
-
-do_configure_prepend () {
- install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
- install -m 0644 ${WORKDIR}/logo.png ${S}/res/
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 kexecboot ${D}${bindir}/
-
- install -d ${D}/proc
- install -d ${D}/mnt
-}
-
-FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
-
-pkg_postinst_${PN} () {
- ln -sf ${bindir}/kexecboot $D/init
-}
+require kexecboot.inc