summaryrefslogtreecommitdiff
path: root/packages/kexec/kexec-tools-static_1.101.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/kexec/kexec-tools-static_1.101.bb')
-rw-r--r--packages/kexec/kexec-tools-static_1.101.bb21
1 files changed, 16 insertions, 5 deletions
diff --git a/packages/kexec/kexec-tools-static_1.101.bb b/packages/kexec/kexec-tools-static_1.101.bb
index ca23917a11..5031b5f923 100644
--- a/packages/kexec/kexec-tools-static_1.101.bb
+++ b/packages/kexec/kexec-tools-static_1.101.bb
@@ -1,12 +1,23 @@
+# the binaries are statical linked against klibc
require kexec-tools.inc
-PR = "r0"
+PR = "r1"
+DEPENDS = "klibc"
-SRC_URI += "file://kexec-static.patch;patch=1"
+SRC_URI += "file://kexec-klibc.patch;patch=1"
S = "${WORKDIR}/kexec-tools-${PV}"
-PACKAGES =+ "kexec-static kdump-static"
+EXTRA_OECONF = " --without-zlib"
-FILES_kexec-static = "${sbindir}/kexec"
-FILES_kdump-static = "${sbindir}/kdump"
+export CC=${TARGET_PREFIX}klcc
+
+# standart oe cflags don't work with klcc
+export CFLAGS=""
+export CPPFLAGS=""
+export LDFLAGS=""
+
+PACKAGES =+ "kexec-klibc kdump-klibc"
+
+FILES_kexec-klibc = "${sbindir}/kexec"
+FILES_kdump-klibc = "${sbindir}/kdump"