summaryrefslogtreecommitdiff
path: root/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch')
-rw-r--r--packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch49
1 files changed, 2 insertions, 47 deletions
diff --git a/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch b/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
index afe472fc1c..11a9db4373 100644
--- a/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
+++ b/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
@@ -1,5 +1,5 @@
---- ixp_osal/Makefile 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/Makefile 1970-01-01 00:00:00.000000000 +0000
+--- ixp400_xscale_sw/Makefile 1970-01-01 00:00:00.000000000 +0000
++++ ixp400_xscale_sw/Makefile 1970-01-01 00:00:00.000000000 +0000
@@ -297,9 +297,9 @@ endif
else # IX_TARGET_OS == vxworks
# linux compiler flags
@@ -24,48 +24,3 @@
################################################################
# Rules to check that macros are defined.
-@@ -1321,10 +1323,26 @@ ixp400.o : $(OBJ_DIR)/ixp400.o
-
- ifndef IX_INCLUDE_MICROCODE
- $(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(OSAL_MODULE)
-+ rm -f $(OBJ_DIR)/ixp400.c
-+ touch $(OBJ_DIR)/ixp400.c
-+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
-+ make -C $(OBJ_DIR)
-+ rm -f $(OBJ_DIR)/ixp400.c
-+ cp ixp400.c $(OBJ_DIR)/ixp400.c
- $(LD) $(LDFLAGS) $^ -o $@
-+ rm -f $(OBJ_DIR)/ixp400.ko $(OBJ_DIR)/ixp400.mod.o
-+ make -C $(OBJ_DIR)
- else
- $(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(NPE_PRODUCTION_HEADER_OBJ) $(OSAL_MODULE)
-+ rm -f $(OBJ_DIR)/ixp400.c
-+ touch $(OBJ_DIR)/ixp400.c
-+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
-+ make -C $(OBJ_DIR)
-+ rm -f $(OBJ_DIR)/ixp400.c
-+ cp ixp400.c $(OBJ_DIR)/ixp400.c
- $(LD) $(LDFLAGS) $^ -o $@
-+ rm -f $(OBJ_DIR)/ixp400.ko $(OBJ_DIR)/ixp400.mod.o
-+ make -C $(OBJ_DIR)
- endif
-
-
---- ixp_osal/ixp400.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/ixp400.c 1970-01-01 00:00:00.000000000 +0000
-@@ -0,0 +1,1 @@
-+#error this file must never be compiled
---- ixp_osal/Makefile.kmod26 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/Makefile.kmod26 1970-01-01 00:00:00.000000000 +0000
-@@ -0,0 +1,11 @@
-+obj-m := ixp400.o
-+
-+PWD := $(shell pwd)
-+
-+LINUX_SRC := $($(IX_TARGET)_KERNEL_DIR)
-+
-+default:
-+ $(MAKE) ARCH=arm CROSS_COMPILE=$(LINUX_CROSS_COMPILE) $(KERNEL_VERBOSE) -C $(LINUX_SRC) SUBDIRS=$(PWD) modules
-+
-+clean:
-+ rm -f ixp400.ko