summaryrefslogtreecommitdiff
path: root/packages/ixp425-eth/ixp425-eth_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ixp425-eth/ixp425-eth_1.2.bb')
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.2.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/ixp425-eth/ixp425-eth_1.2.bb b/packages/ixp425-eth/ixp425-eth_1.2.bb
index 9336e1fe6d..3cc9a6c70a 100644
--- a/packages/ixp425-eth/ixp425-eth_1.2.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.2.bb
@@ -8,7 +8,8 @@ SRC_URI += "file://ixp400linuxethernetdriver-1_2-kernel26_hr_20050929.patch;patc
SRC_URI += "file://makefile.patch;patch=1"
SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
-PR = "r2"
+SRC_URI += "file://modprobe.conf"
+PR = "r4"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"
@@ -18,6 +19,7 @@ S = "${WORKDIR}"
COMPATIBLE_HOST = "^armeb-linux.*"
PROVIDES = "virtual/ixp-eth"
+RPROVIDES = "ixp-eth"
inherit module
@@ -46,4 +48,6 @@ do_compile () {
do_install () {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
install -m 0644 ixp425_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
+ install -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 modprobe.conf ${D}${sysconfdir}/modprobe.d/eth0
}