summaryrefslogtreecommitdiff
path: root/packages/initscripts
diff options
context:
space:
mode:
Diffstat (limited to 'packages/initscripts')
-rw-r--r--packages/initscripts/initscripts-1.0/bootmisc.sh57
-rw-r--r--packages/initscripts/initscripts-1.0/halt31
-rw-r--r--packages/initscripts/initscripts-1.0/reboot17
-rw-r--r--packages/initscripts/initscripts_1.0.bb2
4 files changed, 106 insertions, 1 deletions
diff --git a/packages/initscripts/initscripts-1.0/bootmisc.sh b/packages/initscripts/initscripts-1.0/bootmisc.sh
index e69de29bb2..bd8a0721f1 100644
--- a/packages/initscripts/initscripts-1.0/bootmisc.sh
+++ b/packages/initscripts/initscripts-1.0/bootmisc.sh
@@ -0,0 +1,57 @@
+#
+# bootmisc.sh Miscellaneous things to be done during bootup.
+#
+
+. /etc/default/rcS
+#
+# Put a nologin file in /etc to prevent people from logging in before
+# system startup is complete.
+#
+if test "$DELAYLOGIN" = yes
+then
+ echo "System bootup in progress - please wait" > /etc/nologin
+ cp /etc/nologin /etc/nologin.boot
+fi
+
+#
+# Set pseudo-terminal access permissions.
+#
+if ( ! grep -q devfs /proc/mounts ) && test -c /dev/ttyp0
+then
+ chmod 666 /dev/tty[p-za-e][0-9a-f]
+ chown root:tty /dev/tty[p-za-e][0-9a-f]
+fi
+
+#
+# Update /etc/motd.
+#
+if test "$EDITMOTD" != no
+then
+ uname -a > /etc/motd.tmp
+ sed 1d /etc/motd >> /etc/motd.tmp
+ mv /etc/motd.tmp /etc/motd
+fi
+
+#
+# This is as good a place as any for a sanity check
+# /tmp should be a symlink to /var/tmp to cut down on the number
+# of mounted ramdisks.
+if test ! -L /tmp && test -d /var/tmp
+then
+ rm -rf /tmp
+ ln -sf /var/tmp tmp
+fi
+
+#
+# Update dynamic library cache
+#
+/sbin/ldconfig
+
+#
+# Recover the time, if there is a time file
+#
+if test -e /etc/timestamp
+then
+ date -s `cat /etc/timestamp`
+fi
+: exit 0
diff --git a/packages/initscripts/initscripts-1.0/halt b/packages/initscripts/initscripts-1.0/halt
index e69de29bb2..aa1769606a 100644
--- a/packages/initscripts/initscripts-1.0/halt
+++ b/packages/initscripts/initscripts-1.0/halt
@@ -0,0 +1,31 @@
+#! /bin/sh
+#
+# halt Execute the halt command.
+#
+# Version: @(#)halt 2.84-2 07-Jan-2002 miquels@cistron.nl
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+# Update the timestamp, if there is already one
+if test -e /etc/timestamp
+then
+ date +%2m%2d%2H%2M%Y > /etc/timestamp
+fi
+
+# See if we need to cut the power.
+if test -x /etc/init.d/ups-monitor
+then
+ /etc/init.d/ups-monitor poweroff
+fi
+
+# Don't shut down drives if we're using RAID.
+hddown="-h"
+if grep -qs '^md.*active' /proc/mdstat
+then
+ hddown=""
+fi
+
+halt -d -f -i -p $hddown
+
+: exit 0
diff --git a/packages/initscripts/initscripts-1.0/reboot b/packages/initscripts/initscripts-1.0/reboot
index e69de29bb2..7f95255bd9 100644
--- a/packages/initscripts/initscripts-1.0/reboot
+++ b/packages/initscripts/initscripts-1.0/reboot
@@ -0,0 +1,17 @@
+#! /bin/sh
+#
+# reboot Execute the reboot command.
+#
+# Version: @(#)reboot 2.75 22-Jun-1998 miquels@cistron.nl
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+# Update the timestamp, if there is one
+if test -e /etc/timestamp
+then
+ date +%2m%2d%2H%2M%Y > /etc/timestamp
+fi
+
+echo -n "Rebooting... "
+reboot -d -f -i
diff --git a/packages/initscripts/initscripts_1.0.bb b/packages/initscripts/initscripts_1.0.bb
index d5e9b5ee30..4d10dcf399 100644
--- a/packages/initscripts/initscripts_1.0.bb
+++ b/packages/initscripts/initscripts_1.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "makedevs"
DEPENDS_openzaurus = "makedevs virtual/kernel"
RDEPENDS = "makedevs"
LICENSE = "GPL"
-PR = "r37"
+PR = "r38"
SRC_URI = "file://halt \
file://ramdisk \