summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/base-image.bb78
-rw-r--r--packages/images/console-mipv6-image.bb7
-rw-r--r--packages/images/devimage-image.bb8
-rw-r--r--packages/images/essential-image.bb15
-rw-r--r--packages/images/essential-machine-image.bb23
-rw-r--r--packages/images/initramfs-bootmenu-image.bb11
-rw-r--r--packages/images/minimal-gpe-image.bb24
-rw-r--r--packages/images/minimal-openmoko-image.bb21
-rw-r--r--packages/images/nslu2-base-image.bb14
-rw-r--r--packages/images/nslu2-minimal-image.bb3
-rw-r--r--packages/images/nylon-image-base.bb2
-rw-r--r--packages/images/x11-sato-image.bb29
12 files changed, 187 insertions, 48 deletions
diff --git a/packages/images/base-image.bb b/packages/images/base-image.bb
new file mode 100644
index 0000000000..36760ec499
--- /dev/null
+++ b/packages/images/base-image.bb
@@ -0,0 +1,78 @@
+# This image is intended to provide a basic configuration that allows
+# you to access a newly flashed device over the network or via the
+# native console, and use ipkg to install (from feeds accessible via
+# the network) any further features you require into internal flash
+# memory or onto attached storage.
+
+# It should be as small as possible, while still achieving that goal.
+
+# The rationale for naming it 'base-image' is that this image is the
+# base upon which you can install any other functionality you desire.
+
+# See the end of this file for further rationale and policy regarding
+# the contents of this image, and the criteria which are used to make
+# decisions about adding and removing packages from this image.
+
+# Although it is only fully tested with the Angstrom distro, this
+# image is intended to be distro-agnostic.
+
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+DEPENDS = "\
+ task-boot \
+ task-distro-base task-machine-base \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
+ ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
+ "
+
+IMAGE_INSTALL = "\
+ task-boot \
+ task-distro-base task-machine-base \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
+ ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
+ "
+
+export IMAGE_BASENAME = "base-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+
+# Key features of this image are:
+
+# 1) Must be able to mount attached storage devices like SD cards, CF
+# cards, internal disks, external USB disks, etc. Should support
+# various filesystem choices, but ext2 at a minimum. The rationale
+# for this is that you need storage to be able to install significant
+# new functionality.
+
+# 2) Must be able to boot from internal flash, or directly from a
+# filesystem stored on the attached storage. The rationale for this
+# is that you will want to boot from attached storage instead of
+# messing around with ipkg-link.
+
+# Rationale and policy:
+
+# 'base-image' is the smallest possible image which allows you to ssh
+# into a device via it's native network interface, and install
+# packages from feeds across the network into internal flash or onto
+# an attached storage device.
+
+# It is "larger" than minimal-image (which is strictly only that which
+# is required to boot and get ssh access to the device, and nothing
+# else), but is "smaller" than console-image (which has a whole lot of
+# stuff in it which could easily be ipkg installed after boot rather
+# than being in the initial rootfs).
+
+# It is required to always be small enough to fit in the internal
+# flash rootfs partition of an NSLU2 (as an example of the smaller end
+# of flash sizes that OE supports), and features will be removed from
+# the image to ensure that this is always the case. Any feature that
+# can be installed over the network using the package manager after
+# the first boot is always fair game for removal at any time, and
+# patches are welcome to make base-image as small as possible while
+# still retaining the ability to subsequently install that feature.
diff --git a/packages/images/console-mipv6-image.bb b/packages/images/console-mipv6-image.bb
new file mode 100644
index 0000000000..3c9995cf2e
--- /dev/null
+++ b/packages/images/console-mipv6-image.bb
@@ -0,0 +1,7 @@
+# This image is for testing the ipv6 mobility extensions
+
+require console-image.bb
+IMAGE_INSTALL += " task-mipl "
+
+export IMAGE_BASENAME = "console-mobile-ipv6-image"
+
diff --git a/packages/images/devimage-image.bb b/packages/images/devimage-image.bb
index 6a3e60c5e3..cecd98d644 100644
--- a/packages/images/devimage-image.bb
+++ b/packages/images/devimage-image.bb
@@ -3,12 +3,8 @@
# only shell and dropbear are loaded by default.
# Allows to login via serial and real console or SSH
-DEVIMAGE_EXTRA_RDEPENDS ?= ""
-IMAGE_INSTALL = "devimage busybox dropbear udev \
- module-init-tools pcmciautils \
- wireless-tools wpa-supplicant \
- irda-utils acx-firmware \
- ${DEVIMAGE_EXTRA_RDEPENDS}"
+DEPENDS = "task-devimage"
+IMAGE_INSTALL = "task-devimage"
export IMAGE_BASENAME = "devimage"
IMAGE_LINGUAS = ""
diff --git a/packages/images/essential-image.bb b/packages/images/essential-image.bb
deleted file mode 100644
index 8b566af6ec..0000000000
--- a/packages/images/essential-image.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
-# License: MIT (see COPYING.MIT)
-#
-# Filename: essential-image.bb
-# Date: 23-Apr-06
-
-HOMEPAGE = "http://www.hentges.net/misc/openzaurus/index.shtml"
-
-DEPENDS = "task-essential-to-boot"
-IMAGE_LINGUAS = ""
-IMAGE_INSTALL = "task-essential-to-boot"
-
-inherit image
-
diff --git a/packages/images/essential-machine-image.bb b/packages/images/essential-machine-image.bb
deleted file mode 100644
index b74dec5e35..0000000000
--- a/packages/images/essential-machine-image.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-#
-# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
-# License: MIT (see COPYING.MIT)
-#
-# Filename: essential-machine-image.bb
-# Date: 24-Apr-06
-
-DESCRIPTION = "<description>"
-HOMEPAGE = "http://www.hentges.net/misc/openzaurus/index.shtml"
-
-DEPENDS = "task-essential-to-boot task-essential-parts"
-
-MACHINE_TASKS_akita = "task-essential-to-boot \
- task-essential-pcmcia task-essential-userspace \
- task-essential-usbhost task-essential-usbclient \
- task-essential-sound task-essential-irda \
- task-essential-sd"
-
-IMAGE_LINGUAS = ""
-IMAGE_INSTALL = "${MACHINE_TASKS}"
-export IMAGE_BASENAME = "essential-image"
-
-inherit image \ No newline at end of file
diff --git a/packages/images/initramfs-bootmenu-image.bb b/packages/images/initramfs-bootmenu-image.bb
new file mode 100644
index 0000000000..a495363661
--- /dev/null
+++ b/packages/images/initramfs-bootmenu-image.bb
@@ -0,0 +1,11 @@
+# Sample initramfs image
+
+IMAGE_INSTALL = "busybox-static initramfs-module-bootmenu"
+IMAGE_LINGUAS = ""
+
+# Remove any kernel-image that the kernel-module-* packages may have pulled in.
+PACKAGE_REMOVE = "kernel-image-* update-modules module-init-tools-depmod uclibc update-rc.d"
+ROOTFS_POSTPROCESS_COMMAND += "ipkg-cl ${IPKG_ARGS} -force-depends \
+ remove ${PACKAGE_REMOVE};"
+
+inherit image
diff --git a/packages/images/minimal-gpe-image.bb b/packages/images/minimal-gpe-image.bb
new file mode 100644
index 0000000000..3f475567d2
--- /dev/null
+++ b/packages/images/minimal-gpe-image.bb
@@ -0,0 +1,24 @@
+#Angstrom minimal gpe image
+# This image provides a barebone dm and 'desktop'
+# Very angstrom and ipkg centric
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+export IMAGE_BASENAME = "minimalist-gpe-image"
+
+PR = "r1"
+
+DEPENDS = "task-boot"
+IMAGE_INSTALL = "\
+ ${XSERVER} \
+ task-boot \
+ gpe-dm gpe-session-scripts gpe-login \
+ matchbox-wm \
+ angstrom-feed-configs \
+ ipkg \
+ "
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+
+inherit image
diff --git a/packages/images/minimal-openmoko-image.bb b/packages/images/minimal-openmoko-image.bb
new file mode 100644
index 0000000000..6ab4935c24
--- /dev/null
+++ b/packages/images/minimal-openmoko-image.bb
@@ -0,0 +1,21 @@
+#------------------------------------------------------
+# Minimal OpenMoko Image Recipe
+# This should only have the base system + dialer
+# #------------------------------------------------------
+
+IMAGE_LINGUAS = ""
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+IMAGE_INSTALL = "\
+ task-base \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ task-openmoko-linux \
+ task-openmoko-net \
+ task-openmoko-ui \
+ task-openmoko-base \
+ task-openmoko-phone \
+ "
+
+inherit image
+
+ROOTFS_POSTPROCESS_COMMAND += 'date "+%m%d%H%M%Y" >${IMAGE_ROOTFS}/etc/timestamp'
diff --git a/packages/images/nslu2-base-image.bb b/packages/images/nslu2-base-image.bb
new file mode 100644
index 0000000000..444e9f6a49
--- /dev/null
+++ b/packages/images/nslu2-base-image.bb
@@ -0,0 +1,14 @@
+# Note that this package is intended to create an *identical*
+# kernel and rootfs as the normal base-image.bb
+
+# The only reason for the existence of this .bb file is to
+# create the 8MB and 16MB flashable NSLU2 firmware images.
+
+# Please do not add anything other than the following two
+# lines to this file, and please do not do anything in
+# the nslu2-image class which might affect the kernel
+# or rootfs.
+
+require base-image.bb
+
+inherit nslu2-image
diff --git a/packages/images/nslu2-minimal-image.bb b/packages/images/nslu2-minimal-image.bb
deleted file mode 100644
index db2312c613..0000000000
--- a/packages/images/nslu2-minimal-image.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require minimal-image.bb
-
-INHERIT += nslu2-image
diff --git a/packages/images/nylon-image-base.bb b/packages/images/nylon-image-base.bb
index b4913097be..27dc165800 100644
--- a/packages/images/nylon-image-base.bb
+++ b/packages/images/nylon-image-base.bb
@@ -8,7 +8,7 @@ NYLON_BASE = "base-files base-passwd bash busybox \
mtd-utils \
nano ncurses netbase \
openssh sysvinit \
- timezones tinylogin udev"
+ tzdata tinylogin udev"
DEPENDS += "virtual/kernel less nano"
IMAGE_INSTALL = "kernel less nano elvis-tiny \
diff --git a/packages/images/x11-sato-image.bb b/packages/images/x11-sato-image.bb
new file mode 100644
index 0000000000..1204f22496
--- /dev/null
+++ b/packages/images/x11-sato-image.bb
@@ -0,0 +1,29 @@
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+IMAGE_INSTALL = "\
+ task-base-extended \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ pointercal \
+ matchbox-wm \
+ matchbox-keyboard matchbox-keyboard-applet matchbox-keyboard-im \
+ matchbox-desktop \
+ ${XSERVER} \
+ xserver-kdrive-common xserver-nodm-init \
+ ttf-liberation \
+ xauth xhost xset xrandr \
+ matchbox-sato \
+ matchbox-config-gtk \
+ matchbox-themes-gtk \
+ matchbox-applet-startup-monitor \
+ xcursor-transparent-theme \
+ sato-icon-theme \
+ settings-daemon \
+"
+
+export IMAGE_BASENAME = "${PN}"
+IMAGE_LINGUAS = ""
+
+inherit image
+