summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/angstrom-minimal-image.bb20
-rw-r--r--packages/images/bootstrap-image.bb3
-rw-r--r--packages/images/devimage-image.bb20
-rw-r--r--packages/images/e-image.bb23
-rw-r--r--packages/images/essential-image.bb2
-rw-r--r--packages/images/essential-machine-image.bb2
-rw-r--r--packages/images/gpe-image.bb26
-rw-r--r--packages/images/gpephone-image.bb4
-rw-r--r--packages/images/helloworld-image.bb28
-rw-r--r--packages/images/initramfs-image.bb17
-rw-r--r--packages/images/initramfs-minimal-image.bb15
-rw-r--r--packages/images/maemo-image.bb2
-rw-r--r--packages/images/nylon-image-base.bb5
-rw-r--r--packages/images/nylon-image-mini.bb8
-rw-r--r--packages/images/nylon-image-standard.bb16
-rw-r--r--packages/images/openmoko-devel-image.bb1
-rw-r--r--packages/images/openmoko-image.bb5
-rw-r--r--packages/images/openprotium-image.bb7
-rw-r--r--packages/images/opie-image-16mb.bb69
-rw-r--r--packages/images/opie-image.bb5
-rw-r--r--packages/images/pivotboot-image.bb3
-rw-r--r--packages/images/sectest-gpe-image.bb2
-rw-r--r--packages/images/slugos-image.bb2
-rw-r--r--packages/images/unslung-image.bb50
24 files changed, 218 insertions, 117 deletions
diff --git a/packages/images/angstrom-minimal-image.bb b/packages/images/angstrom-minimal-image.bb
new file mode 100644
index 0000000000..83d814a79a
--- /dev/null
+++ b/packages/images/angstrom-minimal-image.bb
@@ -0,0 +1,20 @@
+#Angstrom minimalist image
+#gives you a small images with ssh access
+LICENSE = "MIT"
+PR = "r3"
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+DISTRO_SSH_DAEMON ?= "dropbear"
+IMAGE_LINGUAS = " "
+
+RDEPENDS = "task-boot \
+ ${DISTRO_SSH_DAEMON} \
+ angstrom-version \
+ "
+
+export IMAGE_BASENAME = "minimalist-image"
+export IMAGE_LINGUAS = ""
+export PACKAGE_INSTALL = "${RDEPENDS}"
+
+inherit image
+
diff --git a/packages/images/bootstrap-image.bb b/packages/images/bootstrap-image.bb
index 1ff60e60e1..f25ad222aa 100644
--- a/packages/images/bootstrap-image.bb
+++ b/packages/images/bootstrap-image.bb
@@ -6,7 +6,4 @@ DEPENDS = "${MACHINE_TASK_PROVIDER}"
inherit image
-FEED_URIS_append_familiar = " x11##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/x11 \
- opie##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/opie"
-
LICENSE = "MIT"
diff --git a/packages/images/devimage-image.bb b/packages/images/devimage-image.bb
new file mode 100644
index 0000000000..e8177433be
--- /dev/null
+++ b/packages/images/devimage-image.bb
@@ -0,0 +1,20 @@
+# Image for kernel debugging and development testing
+# It includes all useful "kernel userspace" utilities, but
+# only shell and dropbear are loaded by default.
+# Allows to login via serial and real console or SSH
+LICENSE = "MIT"
+PR = "r2.2"
+
+DEVIMAGE_EXTRA_RDEPENDS ?= ""
+RDEPENDS = "devimage busybox dropbear udev \
+ module-init-tools pcmciautils \
+ wireless-tools wpa-supplicant \
+ irda-utils acx-firmware \
+ ${DEVIMAGE_EXTRA_RDEPENDS}"
+
+export IMAGE_BASENAME = "devimage"
+export IMAGE_LINGUAS = ""
+
+PACKAGE_INSTALL = "${RDEPENDS}"
+
+inherit image
diff --git a/packages/images/e-image.bb b/packages/images/e-image.bb
index 2f0bef98ef..acd45cd5ae 100644
--- a/packages/images/e-image.bb
+++ b/packages/images/e-image.bb
@@ -1,15 +1,15 @@
require e-image-core.bb
DESCRIPTION = "An X11-based distribution with the Enlightenment Window Manager and Tools"
-PR = "r5"
+PR = "r6"
export IMAGE_BASENAME = "e-image"
export PACKAGE_INSTALL += "task-e-x11-core \
- gpe-task-pim \
- gpe-task-settings \
- gpe-task-apps \
- gpe-task-connectivity \
- gpe-task-games \
- gpe-task-apps-extra \
+ ask-gpe-pim \
+ task-gpe-settings \
+ task-gpe-apps \
+ task-gpe-connectivity \
+ task-gpe-games \
+ task-apps-extra \
figment \
xhost \
gpe-soundserver \
@@ -23,13 +23,8 @@ export PACKAGE_INSTALL += "task-e-x11-core \
gdk-pixbuf-loader-pnm \
gdk-pixbuf-loader-xbm \
gdk-pixbuf-loader-xpm"
-# gdk-pixbuf-loader-pcx \
-# gdk-pixbuf-loader-ico \
-# gdk-pixbuf-loader-ani \
-# gdk-pixbuf-loader-ras \
-# gdk-pixbuf-loader-tga \
-# gdk-pixbuf-loader-wbmp \
-DEPENDS += "task-e-x11-core task-gpe figment xhost gpe-soundserver gpe-confd xauth"
+DEPENDS += "task-e-x11-core task-gpe-base task-gpe-pim task-gpe-settings task-gpe-apps task-gpe-connectivity task-gpe-games \
+ figment xhost gpe-soundserver gpe-confd xauth"
RDEPENDS = "${PACKAGE_INSTALL}"
diff --git a/packages/images/essential-image.bb b/packages/images/essential-image.bb
index 9544b82ead..21078790b7 100644
--- a/packages/images/essential-image.bb
+++ b/packages/images/essential-image.bb
@@ -1,6 +1,6 @@
#
# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
-# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+# License: MIT (see COPYING.MIT)
#
# Filename: essential-image.bb
# Date: 23-Apr-06
diff --git a/packages/images/essential-machine-image.bb b/packages/images/essential-machine-image.bb
index 70ce1e119a..f82f1833dc 100644
--- a/packages/images/essential-machine-image.bb
+++ b/packages/images/essential-machine-image.bb
@@ -1,6 +1,6 @@
#
# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
-# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+# License: MIT (see COPYING.MIT)
#
# Filename: essential-machine-image.bb
# Date: 24-Apr-06
diff --git a/packages/images/gpe-image.bb b/packages/images/gpe-image.bb
index b448c0a9b1..aa851cf68f 100644
--- a/packages/images/gpe-image.bb
+++ b/packages/images/gpe-image.bb
@@ -1,21 +1,20 @@
-FEED_URIS_append_familiar = " x11##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/x11"
-PR = "r20"
+PR = "r22"
export IMAGE_BASENAME = "gpe-image"
GPE_EXTRA_THEMES = "gpe-theme-industrial"
GPE_EXTRA_INSTALL_none = ""
-GPE_EXTRA_INSTALL_bigscreen = "gpe-task-games ${GPE_EXTRA_THEMES}"
-GPE_EXTRA_INSTALL_smallscreen = "gpe-task-games ${GPE_EXTRA_THEMES}"
+GPE_EXTRA_INSTALL_bigscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
+GPE_EXTRA_INSTALL_smallscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
GUI_MACHINE_CLASS ?= "none"
GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
#ship more stuff with devices with >16MB of flash
GPE_BIGFLASH_INSTALL := '${@base_conditional("ROOT_FLASH_SIZE", "16", "", "\
- gpe-task-connectivity \
+ task-gpe-connectivity \
gpe-theme-clearlooks \
figment \
",d)}'
@@ -24,15 +23,22 @@ GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
XSERVER ?= "xserver-kdrive-fbdev"
-DEPENDS = "${MACHINE_TASK_PROVIDER} task-gpe"
+DEPENDS = "${MACHINE_TASK_PROVIDER} \
+ task-gpe-base \
+ task-gpe-apps \
+ task-gpe-pim \
+ task-gpe-settings \
+ task-gpe-games \
+ virtual/xserver"
+
RDEPENDS = "${PACKAGE_INSTALL}"
export PACKAGE_INSTALL = "\
${MACHINE_TASK_PROVIDER} \
- gpe-task-base \
- gpe-task-pim \
- gpe-task-settings \
- gpe-task-apps \
+ task-gpe-base \
+ task-gpe-pim \
+ task-gpe-settings \
+ task-gpe-apps \
${XSERVER} \
${GPE_EXTRA_INSTALL}"
diff --git a/packages/images/gpephone-image.bb b/packages/images/gpephone-image.bb
index e9735f19c4..21496cae55 100644
--- a/packages/images/gpephone-image.bb
+++ b/packages/images/gpephone-image.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
export IMAGE_BASENAME = "gpephone-image"
@@ -20,7 +20,7 @@ GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
XSERVER ?= "xserver-kdrive-fbdev"
-DEPENDS = "${MACHINE_TASK_PROVIDER} task-gpephone"
+DEPENDS = "${MACHINE_TASK_PROVIDER} task-gpephone virtual/xserver"
RDEPENDS = "${PACKAGE_INSTALL}"
export PACKAGE_INSTALL = "\
diff --git a/packages/images/helloworld-image.bb b/packages/images/helloworld-image.bb
new file mode 100644
index 0000000000..058bb7f12a
--- /dev/null
+++ b/packages/images/helloworld-image.bb
@@ -0,0 +1,28 @@
+# Hello world image
+# Contains *only* a statically linked hello world init program
+LICENSE = "MIT"
+PR = "r0"
+
+RDEPENDS = "helloworld"
+
+export IMAGE_BASENAME = "helloworld-image"
+export IMAGE_LINGUAS = ""
+
+PACKAGE_INSTALL = ${RDEPENDS}
+
+inherit image
+
+# Hello world image
+# Contains *only* a statically linked hello world init program
+LICENSE = "MIT"
+PR = "r0"
+
+RDEPENDS = "helloworld"
+
+export IMAGE_BASENAME = "helloworld-image"
+export IMAGE_LINGUAS = ""
+
+PACKAGE_INSTALL = ${RDEPENDS}
+
+inherit image
+
diff --git a/packages/images/initramfs-image.bb b/packages/images/initramfs-image.bb
new file mode 100644
index 0000000000..95e3f84082
--- /dev/null
+++ b/packages/images/initramfs-image.bb
@@ -0,0 +1,17 @@
+# Sample initramfs image
+LICENSE = "MIT"
+PR = "r2"
+
+RDEPENDS = "initramfs-module-block initramfs-module-loop initramfs-module-nfs"
+
+export IMAGE_BASENAME = "initramfs-image"
+export IMAGE_LINGUAS = ""
+
+PACKAGE_INSTALL = "${RDEPENDS}"
+
+# Remove any kernel-image that the kernel-module-* packages may have pulled in.
+PACKAGE_REMOVE = "kernel-image-* update-modules"
+ROOTFS_POSTPROCESS_COMMAND += "ipkg-cl ${IPKG_ARGS} -force-depends \
+ remove ${PACKAGE_REMOVE};"
+
+inherit image
diff --git a/packages/images/initramfs-minimal-image.bb b/packages/images/initramfs-minimal-image.bb
new file mode 100644
index 0000000000..1b60405e74
--- /dev/null
+++ b/packages/images/initramfs-minimal-image.bb
@@ -0,0 +1,15 @@
+# Sample initramfs image
+LICENSE = "MIT"
+PR = "r0"
+
+#RDEPENDS = "initramfs-boot busybox kernel-module-uinput uclibc libgcc1"
+RDEPENDS = "initramfs-nfsboot busybox-static kernel-module-uinput"
+
+export IMAGE_BASENAME = "initramfs-image"
+export IMAGE_LINGUAS = ""
+
+PACKAGE_INSTALL = "${RDEPENDS}"
+# Install only ${PACKAGE_INSTALL}, not even deps
+PACKAGE_INSTALL_NO_DEPS = "1"
+
+inherit image
diff --git a/packages/images/maemo-image.bb b/packages/images/maemo-image.bb
index 2153e427c1..f8f5cb5c9d 100644
--- a/packages/images/maemo-image.bb
+++ b/packages/images/maemo-image.bb
@@ -2,8 +2,6 @@
# Meta package for maemo based system image
#
-FEED_URIS_append_familiar = " maemo##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/maemo"
-
PR = "r2"
export IMAGE_BASENAME = "maemo-image"
diff --git a/packages/images/nylon-image-base.bb b/packages/images/nylon-image-base.bb
index 120cff5822..8cd71194b4 100644
--- a/packages/images/nylon-image-base.bb
+++ b/packages/images/nylon-image-base.bb
@@ -3,13 +3,13 @@ inherit nylon-image
LICENSE = "MIT"
export IMAGE_BASENAME = "nylon-base"
-
+
NYLON_BASE = "base-files base-passwd bash busybox \
ipkg initscripts less \
mtd-utils \
nano ncurses netbase \
openssh sysvinit \
- timezones tinylogin"
+ timezones tinylogin udev"
DEPENDS += "virtual/kernel less nano"
RDEPENDS = "kernel less nano elvis-tiny \
@@ -20,6 +20,7 @@ RDEPENDS_append_mtx-1 = " modutils modutils-initscripts modutils-depmod modutils
RDEPENDS_append_mtx-2 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
## kernel 2.6 ##
RDEPENDS_append_mtx-3 = " module-init-tools udev"
+RDEPENDS_append_mtx-3a = " module-init-tools"
export PACKAGE_INSTALL = "${RDEPENDS}"
diff --git a/packages/images/nylon-image-mini.bb b/packages/images/nylon-image-mini.bb
index e6acd1f2dc..c0ed998449 100644
--- a/packages/images/nylon-image-mini.bb
+++ b/packages/images/nylon-image-mini.bb
@@ -1,5 +1,8 @@
export IMAGE_BASENAME = "nylon-mini"
+inherit image
+LICENSE = "MIT"
+
NYLON_BASE = "base-files base-passwd busybox \
dropbear \
miniinit \
@@ -8,12 +11,9 @@ NYLON_BASE = "base-files base-passwd busybox \
netbase \
wireless-tools"
-RDEPENDS = "kernel \
+RDEPENDS += "kernel \
${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS}"
export PACKAGE_INSTALL = "${RDEPENDS}"
IMAGE_LINGUAS = ""
-
-inherit image
-LICENSE = "MIT"
diff --git a/packages/images/nylon-image-standard.bb b/packages/images/nylon-image-standard.bb
index 29e29cd1eb..ca5f987dfe 100644
--- a/packages/images/nylon-image-standard.bb
+++ b/packages/images/nylon-image-standard.bb
@@ -3,26 +3,18 @@ require nylon-image-base.bb
export IMAGE_BASENAME = "nylon-standard"
NYLON_STANDARD = "\
- bridge-utils \
- dnsmasq \
hostap-utils \
- hostap-daemon \
linux-hotplug \
- ifplugd iproute2 iptables \
- madwifi-modules \
- nylon-scripts \
+ ifplugd \
olsrd \
- ppp pciutils \
+ ppp \
rp-pppoe \
shorewall \
tcpdump \
- usbutils \
- wireless-tools \
- wpa-supplicant \
- yamonenv"
+ wpa-supplicant"
DEPENDS += "hostap-modules ntp \
${NYLON_STANDARD}"
-RDEPENDS += "hostap-modules-pci ntpdate nano elvis-tiny \
+RDEPENDS += "hostap-modules-pci ntpdate less nano elvis-tiny \
${NYLON_STANDARD}"
diff --git a/packages/images/openmoko-devel-image.bb b/packages/images/openmoko-devel-image.bb
index 3f238196a4..9c72533f8d 100644
--- a/packages/images/openmoko-devel-image.bb
+++ b/packages/images/openmoko-devel-image.bb
@@ -1,6 +1,5 @@
require openmoko-image.bb
export PACKAGE_INSTALL += "\
- task-openmoko-demo \
task-openmoko-debug \
"
diff --git a/packages/images/openmoko-image.bb b/packages/images/openmoko-image.bb
index 0ebddcb276..65158f679b 100644
--- a/packages/images/openmoko-image.bb
+++ b/packages/images/openmoko-image.bb
@@ -12,9 +12,10 @@ export PACKAGE_INSTALL = "\
task-openmoko-ui \
task-openmoko-base \
task-openmoko-phone \
- task-openmoko-finger \
+ task-openmoko-games \
task-openmoko-pim \
-"
+ "
+
DEPENDS = "\
${MACHINE_TASK_PROVIDER} \
task-openmoko \
diff --git a/packages/images/openprotium-image.bb b/packages/images/openprotium-image.bb
index 472000f4f0..25d38cf1c3 100644
--- a/packages/images/openprotium-image.bb
+++ b/packages/images/openprotium-image.bb
@@ -83,7 +83,7 @@ RDEPENDS = " \
kernel base-files base-passwd netbase \
busybox initscripts-openprotium openprotium-init \
update-modules sysvinit tinylogin \
- module-init-tools modutils-initscripts \
+ module-init-tools-depmod modutils-initscripts \
ipkg-collateral ipkg ipkg-link \
libgcc1 \
portmap \
@@ -92,11 +92,6 @@ RDEPENDS = " \
mdadm \
hdparm \
mtd-utils \
- sccd \
- util-linux-mount \
- util-linux-umount \
- util-linux-swaponoff \
- util-linux-losetup \
${OPENPROTIUM_SUPPORT} \
${OPENPROTIUM_KERNEL} "
# ${SLUGOS_EXTRA_RDEPENDS}"
diff --git a/packages/images/opie-image-16mb.bb b/packages/images/opie-image-16mb.bb
new file mode 100644
index 0000000000..9c0ed1cacc
--- /dev/null
+++ b/packages/images/opie-image-16mb.bb
@@ -0,0 +1,69 @@
+export IMAGE_BASENAME = "opie-image-16mb"
+export IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+PR = "r1"
+
+DEPENDS = "${MACHINE_TASK_PROVIDER} task-opie-16mb"
+RDEPENDS = "${INSTALL_PACKAGES}"
+
+INSTALL_PACKAGES = "task-boot \
+ ipkg ipkg-collateral \
+ dropbear \
+ task-opie-16mb-base \
+ task-opie-16mb-applets \
+ task-opie-16mb-inputmethods \
+ task-opie-16mb-settings \
+ task-opie-16mb-apps \
+ task-opie-16mb-pim \
+ task-opie-irda"
+
+export PACKAGE_INSTALL = "${INSTALL_PACKAGES}"
+
+# merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
+merge_feeds() {
+
+ if ! test -z "${FEED_URIS}"
+ then
+ # Die gracefully if ipkg-collateral failed
+ if ! test -e "${IMAGE_ROOTFS}/etc/ipkg.conf"
+ then
+ echo "[${IMAGE_ROOTFS}/etc/ipkg.conf] is missing!"
+ exit 1
+ fi
+
+ # comment out existing feed-sources inserted by ipkg-collateral
+ cat ${IMAGE_ROOTFS}/etc/ipkg.conf | sed "s/^src\ /#src\ /" > ${IMAGE_ROOTFS}/etc/ipkg.conf_
+ rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
+
+ # extract, then delete destinations
+ cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
+ cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep -v "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf_
+ rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
+
+
+ for line in ${FEED_URIS}
+ do
+ # strip leading and trailing spaces/tabs, then split into name and uri
+ line_clean="`echo "$line"|sed 's/^[ \t]*//;s/[ \t]*$//'`"
+ feed_name="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\1/p'`"
+ feed_uri="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\2/p'`"
+
+ # insert new feed-sources
+ echo "src/gz $feed_name $feed_uri" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
+ done
+
+ # remove temporary files and rebuild ipkg.conf
+ echo "" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
+ cat ${IMAGE_ROOTFS}/etc/ipkg.conf.dest >> ${IMAGE_ROOTFS}/etc/ipkg.conf
+ rm ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
+
+ # remove -feed.conf files which are no longer needed
+ cd ${IMAGE_ROOTFS}/etc/ipkg/ && rm -- *-feed.conf
+ fi
+}
+
+# merge feed-sources into ipkg.conf and create /etc/timestamp from build date
+IMAGE_PREPROCESS_COMMAND = "merge_feeds; create_etc_timestamp"
+
+inherit image
diff --git a/packages/images/opie-image.bb b/packages/images/opie-image.bb
index 3613ccafde..cd8d7df654 100644
--- a/packages/images/opie-image.bb
+++ b/packages/images/opie-image.bb
@@ -2,7 +2,7 @@ export IMAGE_BASENAME = "opie-image"
export IMAGE_LINGUAS = ""
LICENSE = "MIT"
-PR = "r21"
+PR = "r22"
DEPENDS = "${MACHINE_TASK_PROVIDER} task-opie"
RDEPENDS = "${INSTALL_PACKAGES}"
@@ -14,9 +14,6 @@ INSTALL_PACKAGES = "${MACHINE_TASK_PROVIDER} task-opie-base task-opie-base-apple
task-opie-extra-settings \
task-opie-bluetooth task-opie-irda "
-INSTALL_PACKAGES_spitz_append = "task-opie-extra-games task-opie-extra-apps task-opie-extra-styles"
-INSTALL_PACKAGES_akita_append = "task-opie-extra-games task-opie-extra-apps task-opie-extra-styles"
-
export PACKAGE_INSTALL = "${INSTALL_PACKAGES}"
# merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
diff --git a/packages/images/pivotboot-image.bb b/packages/images/pivotboot-image.bb
index 78c3d7a6e9..529e4cdb83 100644
--- a/packages/images/pivotboot-image.bb
+++ b/packages/images/pivotboot-image.bb
@@ -7,7 +7,4 @@ PR = "r1"
inherit image
-FEED_URIS_append_familiar = " x11##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/x11 \
- opie##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/opie"
-
LICENSE = "MIT"
diff --git a/packages/images/sectest-gpe-image.bb b/packages/images/sectest-gpe-image.bb
index fa16437662..a56991b902 100644
--- a/packages/images/sectest-gpe-image.bb
+++ b/packages/images/sectest-gpe-image.bb
@@ -1,8 +1,6 @@
LICENSE = "MIT"
PR = "r6"
-FEED_URIS_append_familiar = " x11##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/x11"
-
export IMAGE_BASENAME = "sectest-gpe-image"
GPE_EXTRA_THEMES = "\
diff --git a/packages/images/slugos-image.bb b/packages/images/slugos-image.bb
index d78528d700..be746009b6 100644
--- a/packages/images/slugos-image.bb
+++ b/packages/images/slugos-image.bb
@@ -14,7 +14,7 @@ PACKAGE_INSTALL = "task-slugos"
COMPATIBLE_MACHINE = "nslu2"
IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
-IMAGE_FSTYPES = "jffs2"
+IMAGE_FSTYPES = "jffs2 tar.gz"
EXTRA_IMAGECMD_jffs2 += " -D ${SLUGOS_DEVICE_TABLE}"
IMAGE_LINGUAS = ""
diff --git a/packages/images/unslung-image.bb b/packages/images/unslung-image.bb
index 897fb131c1..a24271a9d6 100644
--- a/packages/images/unslung-image.bb
+++ b/packages/images/unslung-image.bb
@@ -1,5 +1,5 @@
LICENSE = "MIT"
-PR = "r25"
+PR = "r26"
COMPATIBLE_MACHINE = "nslu2"
IMAGE_BASENAME = "unslung"
@@ -12,17 +12,11 @@ DEPENDS = "virtual/kernel \
${UNSLUNG_EXTRA_DEPENDS}"
RDEPENDS = "kernel update-modules unslung-rootfs \
- libc6-unslung slingbox ipkg \
- libipkg \
-# cpio \
-# findutils \
+ libc6-unslung slingbox ipkg libipkg \
${UNSLUNG_EXTRA_RDEPENDS}"
PACKAGE_INSTALL = "kernel update-modules unslung-rootfs \
- libc6-unslung slingbox ipkg \
- libipkg \
-# cpio \
-# findutils \
+ libc6-unslung slingbox ipkg libipkg \
kernel-module-netconsole \
${UNSLUNG_EXTRA_INSTALL}"
@@ -76,27 +70,6 @@ unslung_clean_image () {
${STRIP} ${IMAGE_ROOTFS}/lib/libgcc_s.so.1
chmod ugo+x ${IMAGE_ROOTFS}/lib/libgcc_s.so.1
-# MJW - experimental right now, but no longer need cpio and find
- # We need cpio and find, but we don't need any of the other stuff in
- # the packages (users can install the full package with ipkg after
- # unsling). Remove the extra files and executables, and clean up
- # the entries from the ipkg database manually.
-
- #-- these are for cpio:
-# rm -f ${IMAGE_ROOTFS}/usr/bin/mt
-# rm -rf ${IMAGE_ROOTFS}/usr/libexec
-# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/cpio.*
-# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/alternatives/rmt
-# sed -i -e '/^Package: cpio/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
-
- #-- and these for find:
-# rm -f ${IMAGE_ROOTFS}/usr/bin/locate
-# rm -f ${IMAGE_ROOTFS}/usr/bin/updatedb
-# rm -f ${IMAGE_ROOTFS}/usr/bin/xargs
-# rm -f ${IMAGE_ROOTFS}/usr/bin/xargs.findutils
-# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/findutils.*
-# sed -i -e '/^Package: findutils/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
-
# FIXME: change made 24 Jul 2006 by the OE folks changes the "strip"
# behavior to create an extra file named .debug/<filename> containing
# the stripped symbols. These files are supposed to be packaged
@@ -120,20 +93,3 @@ unslung_clean_image () {
# #### End of Hack!
}
-
-nslu2_pack_image () {
- install -d ${DEPLOY_DIR_IMAGE}/slug
- install -m 0644 ${STAGING_LIBDIR}/nslu2-binaries/RedBoot \
- ${STAGING_LIBDIR}/nslu2-binaries/Trailer \
- ${STAGING_LIBDIR}/nslu2-binaries/SysConf \
- ${DEPLOY_DIR_IMAGE}/slug/
- install -m 0644 ${DEPLOY_DIR_IMAGE}/zImage-${IMAGE_BASENAME} ${DEPLOY_DIR_IMAGE}/slug/vmlinuz
- install -m 0644 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 ${DEPLOY_DIR_IMAGE}/slug/flashdisk.jffs2
- cd ${DEPLOY_DIR_IMAGE}/slug
- slugimage -p -b RedBoot -s SysConf -r Ramdisk:1,Flashdisk:flashdisk.jffs2 -t Trailer \
- -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.flashdisk.img
- rm -rf ${DEPLOY_DIR_IMAGE}/slug
-}
-
-EXTRA_IMAGEDEPENDS += 'slugimage-native nslu2-linksys-firmware'
-IMAGE_POSTPROCESS_COMMAND += "nslu2_pack_image; "