summaryrefslogtreecommitdiff
path: root/packages/images/neuros-osd-base-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/images/neuros-osd-base-image.bb')
-rw-r--r--packages/images/neuros-osd-base-image.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/images/neuros-osd-base-image.bb b/packages/images/neuros-osd-base-image.bb
new file mode 100644
index 0000000000..ddf524574a
--- /dev/null
+++ b/packages/images/neuros-osd-base-image.bb
@@ -0,0 +1,18 @@
+# This image is intended to be the base for further neuros images
+
+# Select which Secure Shell Daemon gets included into the rootfs
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+# Include a timestamp that initscripts can use to set the time to a
+# more sane value after a reboot
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+IMAGE_INSTALL = "task-boot \
+ util-linux-mount util-linux-umount \
+ ${DISTRO_SSH_DAEMON} \
+ "
+
+IMAGE_LINGUAS = ""
+
+inherit image
+