summaryrefslogtreecommitdiff
path: root/packages/images/neuros-osd-base-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/images/neuros-osd-base-image.bb')
-rw-r--r--packages/images/neuros-osd-base-image.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/packages/images/neuros-osd-base-image.bb b/packages/images/neuros-osd-base-image.bb
index ddf524574a..d2e39760c8 100644
--- a/packages/images/neuros-osd-base-image.bb
+++ b/packages/images/neuros-osd-base-image.bb
@@ -1,7 +1,15 @@
# This image is intended to be the base for further neuros images
+inherit image
+
+export IMAGE_BASENAME = "Neuros-OSD2-base-image"
+
+PR = "r1"
+
# Select which Secure Shell Daemon gets included into the rootfs
DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_DEV_MANAGER = "mdev"
+PREFERRED_PROVIDER_hotplug = "mdev"
# Include a timestamp that initscripts can use to set the time to a
# more sane value after a reboot
@@ -9,10 +17,10 @@ IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
IMAGE_INSTALL = "task-boot \
util-linux-mount util-linux-umount \
+ e2fsprogs dosfstools \
+ wireless-tools zd1211-firmware \
${DISTRO_SSH_DAEMON} \
- "
+ qt-embedded dbus \
+ "
IMAGE_LINGUAS = ""
-
-inherit image
-