summaryrefslogtreecommitdiff
path: root/packages/hotplug-ng
diff options
context:
space:
mode:
Diffstat (limited to 'packages/hotplug-ng')
-rw-r--r--packages/hotplug-ng/files/flags.patch87
-rw-r--r--packages/hotplug-ng/hotplug-ng_001.bb25
-rw-r--r--packages/hotplug-ng/hotplug-ng_002.bb25
3 files changed, 0 insertions, 137 deletions
diff --git a/packages/hotplug-ng/files/flags.patch b/packages/hotplug-ng/files/flags.patch
deleted file mode 100644
index 1b67ce360f..0000000000
--- a/packages/hotplug-ng/files/flags.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-Index: hotplug-ng-001/Makefile
-===================================================================
---- hotplug-ng-001.orig/Makefile 2005-02-10 17:40:02.000000000 -0600
-+++ hotplug-ng-001/Makefile 2005-02-17 11:22:09.000000000 -0600
-@@ -96,25 +96,28 @@
- then echo "-Os"; else echo "-O2" ; fi}
-
- # add -Wredundant-decls when libsysfs gets cleaned up
--WARNINGS := -Wall
-+WARNINGS = -Wall
-
--CFLAGS := -pipe
-+CFLAGS = -pipe
-+rCFLAGS = -D_GNU_SOURCE
-
- ifeq ($(strip $(USE_LOG)),true)
-- CFLAGS += -DLOG
-+ rCFLAGS += -DLOG
- endif
-
- # if DEBUG is enabled, then we do not strip or optimize
- ifeq ($(strip $(DEBUG)),true)
-- CFLAGS += -O1 -g -DDEBUG -D_GNU_SOURCE
-+ CFLAGS += -O1 -g -DDEBUG
- LDFLAGS += -Wl,-warn-common
- STRIPCMD = /bin/true -Since_we_are_debugging
- else
-- CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer -D_GNU_SOURCE
-+ CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer
- LDFLAGS += -s -Wl,-warn-common
- STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
- endif
-
-+CFLAGS += $(WARNINGS)
-+
- # If we are using our version of klibc, then we need to build, link it, and then
- # link udev against it statically.
- # Otherwise, use glibc and link dynamically.
-@@ -132,8 +135,8 @@
-
- CRT0 = $(KLIBC_DIR)/crt0.o
- LIBC = $(ARCH_LIB_OBJS) $(LIB_OBJS) $(CRT0)
-- CFLAGS += $(WARNINGS) -nostdinc \
-- $(OPTFLAGS) \
-+ CFLAGS += $(OPTFLAGS)
-+ rCFLAGS += -nostdinc \
- -D__KLIBC__ -fno-builtin-printf \
- -I$(KLIBC_FIXUPS_DIR) \
- -include $(KLIBC_FIXUPS_DIR)/klibc_fixups.h \
-@@ -148,17 +151,16 @@
- WARNINGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
- CRT0 =
- LIBC =
-- CFLAGS += $(WARNINGS) -I$(GCCINCDIR)
- LIB_OBJS = -lc
- LDFLAGS =
- endif
-
- ifeq ($(strip $(USE_SELINUX)),true)
-- CFLAGS += -DUSE_SELINUX
-+ rCFLAGS += -DUSE_SELINUX
- LIB_OBJS += -lselinux
- endif
-
--CFLAGS += -I$(PWD)/libsysfs/sysfs \
-+rCFLAGS += -I$(PWD)/libsysfs/sysfs \
- -I$(PWD)/libsysfs
-
- all: $(ROOT) $(MODULE_ALL) $(GEN_CONFIGS)
-@@ -169,7 +171,7 @@
- @if [ ! -r klibc/linux ]; then \
- ln -f -s $(KERNEL_DIR) klibc/linux; \
- fi
-- $(MAKE) -C klibc SUBDIRS=klibc
-+ $(MAKE) -C klibc CFLAGS="$(rCFLAGS) $(CFLAGS)" SUBDIRS=klibc
-
- SYSFS = $(PWD)/libsysfs/sysfs_bus.o \
- $(PWD)/libsysfs/sysfs_class.o \
-@@ -272,7 +274,7 @@
- #.c.o:
- # $(CC) $(CFLAGS) $(DEFS) $(CPPFLAGS) -c -o $@ $<
- .c.o:
-- $(QUIET) $(CC) $(CFLAGS) -c -o $@ $<
-+ $(QUIET) $(CC) $(rCFLAGS) $(CFLAGS) -c -o $@ $<
-
-
- clean:
diff --git a/packages/hotplug-ng/hotplug-ng_001.bb b/packages/hotplug-ng/hotplug-ng_001.bb
deleted file mode 100644
index c76c0f06eb..0000000000
--- a/packages/hotplug-ng/hotplug-ng_001.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
-package with very tiny, compiled executable programs, instead of the \
-existing bash scripts."
-LICENSE = "GPL"
-RPROVIDES = "hotplug"
-RCONFLICTS = "hotplug"
-RREPLACES = "hotplug"
-PR = "r1"
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz \
- file://flags.patch;patch=1"
-S = "${WORKDIR}/hotplug-ng-${PV}"
-
-LD = "${CC}"
-export HOSTCC = "${BUILD_CC}"
-# Stripping should be done when _packaging_, not building
-EXTRA_OEMAKE += "'STRIP=/bin/true'"
-
-export etcdir = "${sysconfdir}"
-export sbindir = "${base_sbindir}"
-export bindir = "${base_bindir}"
-
-do_install () {
- oe_runmake 'DESTDIR=${D}' install
-}
diff --git a/packages/hotplug-ng/hotplug-ng_002.bb b/packages/hotplug-ng/hotplug-ng_002.bb
deleted file mode 100644
index 3c5014be9a..0000000000
--- a/packages/hotplug-ng/hotplug-ng_002.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
-package with very tiny, compiled executable programs, instead of the \
-existing bash scripts."
-LICENSE = "GPL"
-RPROVIDES_${PN} = "hotplug"
-RCONFLICTS_${PN} = "hotplug"
-RREPLACES_${PN} = "hotplug"
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz"
-
-#S = "${WORKDIR}/hotplug-ng-${PV}"
-
-LD = "${CC}"
-export HOSTCC = "${BUILD_CC}"
-CFLAGS = " -I${S}/libsysfs/sysfs"
-# Stripping should be done when _packaging_, not building
-EXTRA_OEMAKE += "'STRIP=/bin/true'"
-
-export etcdir = "${sysconfdir}"
-export sbindir = "${base_sbindir}"
-export bindir = "${base_bindir}"
-
-do_install () {
- oe_runmake 'DESTDIR=${D}' install
-}