summaryrefslogtreecommitdiff
path: root/packages/hal
diff options
context:
space:
mode:
Diffstat (limited to 'packages/hal')
-rw-r--r--packages/hal/consolekit_0.3.0.bb18
-rw-r--r--packages/hal/files/20hal58
-rw-r--r--packages/hal/files/99_hal2
-rw-r--r--packages/hal/files/autoconf.diff11
-rw-r--r--packages/hal/files/dbus-fix-api.patch26
-rw-r--r--packages/hal/files/hal-right-input-h.patch29
-rw-r--r--packages/hal/files/sg-inhibit.patch24
-rw-r--r--packages/hal/gnome-device-manager_0.2.bb11
-rw-r--r--packages/hal/hal-0.5.11/fix-configure.diff22
-rw-r--r--packages/hal/hal-0.5.11/wifi-2.6.27.diff64
-rw-r--r--packages/hal/hal-info.inc20
-rw-r--r--packages/hal/hal-info_20070618.bb1
-rw-r--r--packages/hal/hal-info_20070831.bb16
-rw-r--r--packages/hal/hal-info_20080313.bb1
-rw-r--r--packages/hal/hal-info_20080508.bb1
-rw-r--r--packages/hal/hal-info_git.bb24
-rw-r--r--packages/hal/hal.inc95
-rw-r--r--packages/hal/hal/configure_fix.patch60
-rw-r--r--packages/hal/hal_0.5.11.bb15
-rw-r--r--packages/hal/hal_0.5.9.1.bb92
-rw-r--r--packages/hal/hal_0.5.9.bb3
-rw-r--r--packages/hal/hal_git.bb88
-rw-r--r--packages/hal/ohm/fix_configure.patch39
-rw-r--r--packages/hal/ohm_git.bb45
24 files changed, 0 insertions, 765 deletions
diff --git a/packages/hal/consolekit_0.3.0.bb b/packages/hal/consolekit_0.3.0.bb
deleted file mode 100644
index 9e100b60ca..0000000000
--- a/packages/hal/consolekit_0.3.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "ConsoleKit is a framework for defining and tracking users, login sessions, and seats."
-LICENSE = "GPLv2"
-DEPENDS = "libpam dbus"
-
-inherit gnome
-
-SRC_URI = "http://people.freedesktop.org/~mccann/dist/ConsoleKit-${PV}.tar.bz2"
-S = "${WORKDIR}/ConsoleKit-${PV}"
-
-do_stage () {
- autotools_stage_all
-}
-
-FILES_${PN} += "${libdir}/ConsoleKit ${datadir}/dbus-1"
-
-
-
-
diff --git a/packages/hal/files/20hal b/packages/hal/files/20hal
deleted file mode 100644
index 926bd893e2..0000000000
--- a/packages/hal/files/20hal
+++ /dev/null
@@ -1,58 +0,0 @@
-#! /bin/sh
-#
-# hal Start the Daemon that stores device informations
-# for the Hardware abstraction layer
-#
-# Written by Martin Waitz based on skeleton code
-# written by Miquel van Smoorenburg <miquels@cistron.nl>.
-# Modified for Debian
-# by Ian Murdock <imurdock@gnu.ai.mit.edu>.
-#
-
-PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-DAEMON=/usr/sbin/hald
-PIDDIR=/var/run/hald
-PIDFILE=$PIDDIR/pid
-NAME=hald
-DAEMONUSER=haldaemon
-DESC="Hardware abstraction layer"
-
-test -x $DAEMON || exit 0
-
-set -e
-
-do_start() {
- if [ ! -d $PIDDIR ]; then
- mkdir -p $PIDDIR
- chown $DAEMONUSER:$DAEMONUSER $PIDDIR
- fi
- echo "Starting $DESC" "$NAME"
- start-stop-daemon --start --pidfile $PIDFILE \
- --exec $DAEMON -- $DAEMON_OPTS
-}
-
-do_stop() {
- echo "Stopping $DESC" "$NAME"
- start-stop-daemon --stop --quiet --pidfile $PIDFILE \
- --exec $DAEMON
-}
-
-case "$1" in
- start)
- do_start
- ;;
- stop)
- do_stop
- ;;
- restart|force-reload)
- do_stop
- sleep 5
- do_start
- ;;
- *)
- echo "Usage: $0 {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/hal/files/99_hal b/packages/hal/files/99_hal
deleted file mode 100644
index c82da990ba..0000000000
--- a/packages/hal/files/99_hal
+++ /dev/null
@@ -1,2 +0,0 @@
-d root root 0700 /var/run/hald none
-d haldaemon haldaemon 0755 /var/cache/hald none
diff --git a/packages/hal/files/autoconf.diff b/packages/hal/files/autoconf.diff
deleted file mode 100644
index eb30cccdbe..0000000000
--- a/packages/hal/files/autoconf.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- hal-0.5.9/configure.in~ 2007-04-03 05:36:44.000000000 +0100
-+++ hal-0.5.9/configure.in 2007-04-03 10:29:39.000000000 +0100
-@@ -6,7 +6,7 @@
- # Patches for that is welcome.
- #
-
--AC_PREREQ(2.59c)
-+AC_PREREQ(2.59)
- AC_INIT(hal, 0.5.9, david@fubar.dk)
- AM_INIT_AUTOMAKE(hal, 0.5.9)
- AM_CONFIG_HEADER(config.h)
diff --git a/packages/hal/files/dbus-fix-api.patch b/packages/hal/files/dbus-fix-api.patch
deleted file mode 100644
index 1f025870bc..0000000000
--- a/packages/hal/files/dbus-fix-api.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: hal-0.5.7/tools/lshal.c
-===================================================================
---- hal-0.5.7.orig/tools/lshal.c 2006-02-13 14:35:31.000000000 +0000
-+++ hal-0.5.7/tools/lshal.c 2006-11-09 13:48:07.000000000 +0000
-@@ -701,7 +701,7 @@
- libhal_ctx_shutdown (hal_ctx, &error);
- libhal_ctx_free (hal_ctx);
-
-- dbus_connection_disconnect (conn);
-+ dbus_connection_close (conn);
- dbus_connection_unref (conn);
-
- if (show_device)
-Index: hal-0.5.7/tools/hal-device.c
-===================================================================
---- hal-0.5.7.orig/tools/hal-device.c 2006-11-09 13:49:44.000000000 +0000
-+++ hal-0.5.7/tools/hal-device.c 2006-11-09 13:50:00.000000000 +0000
-@@ -155,7 +155,7 @@
-
- libhal_ctx_shutdown(hal_ctx, &error);
- libhal_ctx_free(hal_ctx);
-- dbus_connection_disconnect(conn);
-+ dbus_connection_close(conn);
- dbus_connection_unref(conn);
- dbus_error_free(&error);
-
diff --git a/packages/hal/files/hal-right-input-h.patch b/packages/hal/files/hal-right-input-h.patch
deleted file mode 100644
index f820b7790a..0000000000
--- a/packages/hal/files/hal-right-input-h.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/configure.in b/configure.in
-index e76ff51..5e8cc21 100644
---- a/configure.in
-+++ b/configure.in
-@@ -983,6 +983,11 @@ AC_ARG_WITH([linux-input-header],
- [Use an given Linux input.h rather than that installed on the system (<linux/input.h>)]))
- if test "x$with_linux_input_header" != "x"; then
- AC_DEFINE_UNQUOTED(HAL_LINUX_INPUT_HEADER_H, "$with_linux_input_header", [If set, the header to use instead of <linux/input.h>])
-+ LINUX_INPUT_H=$with_linux_input_header
-+ AC_SUBST(LINUX_INPUT_H)
-+else
-+ LINUX_INPUT_H=/usr/include/linux/input.h
-+ AC_SUBST(LINUX_INPUT_H)
- fi
-
- dnl
-diff --git a/tools/Makefile.am b/tools/Makefile.am
-index ae03edd..7d1cbab 100644
---- a/tools/Makefile.am
-+++ b/tools/Makefile.am
-@@ -79,7 +79,7 @@ endif
- if BUILD_KEYMAPS
-
- if HAVE_GPERF
--hal-setup-keymap-keys.txt: /usr/include/linux/input.h
-+hal-setup-keymap-keys.txt: @LINUX_INPUT_H@
- awk '/^#define.*KEY_/ { if ($$2 != "KEY_MAX") { print substr($$2, 5) } }' < $< > $@
-
- hal-setup-keymap-hash-name.gperf: hal-setup-keymap-keys.txt
diff --git a/packages/hal/files/sg-inhibit.patch b/packages/hal/files/sg-inhibit.patch
deleted file mode 100644
index f0cc41448a..0000000000
--- a/packages/hal/files/sg-inhibit.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- hal-0.5.9.1/hald/linux/probing/linux_dvd_rw_utils.c.old 2007-08-03 17:24:12.000000000 +0100
-+++ hal-0.5.9.1/hald/linux/probing/linux_dvd_rw_utils.c 2007-08-03 17:25:06.000000000 +0100
-@@ -58,6 +58,10 @@
-
- #include "linux_dvd_rw_utils.h"
-
-+#if defined(SG_FLAG_UNUSED_LUN_INHIBIT)
-+# define SG_FLAG_LUN_INHIBIT SG_FLAG_UNUSED_LUN_INHIBIT
-+#endif
-+
- typedef enum {
- NONE = CGC_DATA_NONE, // 3
- READ = CGC_DATA_READ, // 2
-@@ -153,8 +153,8 @@
- errno = EIO;
- ret = -1;
- if (cmd->sg_io.masked_status & CHECK_CONDITION) {
-- CREAM_ON_ERRNO (cmd->sg_io.sbp);
-- ret = ERRCODE (cmd->sg_io.sbp);
-+ CREAM_ON_ERRNO ((char*)cmd->sg_io.sbp);
-+ ret = ERRCODE ((char*)cmd->sg_io.sbp);
- if (ret == 0)
- ret = -1;
- }
diff --git a/packages/hal/gnome-device-manager_0.2.bb b/packages/hal/gnome-device-manager_0.2.bb
deleted file mode 100644
index 9b79650c2e..0000000000
--- a/packages/hal/gnome-device-manager_0.2.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-DESCRIPTION = "Device viewer with a GTK+ UI"
-LICENSE = "GPL/LGPL"
-DEPENDS = "libgnomeui hal gtk+"
-
-inherit gnome
-
-SRC_URI = "http://hal.freedesktop.org/releases/gnome-device-manager-${PV}.tar.bz2"
-
-FILES_${PN} += "${datadir}/icons"
-
-
diff --git a/packages/hal/hal-0.5.11/fix-configure.diff b/packages/hal/hal-0.5.11/fix-configure.diff
deleted file mode 100644
index 7d9d42d69f..0000000000
--- a/packages/hal/hal-0.5.11/fix-configure.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-From: Rémi Cardona <remi@gentoo.org>
-Date: Sat, 9 Aug 2008 15:04:07 +0000 (+0200)
-Subject: add libtool-2.2 support
-X-Git-Url: http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=c8a1aedf87bbb200fc5daa0ec8559a2d84fbb61d
-
-add libtool-2.2 support
-
-Fix for aclocal to work properly with libtool 2.2 which no longer
-checks for C++ automatically (this patch is of course backwards
-compatible with libtool 1.5.x)
----
-
---- a/configure.in
-+++ b/configure.in
-@@ -29,6 +29,7 @@ AC_SUBST(LT_AGE)
-
- AC_ISC_POSIX
- AC_PROG_CC
-+AC_PROG_CXX
- AM_PROG_CC_C_O
- AC_HEADER_STDC
- AC_PROG_LIBTOOL
diff --git a/packages/hal/hal-0.5.11/wifi-2.6.27.diff b/packages/hal/hal-0.5.11/wifi-2.6.27.diff
deleted file mode 100644
index 4b41c2881c..0000000000
--- a/packages/hal/hal-0.5.11/wifi-2.6.27.diff
+++ /dev/null
@@ -1,64 +0,0 @@
-Index: hal-0.5.11/hald/linux/device.c
-===================================================================
---- hal-0.5.11.orig/hald/linux/device.c
-+++ hal-0.5.11/hald/linux/device.c
-@@ -45,6 +45,10 @@
- #include <linux/input.h>
- #endif
-
-+/* for wireless extensions */
-+#include <linux/if.h>
-+#include <linux/wireless.h>
-+
- #include <dbus/dbus.h>
- #include <dbus/dbus-glib.h>
-
-@@ -532,10 +536,14 @@ net_add (const gchar *sysfs_path, const
- const char *addr;
- const char *parent_subsys;
- char bridge_path[HAL_PATH_MAX];
-- char wireless_path[HAL_PATH_MAX];
-- char wiphy_path[HAL_PATH_MAX];
-+ char phy80211_path[HAL_PATH_MAX];
- struct stat s;
- dbus_uint64_t mac_address = 0;
-+ int ioctl_fd;
-+ struct iwreq iwr;
-+
-+ ioctl_fd = socket (PF_INET, SOCK_DGRAM, 0);
-+ strncpy (iwr.ifr_ifrn.ifrn_name, ifname, IFNAMSIZ);
-
- addr = hal_device_property_get_string (d, "net.address");
- if (addr != NULL) {
-@@ -554,9 +562,8 @@ net_add (const gchar *sysfs_path, const
- }
-
- snprintf (bridge_path, HAL_PATH_MAX, "%s/bridge", sysfs_path);
-- snprintf (wireless_path, HAL_PATH_MAX, "%s/wireless", sysfs_path);
-- /* wireless dscape stack e.g. from rt2500pci driver*/
-- snprintf (wiphy_path, HAL_PATH_MAX, "%s/wiphy", sysfs_path);
-+ /* cfg80211 */
-+ snprintf (phy80211_path, HAL_PATH_MAX, "%s/phy80211", sysfs_path);
- parent_subsys = hal_device_property_get_string (parent_dev, "info.subsystem");
-
- if (parent_subsys && strcmp(parent_subsys, "bluetooth") == 0) {
-@@ -564,8 +571,8 @@ net_add (const gchar *sysfs_path, const
- hal_device_property_set_string (d, "info.category", "net.bluetooth");
- hal_device_add_capability (d, "net.bluetooth");
- hal_device_property_set_uint64 (d, "net.bluetooth.mac_address", mac_address);
-- } else if ((stat (wireless_path, &s) == 0 && (s.st_mode & S_IFDIR)) ||
-- (stat (wiphy_path, &s) == 0 && (s.st_mode & S_IFDIR))) {
-+ } else if ((ioctl (ioctl_fd, SIOCGIWNAME, &iwr) == 0) ||
-+ (stat (phy80211_path, &s) == 0 && (s.st_mode & S_IFDIR))) {
- hal_device_property_set_string (d, "info.product", "WLAN Interface");
- hal_device_property_set_string (d, "info.category", "net.80211");
- hal_device_add_capability (d, "net.80211");
-@@ -581,6 +588,8 @@ net_add (const gchar *sysfs_path, const
- hal_device_add_capability (d, "net.80203");
- hal_device_property_set_uint64 (d, "net.80203.mac_address", mac_address);
- }
-+
-+ close (ioctl_fd);
- } else if (media_type == ARPHRD_IRDA) {
- hal_device_property_set_string (d, "info.product", "Networking Interface");
- hal_device_property_set_string (d, "info.category", "net.irda");
diff --git a/packages/hal/hal-info.inc b/packages/hal/hal-info.inc
deleted file mode 100644
index 635fd0aa41..0000000000
--- a/packages/hal/hal-info.inc
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer device information"
-HOMEPAGE = "http://hal.freedesktop.org/"
-SECTION = "unknown"
-LICENSE = "GPL AFL"
-
-SRC_URI = "http://hal.freedesktop.org/releases/${PN}-${PV}.tar.gz"
-S = "${WORKDIR}/${PN}-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-recall --disable-video"
-
-do_configure() {
- gnu-configize
- libtoolize --force
- oe_runconf
-}
-
-PACKAGE_ARCH = "all"
-FILES_${PN} += "${datadir}/hal/"
diff --git a/packages/hal/hal-info_20070618.bb b/packages/hal/hal-info_20070618.bb
deleted file mode 100644
index e6d50e3981..0000000000
--- a/packages/hal/hal-info_20070618.bb
+++ /dev/null
@@ -1 +0,0 @@
-require hal-info.inc
diff --git a/packages/hal/hal-info_20070831.bb b/packages/hal/hal-info_20070831.bb
deleted file mode 100644
index a379254937..0000000000
--- a/packages/hal/hal-info_20070831.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer device information"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL AFL"
-DEPENDS = "hal"
-
-SRC_URI = "git://anongit.freedesktop.org/hal-info/;protocol=git;tag=HAL_INFO_${PV}"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-recall --disable-video"
-
-PACKAGE_ARCH = "all"
-FILES_${PN} += "/usr/share/hal/"
diff --git a/packages/hal/hal-info_20080313.bb b/packages/hal/hal-info_20080313.bb
deleted file mode 100644
index e6d50e3981..0000000000
--- a/packages/hal/hal-info_20080313.bb
+++ /dev/null
@@ -1 +0,0 @@
-require hal-info.inc
diff --git a/packages/hal/hal-info_20080508.bb b/packages/hal/hal-info_20080508.bb
deleted file mode 100644
index e6d50e3981..0000000000
--- a/packages/hal/hal-info_20080508.bb
+++ /dev/null
@@ -1 +0,0 @@
-require hal-info.inc
diff --git a/packages/hal/hal-info_git.bb b/packages/hal/hal-info_git.bb
deleted file mode 100644
index 48192a8e7e..0000000000
--- a/packages/hal/hal-info_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer device information"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL AFL"
-DEPENDS = "hal"
-
-PV = "${SRCDATE}+git"
-PR = "r2"
-
-
-SRC_URI = "git://anongit.freedesktop.org/hal-info/;protocol=git;rev=HAL_INFO_20070831"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-recall --disable-video"
-
-
-PACKAGE_ARCH = "all"
-FILES_${PN} += "${datadir}/hal/"
-
-# By default, use the released hal-info
-DEFAULT_PREFERENCE = "-1"
diff --git a/packages/hal/hal.inc b/packages/hal/hal.inc
deleted file mode 100644
index f8ef0e4398..0000000000
--- a/packages/hal/hal.inc
+++ /dev/null
@@ -1,95 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL LGPL AFL"
-
-SRC_URI = "http://hal.freedesktop.org/releases/hal-${PV}.tar.gz"
-
-S = "${WORKDIR}/hal-${PV}"
-
-inherit autotools pkgconfig
-
-DEPENDS = "virtual/kernel dbus-glib udev intltool intltool-native expat libusb gperf-native"
-RDEPENDS += "hal-info udev-utils"
-
-SRC_URI += "file://99_hal \
- file://20hal \
- "
-
-LEAD_SONAME = "libhal.so"
-
-# machines with pci and acpi get a machine dependant hal
-EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
- --with-expat=${STAGING_LIBDIR}/.. \
- --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
- --with-hotplug=${sysconfdir}/hotplug.d \
- --disable-docbook-docs \
- --disable-policy-kit \
- --disable-pmu \
- --disable-pnp-ids \
- ${@base_contains('COMBINED_FEATURES', 'pci', '--enable-pci --enable-pci-ids', '--disable-pci --disable-pci-ids',d)} \
- ${@base_contains('MACHINE_FEATURES', 'acpi', '--enable-acpi', '--disable-acpi',d)} \
- "
-
-MY_ARCH := "${PACKAGE_ARCH}"
-PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'acpi', '${MACHINE_ARCH}', '${MY_ARCH}',d)}"
-PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}',d)}"
-
-do_install_append() {
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
- install -d ${D}/etc/dbus-1/event.d
- install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
-}
-
-do_stage() {
- oe_libinstall -C libhal -a -so libhal ${STAGING_LIBDIR}
- oe_libinstall -C libhal-storage -a -so libhal-storage ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/hal
- install -m 0644 libhal/libhal.h ${STAGING_INCDIR}/hal
- install -m 0644 libhal-storage/libhal-storage.h ${STAGING_INCDIR}/hal
-}
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-pkg_postinst_hal () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep haldaemon /etc/group || addgroup haldaemon
- grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
-
- /etc/init.d/populate-volatile.sh update
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-pkg_postrm_hal () {
- deluser haldaemon || true
- delgroup haldaemon || true
-}
-
-FILES_${PN} = "${sysconfdir} \
- ${bindir}/hal-disable-polling \
- ${bindir}/hal-setup-keymap \
- ${bindir}/lshal \
- ${bindir}/hal-find-by-capability \
- ${bindir}/hal-find-by-property \
- ${bindir}/hal-device \
- ${bindir}/hal-get-property \
- ${bindir}/hal-set-property \
- ${bindir}/hal-lock \
- ${bindir}/hal-is-caller-locked-out \
- ${sbindir} \
- ${libdir}/libhal.so.* \
- ${libdir}/libhal-storage.so.* \
- ${libdir}/hal \
- ${libexecdir} \
- ${datadir}/hal/fdi \
- ${datadir}/hal/scripts"
diff --git a/packages/hal/hal/configure_fix.patch b/packages/hal/hal/configure_fix.patch
deleted file mode 100644
index e8417040de..0000000000
--- a/packages/hal/hal/configure_fix.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-The AC_LANG sections upset libtool 2.2.2, as do .cpp files without a call
-to AC_PROG_CXX. Easiest solution is to patch this out for now.
-
-RP - 14/4/08
-
-Index: hal-0.5.9.1/configure.in
-===================================================================
---- hal-0.5.9.1.orig/configure.in 2008-04-14 22:41:49.000000000 +0100
-+++ hal-0.5.9.1/configure.in 2008-04-14 22:43:13.000000000 +0100
-@@ -345,32 +345,8 @@
- fi
-
- dnl Check for libsmbios
--AC_LANG_PUSH([C++])
--AC_CHECK_LIB(smbios, SMBIOSFreeMemory, LIB_SMBIOS=yes , LIB_SMBIOS=no )
--AC_LANG_POP([C++])
--if test "$LIB_SMBIOS" = "yes" ; then
-- AC_MSG_CHECKING([for libsmbios >= 0.13.4])
-- AC_TRY_RUN(
-- #include <smbios/version.h>
-- int main ()
-- {
-- int major ;
-- int minor ;
-- int micro ;
--
-- if ( sscanf( LIBSMBIOS_RELEASE_VERSION , "%d.%d.%d", &major, &minor, &micro ) == 3 ) {
-- if ((major == 0 && minor == 13 && micro >= 4) ||
-- (major >= 0 && minor > 13)) {
-- return 0;
-- }
-- }
-- return 1;
-- } , [USE_SMBIOS=yes; AC_MSG_RESULT(yes); AM_CONDITIONAL(HAVE_SMBIOS,true)],
-- [USE_SMBIOS=no; AC_MSG_RESULT(failed); AM_CONDITIONAL(HAVE_SMBIOS,false)])
--else
-- USE_SMBIOS=no
-- AM_CONDITIONAL(HAVE_SMBIOS,false)
--fi
-+USE_SMBIOS=no
-+AM_CONDITIONAL(HAVE_SMBIOS,false)
-
- AC_ARG_WITH([libpci],
- [AS_HELP_STRING([--without-libpci],
-Index: hal-0.5.9.1/hald/linux/addons/Makefile.am
-===================================================================
---- hal-0.5.9.1.orig/hald/linux/addons/Makefile.am 2008-04-14 22:45:18.000000000 +0100
-+++ hal-0.5.9.1/hald/linux/addons/Makefile.am 2008-04-14 22:46:05.000000000 +0100
-@@ -60,11 +60,6 @@
- hald_addon_usb_csr_LDADD = $(top_builddir)/libhal/libhal.la -lusb @GLIB_LIBS@
- endif
-
--if BUILD_DELL
--libexec_PROGRAMS += hald-addon-dell-backlight
--hald_addon_dell_backlight_SOURCES = addon-dell-backlight.cpp ../../logger.c
--hald_addon_dell_backlight_LDADD = $(top_builddir)/libhal/libhal.la -lsmbios @GLIB_LIBS@
--endif
- endif
-
- hald_addon_acpi_SOURCES = addon-acpi.c ../../logger.c ../../util_helper.c
diff --git a/packages/hal/hal_0.5.11.bb b/packages/hal/hal_0.5.11.bb
deleted file mode 100644
index 3b5888a863..0000000000
--- a/packages/hal/hal_0.5.11.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-require hal.inc
-
-PR = "r5"
-
-SRC_URI += " file://hal-right-input-h.patch;patch=1 \
- file://fix-configure.diff;patch=1 \
- file://wifi-2.6.27.diff;patch=1"
-
-# The following code finds the right linux/input.h,
-# which also works with external-toolchain/SDK
-do_configure() {
- linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
- grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
- autotools_do_configure --with-linux-input-header=${linux_input_h}
-}
diff --git a/packages/hal/hal_0.5.9.1.bb b/packages/hal/hal_0.5.9.1.bb
deleted file mode 100644
index ecc98e10bc..0000000000
--- a/packages/hal/hal_0.5.9.1.bb
+++ /dev/null
@@ -1,92 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL LGPL AFL"
-
-DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb-compat"
-RDEPENDS_${PN} += "udev-utils hal-info"
-
-PR = "r9"
-
-SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
- file://configure_fix.patch;patch=1 \
- file://sg-inhibit.patch;patch=1 \
- file://20hal \
- file://99_hal"
-
-S = "${WORKDIR}/hal-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
- --with-expat=${STAGING_DIR_HOST}${layout_prefix} \
- --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
- --with-hotplug=${sysconfdir}/hotplug.d \
- --disable-docbook-docs \
- --disable-policy-kit \
- --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
- --disable-sonypic \
- --disable-pmu --disable-pci \
- --disable-pci-ids --disable-pnp-ids \
- "
-
-do_install_append() {
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
- install -d ${D}/etc/dbus-1/event.d
- install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
-}
-
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_LIBDIR}
- install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
- install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
-}
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-pkg_postinst_hal () {
- # can not do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep haldaemon /etc/group || addgroup haldaemon
- grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
-
- /etc/init.d/populate-volatile.sh update
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 reload
- fi
-}
-
-pkg_postrm_hal () {
- deluser haldaemon || true
- delgroup haldaemon || true
-}
-
-PACKAGES =+ "libhal libhal-storage"
-
-FILES_libhal = "${libdir}/libhal.so.*"
-FILES_libhal-storage = "${libdir}/libhal-storage.so.*"
-
-FILES_${PN} = "${sysconfdir} \
- ${bindir}/lshal \
- ${bindir}/hal-find-by-capability \
- ${bindir}/hal-find-by-property \
- ${bindir}/hal-device \
- ${bindir}/hal-get-property \
- ${bindir}/hal-set-property \
- ${bindir}/hal-lock \
- ${bindir}/hal-is-caller-locked-out \
- ${bindir}/hal-disable-polling \
- ${sbindir} \
- ${libdir}/libhal.so.* \
- ${libdir}/libhal-storage.so.* \
- ${libdir}/hal \
- ${libexecdir} \
- ${datadir}/hal/fdi \
- ${datadir}/hal/scripts"
diff --git a/packages/hal/hal_0.5.9.bb b/packages/hal/hal_0.5.9.bb
deleted file mode 100644
index 1993304545..0000000000
--- a/packages/hal/hal_0.5.9.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require hal.inc
-PR = "r9"
-
diff --git a/packages/hal/hal_git.bb b/packages/hal/hal_git.bb
deleted file mode 100644
index 5fcd7433ed..0000000000
--- a/packages/hal/hal_git.bb
+++ /dev/null
@@ -1,88 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL LGPL AFL"
-
-DEFAULT_PREFERENCE = "-1"
-
-DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb-compat"
-RDEPENDS_${PN} += "udev-utils hal-info"
-
-SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
- file://20hal \
- file://99_hal"
-
-PV = "0.5.9.1+git${SRCDATE}"
-PR = "r7"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
- --with-expat=${STAGING_DIR_HOST}${layout_prefix} \
- --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
- --with-hotplug=${sysconfdir}/hotplug.d \
- --disable-docbook-docs \
- --disable-policy-kit \
- --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
- --disable-sonypic \
- --disable-pmu --disable-pci \
- --disable-pci-ids --disable-pnp-ids \
- "
-
-do_install_append() {
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
- install -d ${D}/etc/dbus-1/event.d
- install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
-}
-
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_LIBDIR}
- install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
- install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
-}
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-pkg_postinst_hal () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep haldaemon /etc/group || addgroup haldaemon
- grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
-
- /etc/init.d/populate-volatile.sh update
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 reload
- fi
-}
-
-pkg_postrm_hal () {
- deluser haldaemon || true
- delgroup haldaemon || true
-}
-
-FILES_${PN} = "${sysconfdir} \
- ${bindir}/lshal \
- ${bindir}/hal-find-by-capability \
- ${bindir}/hal-find-by-property \
- ${bindir}/hal-device \
- ${bindir}/hal-get-property \
- ${bindir}/hal-set-property \
- ${bindir}/hal-lock \
- ${bindir}/hal-is-caller-locked-out \
- ${bindir}/hal-disable-polling \
- ${sbindir} \
- ${libdir}/libhal.so.* \
- ${libdir}/libhal-storage.so.* \
- ${libdir}/hal \
- ${libexecdir} \
- ${datadir}/hal/fdi \
- ${datadir}/hal/scripts"
diff --git a/packages/hal/ohm/fix_configure.patch b/packages/hal/ohm/fix_configure.patch
deleted file mode 100644
index e4b774e785..0000000000
--- a/packages/hal/ohm/fix_configure.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Index: git/configure.in
-===================================================================
---- git.orig/configure.in 2007-12-19 13:43:52.000000000 +0000
-+++ git/configure.in 2008-03-06 23:59:57.000000000 +0000
-@@ -201,9 +201,6 @@
- # Like AC_CHECK_HEADER, but it uses the already-computed -I directories.
- AC_DEFUN(AC_CHECK_X_HEADER, [
- ac_save_CPPFLAGS="$CPPFLAGS"
-- if test \! -z "$includedir" ; then
-- CPPFLAGS="$CPPFLAGS -I$includedir"
-- fi
- CPPFLAGS="$CPPFLAGS $X_CFLAGS"
- AC_CHECK_HEADER([$1],[$2],[$3],[$4])
- CPPFLAGS="$ac_save_CPPFLAGS"])
-@@ -211,9 +208,6 @@
- # Like AC_TRY_COMPILE, but it uses the already-computed -I directories.
- AC_DEFUN(AC_TRY_X_COMPILE, [
- ac_save_CPPFLAGS="$CPPFLAGS"
-- if test \! -z "$includedir" ; then
-- CPPFLAGS="$CPPFLAGS -I$includedir"
-- fi
- CPPFLAGS="$CPPFLAGS $X_CFLAGS"
- AC_TRY_COMPILE([$1], [$2], [$3], [$4])
- CPPFLAGS="$ac_save_CPPFLAGS"])
-@@ -224,14 +218,8 @@
- ac_save_CPPFLAGS="$CPPFLAGS"
- ac_save_LDFLAGS="$LDFLAGS"
- # ac_save_LIBS="$LIBS"
-- if test \! -z "$includedir" ; then
-- CPPFLAGS="$CPPFLAGS -I$includedir"
-- fi
- # note: $X_CFLAGS includes $x_includes
- CPPFLAGS="$CPPFLAGS $X_CFLAGS"
-- if test \! -z "$libdir" ; then
-- LDFLAGS="$LDFLAGS -L$libdir"
-- fi
- # note: $X_LIBS includes $x_libraries
- LDFLAGS="$LDFLAGS $ALL_X_LIBS"
- AC_CHECK_LIB([$1], [$2], [$3], [$4], [$5])
diff --git a/packages/hal/ohm_git.bb b/packages/hal/ohm_git.bb
deleted file mode 100644
index ffdbb07b88..0000000000
--- a/packages/hal/ohm_git.bb
+++ /dev/null
@@ -1,45 +0,0 @@
-DESCRIPTION = "Open Hardware Manager"
-HOMEPAGE = "http://freedesktop.org/Software/ohm"
-LICENSE = "LGPL"
-
-DEPENDS = "gtk+ dbus-glib intltool-native hal"
-RDEPENDS_${PN} += "udev hal-info"
-SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git \
- file://fix_configure.patch;patch=1"
-
-SRCREV = "edfe25d49d67884bf004de7ae0724c162bb5e65e"
-PV = "0.1.2+${PR}+gitr${SRCREV}"
-PE = "1"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--with-distro=debian \
- --without-xauth \
- --disable-gtk-doc \
- --disable-docbook-docs"
-
-do_configure_prepend() {
- touch gtk-doc.make
-}
-
-OE_LT_RPATH_ALLOW=":${libdir}/libohm:"
-OE_LT_RPATH_ALLOW[export]="1"
-
-PACKAGES =+ "libohm ohm-plugin-x11"
-
-FILES_${PN}-dev += "${libdir}/ohm/*.a"
-
-FILES_${PN} = "${sysconfdir} \
- ${bindir}/* \
- ${sbindir}/* \
- ${libdir}/ohm/*.so \
- "
-
-FILES_libohm = "${libdir}/libohm.so.*"
-FILES_ohm-plugin-x11 = "${libdir}/ohm/libohm_x*.so \
- ${libdir}/ohm/libohm_idle.so \
- ${sysconfdir}/ohm/plugins.d/x* \
- ${sysconfdir}/ohm/plugins.d/idle* \
- "