summaryrefslogtreecommitdiff
path: root/packages/hal/hal_0.5.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/hal/hal_0.5.8.1.bb')
-rw-r--r--packages/hal/hal_0.5.8.1.bb75
1 files changed, 0 insertions, 75 deletions
diff --git a/packages/hal/hal_0.5.8.1.bb b/packages/hal/hal_0.5.8.1.bb
deleted file mode 100644
index d0b888192c..0000000000
--- a/packages/hal/hal_0.5.8.1.bb
+++ /dev/null
@@ -1,75 +0,0 @@
-require hal.inc
-
-DEPENDS = "dbus-glib udev intltool expat libusb"
-RDEPENDS += "udev"
-#RDEPENDS_hal-device-manager = "python hal python-pygnome"
-RRECOMMENDS = "udev-utils"
-
-PR = "r2"
-
-SRC_URI += "file://99_hal"
-
-EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
- --with-expat=${STAGING_LIBDIR}/.. \
- --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
- --with-hotplug=${sysconfdir}/hotplug.d \
- --disable-docbook-docs \
- --disable-policy-kit \
- "
-
-do_install_append() {
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
-}
-
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_LIBDIR}
- install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
- install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
-}
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-pkg_postinst_hal () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- /etc/init.d/populate-volatile.sh update
-
- grep haldaemon /etc/group || addgroup haldaemon
- grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-pkg_postrm_hal () {
- deluser haldaemon || true
- delgroup haldaemon || true
-}
-
-#PACKAGES += "hal-device-manager"
-
-#FILES_hal-device-manager = " \
-# ${datadir}/hal/device-manager/ \
-# ${bindir}/hal-device-manager"
-
-FILES_${PN} = "${sysconfdir} \
- ${bindir}/lshal \
- ${bindir}/hal-find-by-capability \
- ${bindir}/hal-find-by-property \
- ${bindir}/hal-device \
- ${bindir}/hal-get-property \
- ${bindir}/hal-set-property \
- ${sbindir} \
- ${libdir}/libhal.so* \
- ${libdir}/libhal-storage.so* \
- ${libdir}/hal \
- ${libexecdir} \
- ${datadir}/hal/fdi \
- ${datadir}/hal/scripts"